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Part 1  Introduction 

The Allworx System Software Version 8.1 is an application for Allworx administrators to configure and 
manage Allworx servers with the following settings:

• Phone System

• Network

• Servers

• Reports

• Maintenance

The Allworx server web administration interface has built-in descriptions, help, and tips on many of its 
pages. Additional documents related to Allworx System Software and Allworx applications: 

• Allworx User’s Guide, Release 8.1

• Allworx System Software Release Notes, Release 8.1

• Allworx Advanced Multi-Site Guide, Release 8.1

• Allworx Phone Guides

• Multi-Tech FaxFinder Setup Application Notes 8.1

• Allworx SNMP User’s Guide

• Allworx Interact and Interact Professional User’s Guide

• Allworx Reach User’s Guide

• Allworx OfficeSafe Operations Guide

• Allworx View Installation Guide

These publications as well as System Administrator’s Guides for Releases 8.0 and lower are available 
on the Allworx Partner Portal (www.allworxportal.com).

1.1 Who Should Read this Guide
This guide is for Allworx administrators that:

• install and maintain Allworx servers.

• understand computer networking and basic telephony.

• completed the Allworx Partner technical training. 

http://www.allworxportal.com
www.allworxportal.com
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1.2 Guide Organization
The Allworx Server Administrator’s Guide describes:

• requirements necessary to perform the operations described within the document.

• steps necessary to install, log in, and configure the Allworx server. To view the mounting, 
electrical connections, and input/out accessories of the Allworx server, see the Allworx Server 
Installation Guide specific to the Allworx server model.

• steps necessary to manage each web administration page to configure the Allworx server. 
Each web administration page is a separate chapter within this document.

1.3 Equipment Requirements
The table below is a complete list of equipment and requirements necessary to perform all operations 
identified in this Administrator’s Guide. 

Equipment Requirements

PC •  Running OS (with latest service pack).

•  RAM minimum: 2 GB.
•  Monitor resolution: 1024 x 768 (XGA).
•  Internet connection.

Allworx server •  Allworx System Software Version 8.1.
•  Administration permissions and passwords for each Allworx server.
•  IP Address or DNS name of each Allworx server.

Allworx Partner Portal •  Login permissions and password.

Supported Web Browsers •  Microsoft Edge
•  Microsoft Internet Explorer 11 (latest release with auto upgrade enabled).
•  Google Chrome (Latest Release).
•  Mozilla Firefox (Latest Release).

Allworx Server Installation Guide The guide is specific to the Allworx server model that describes the mounting, electrical 
connections, and input/output accessories of the Allworx Server. This guide is available at: https://
allworxportal.com/.

Allworx System User Guide The guide is specific to My Allworx Manager and describes the features within the application. This 
guide is available at: https://allworxportal.com/.

Allworx Multi-Site Guide The guide describes the advanced set up configurations for multi-site networks. This guide is 
available at: https://allworxportal.com/.

•  Windows 7 32-bit SP1 •  Windows 8/8.1 32-bit •  Windows 10 32-bit

•  Windows 7 64-bit SP1 •  Windows 8/8.1 64-bit •  Windows 10 64-bit

https://allworxportal.com/
https://allworxportal.com/
https://allworxportal.com/
https://allworxportal.com/
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1.4 Prerequisites
Each chapter of this document includes a Prerequisites table:

1.5 Roles
The available user roles include:

• Server Administrator: predefined system administrator with access to manage all functions of 
the server. The Allworx Server Administrator assigns roles, manages the server administrative 
functions, manages day-to-day phone system settings, manages the network and VoIP settings, 
and initiates system backups and/or restarts.

• System Administrator: access to manage the administrative functions of the server. The user 
permission setting does not enable this role to change the password of the Allworx Server 
Administrator. However, the Allworx Server Administrator can change the password of the 
System Administrator.

• Phone Administrator: access to manage day-to-day phone system settings including changes 
to system recordings as well as adding, changing, and deleting users, extensions, and 
handsets.

• Network Administrator: access to manage the Network and VoIP settings, as well as SIP 
proxies and SIP gateways outside lines.

• Support Technician: access to initiate system backups and restarts as well as managing 
logging operations. 

Access Permissions Identifies features that users with assigned roles can access and manage. The Allworx Server 
Administrator can assign roles to a specific user on the Phone System > Users page. See 
“Roles” on page 3 for more information.

Required Feature Key Identifies add-on features that are available as a separate purchase from the base feature set for 
Allworx servers. See “Feature Keys” on page 217 for more information.

Note: To enable one user to have roles on different servers in a multi-site network, the Allworx administrator must create 
separate user accounts for the user on each server, and then assign the roles on each server. Use different 
usernames for each user account.

Note: The Allworx administrator can assign users to manage queue and Auto Attendant recordings. See “User Template 
Settings” on page 136 for more information.

Note: The Allworx administrator can assign users to manage individual queue settings or queue supervisor. See “User 
Template Settings” on page 136 for more information.
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Part 2  Allworx Server Set Up

The Allworx Server Set Up section describes the 
installation and configuration procedures for the 
Allworx server. Additionally, this section describes 
the Allworx System Software compatibility of each 
Allworx server. 

2.1 Allworx System Software Compatibility

2.2 Allworx Server Features and Compatibility

Allworx Server Model Connect Server Model

6x12 6x 24x 48x 320 324 530 536 731

Allworx System Software

System Software 7.7 and lower X X X X

System Software 8.0 X X X X X X X X X

System Software 8.1 X X X X X X X X

Allworx Server 
Model

Connect Server Model

6x12 6x 48x 320 324 530 536 731

Hardware Support

Enhanced Diagnostic Port X X X X X

Network Ports 2 2 2 2 2 3 3 3

External USB Disk Drive Support X X X

Supported Web Browser

Microsoft Internet Explorer 11 X X X X X X X X

Google Chrome (latest version) X X X X X X X X

Mozilla Firefox (latest version) X X X X X X X X

Microsoft Edge X X X X X X X X

Prerequisites

Access Permissions Allworx Server Administrator
Allworx System Administrator

Feature Key Required No
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Allworx System Software 8.1 Support

Five- and six-digit dialing5 X X X X X X X X

Number of Auto Attendants Supported 9 16 32 9 9 16 16 32

Supports 2000 DID Blocks X X X X X X X X

Telnet Support X X X

Allworx System Software 8.0 Support

SSH Support X X X X X

Allworx Server Features

FXO Ports 6 6 3 0 4 0 6 2

FXS Ports 5 5 2 2 2 2 2 2

T1 Ports 2 0 0 0 0 1

Base System Extensions Limit 12 30 48 12 12 30 30 30

Maximum System Extensions Limit1 12 60 250 20 20 50 50 180

Base Users 12 30 48 12 12 30 30 30

Maximum Users1 12 60 250 20 20 50 50 180

Maximum Handsets 24 120 500 40 40 100 100 360

Maximum External Calls3 12 12 30 30 60

Conference Bridges1 1 1 4 1 1 1 1 4

Maximum Total Bridge Users 8 8 8 8 8 8 8 30

Maximum Calls in All Queues1 16 16 64 12 12 30 30 60

Maximum Calls per Queue1 8 8 16 12 12 30 30 60

Maximum Number of Queues1 10 10 10 10 10 10 10 10

Automatic Call Distribution1 No Yes Yes No No Yes Yes Yes

Auto Attendant Ports 9 9 9 4 4 8 8 16

Multi-Site Controller1 No Yes Yes Yes Yes Yes Yes Yes

Allworx Server 
Model

Connect Server Model

6x12 6x 48x 320 324 530 536 731
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2.3 Install and Configure the Allworx Server

To install the Allworx server:
1. Use the Allworx Server Installation Guide for mounting, electrical connections, and optional 

input/output accessories specific to the Allworx server model.

Maximum Servers in a Multi-Site Network 99 99 99 99 99 99 99

Maximum Multi-Site System Extensions4 1000 1000 1000 1000 1000 1000 1000 1000

Maximum Multi-Site Users4 1000 1000 1000 1000 1000 1000 1000 1000

Voicemail Ports 8 8 16 4 4 8 8 15

Voicemail Limits (number of messages per user)6 1,000 1,000 1,000 1,000 1,000 1,000 1,000 1,000

Voicemail Limits (amount of time per user)6 140 hr 140 hr 140 hr 50 min 50 min 50 min 50 min 50 min

Activation Required X X X X X

Secure Web Page Access X X X X X

Enhanced Codec Support X X X X X

SIP-Video Pass-Through 2 X X X X X

PPPoE X X X

1 Requires an Allworx software feature key. 
2 A SIP endpoint that supports video can register with the Allworx Connect server, and it supports negotiation of video 

calls with that device. The Allworx Connect server supports up to two video sessions and one audio session per call. 
The Allworx Connect server supported codecs are: H263, H264, and MP4V-ES.

3 The total external SIP calls are limited to the Maximum External Calls less any TDM (FXO ports and T1 channels) 
lines configured.

4 The total number of Multi-Site Users and Multi-Site System Extensions varies upon the maximum users licensed on 
each Allworx server.

5 Compatible with Reach for Android/Reach for iOS Version 2.0.7 (minimum) and Interact/ Interact Professional 2.3 
(minimum).

6 There is a practical system limit on 6x, 6x 12, and 48x servers because the system disk can become full before all 
users have met the personal limit. On Connect servers, even if all users max out the limits, the disk will not be full.

Allworx Server 
Model

Connect Server Model

6x12 6x 48x 320 324 530 536 731
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2. Plug the PC into the server LAN port (ETH0 on Connect servers), and set up the network 
interface on the PC to obtain an IP address automatically (using DHCP).

3. Verify the PC has an IP address on the 192.168.2.x network. It may be necessary to release 
and renew the IP address on the PC to get an address from the server.

a. Click Start and type cmd in the Search field. A command window opens. Type the 
following to clear the PC current IP settings:

b. Press enter to clear the PC current IP settings. Type the following to obtain a new IP 
Address:

c. Press enter.

4. Use a web browser via the LAN interface on TCP port 8080 (8443 on Connect servers) to 
access the administrative interface of the Allworx server. Enter:

5. Log in to the web admin page using admin as the username and password. The Allworx server 
admin page displays the factory default settings at first log in and displays the customized 
settings with any subsequent log in. The server is ready for configuration.

Windows 7 1.  Click Start and navigate to the Control Panel.
2.  Locate View by: select Small Icons from the drop-down list.
3.  Double-click Network and Sharing Center > Change adapter settings (left column).
4.  Right-click Local Area Connection > Properties.
NOTE: For wireless computers, select Wireless Network Connection > Properties.
5.  Click Internet Protocol Version 4 (TCP/IPv4) > Properties.
6.  Click Obtain an IP Address automatically and Obtain DNS server address automatically.
7.  Click OK to save the changes.

Windows 8 / 
Windows 10

1.  Click Start and navigate to the Control Panel. In the search box, type adapter.
2.  Click Network and Sharing Center, and then click View network connections.
3.  Locate and right-click the connection to change, and then click Properties. 
4.  (Optional) If prompted, enter the administrator credentials and confirm.
5.  Click the Networking tab, and then click Internet Protocol Version 4 (TCP/IPv4) or Internet Protocol 

Version 6 (TCP/IPv6) > Properties. Specify the address settings:

ipconfig /release 

ipconfig /renew

Allworx 6x, 6x12, 48x server http://192.168.2.254:8080

Connect servers https://192.168.2.254:8443 (Entering a URL of http://192.168.2.254:8080 
redirects to https://192.168.2.254:8443.)

IPv4 Click Obtain an IP address automatically, and then click OK.

IP v6 Click Obtain an IPv6 address automatically, and then click OK.
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To configure the Allworx server: 
1. Log in to the web admin page using admin as the username and password.

2. Locate the left side of the web admin page and click Install Checklist.

3. Follow the order of the steps of the Install Checklist for a successful configuration. Check the 
box on the web admin page next to each step to avoid duplication. The Install Checklist table 
below links to the appropriate System Administrator’s Guide chapter to configure the server.

Install Checklist

Step Description Allworx Server Admin Guide Link

1 Set time on server. “Time” on page 235

2 48x and Connect 731 servers only: Program Digital Lines. If 
connected to T1 interface(s), configure the system to match 
the settings obtained from the service provider.

“Digital Lines” on page 147

3 Program Network configuration:
1.  Network Mode
2.  VLAN settings
3.  Public Interface
4.  Gateway
5.  Server Host Name
6.  Domain Name
7.  Firewall Settings

“Configuration” on page 143

4 Enable/Disable DHCP server. “DHCP” on page 169

5 Set DNS server addresses. “DNS” on page 171

6 Optional: Configure Port Expanders “Px Expanders and Remote Phones” on page 157

7 Enable VPN, if required. “Virtual Private Network (VPN)” on page 165

8 Restart server for settings to take effect.
NOTE: After restarting the server, close this window, and then 
re-open it after logging into the server.

“Restart / Shutdown” on page 231

9 Activate server with Portal, if required. “Registration” on page 229

10 Download/enter the required Feature Keys. “Feature Keys” on page 217

11 Update the Allworx server to the latest software release, if 
required.

“Update” on page 241

12 Optional: Configure use of Primary and Secondary 
Languages.

“Languages” on page 87

13 Define the Internal Extension Length and Internal Dial Plan. “Manage the Internal Extension Length” on page 37
“To manage the Internal Dial Plan:” on page 39

14 Add users. Associate handsets to users, if available. “Manage Users” on page 131
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15 Add handsets. Add the Analog and SIP Handsets using Plug 
and Play or manual programming. Once programmed, check 
the phone by dialing #7 from any Auto Attendant Main Menu.

“Manage Analog Handsets” on page 61
“Manage Handsets” on page 63

16 If live answering inbound calls, create a system extension 
and preferred call routes. Use a Ring Group if live answer 
with line appearances on Allworx handsets is required.
If different sets of handsets need to ring depending on the 
incoming line, give a descriptive name to a Ring Group, 
create an extension for each incoming line, and route the call 
to the Ring Group.;
Configure the Allworx handsets later to use the Ring Group(s) 
defined in this step.

“Add New Extension” on page 55
“Ring Groups” on page 111

17 Define additional system extensions used for routing to 
groups or places such as conference rooms.

“Add New Extension” on page 55

18 Optional: Create and define Call Queues “Call Queues/ACD” on page 25

19 Optional: Define Paging Zones. Define the Paging Zones, 
add Line Out or Handsets to the required zones.

“Paging” on page 109

20 Add/Configure Outside Lines to phone system (standard FXO 
loops, SIP Gateways, SIP Proxies). Enable line appearances, 
if required and define call routes.

“Outside Lines” on page 97

21 Configure Allworx handsets by defining the programmable 
function keys (PFKs). 

“Manage the Programmable Function Keys (PFKs)” on 
page 67

22 Optional: Save the Allworx handset configuration as a 
template, and then apply to remaining Allworx handsets. 
Modify individual handset configurations as required.

“Manage Handset Templates” on page 78

23 Program operator route (0). “Manage Call Routes” on page 57

24 Record Auto Attendant and Call Queue prompts, if required. “Custom Recordings” on page 213

25 Set the Dial Plan for the system. Create special Service 
Groups, if required, and then define the Dialing Rules.

“Dial Plan” on page 37

26 Check handset permissions to access outside resources, if 
required.

“Handsets” on page 61

27 Enter business contact information and schedules. “Contact Information” on page 35
“Schedules” on page 121

28 Check system:
1.  Make 3 to 4 inbound calls (e.g., use cell phone to call the 

Allworx server).
2.  Make outbound local and long distance calls to several 

area codes.

N/A

Step Description Allworx Server Admin Guide Link
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29 Configure Email server.
1.  Leave incoming WAN email forwarding disabled, unless 

server is within firewall!
2.  Enter alternate email domains.
3.  Enter spam blocking services (e.g., spamhaus.org)

“Email” on page 173

30 Enable VPN for additional users, if required. “Manage Users” on page 131

31 Create aliases for email/voicemail distribution lists. “Message Aliases” on page 91

32 Set up and perform a backup using OfficeSafe “Backup” on page 211

33 Deliver user documentation (Welcome sheet, Allworx User’s 
Guide, and Allworx Phone Guides) and conduct basic training 
for each user.

Step Description Allworx Server Admin Guide Link
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Part 3  Phone System 

The Phone System sections describe the setup and management of the Allworx server specific to the 
business requirements. Each chapter explains:

• necessary access permissions and feature keys, 

• necessary equipment to perform the procedure, and

• necessary procedures to manage the Allworx server feature.

The various Phone System pages on the server web admin site enable the Allworx administrator to set 
up, configure, and manage the settings of the following features:

• Audit PIN Codes

• Auto Attendants

• Call Park

• Call Queues / ACD

• Conference Center

• Contact Information

• Dial Plan

• Emergency Caller ID

• Extensions

• Handsets

• Languages

• Message Aliases

• Music On Hold

• Outside Lines

• Paging

• Ring Groups

• Roles

• Schedules

• Shared Call Appearances

• Speed Dial

• Users
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Chapter 3 Audit PIN Code

Audit PIN Code supports call tagging and 
controls outside line access. The Audit PIN 
Code does not support outside line access when 
using a Line Appearance PFK.

Example:

A company charges customers for the tolls and 
time spent on each call. 

To use tagging to properly bill each customer: 

• The Allworx administrator assigns each project a unique PIN code.

• The phone user dials 781 + <PIN code specific to the project> + <phone number> to access the 
outside line to work with the customer.

• The Accounting Department uses the PIN code from the call records to bill each customer.

To specify the number of digits and the service group used by the Audit PIN Code, see “Manage the 
Services” on page 46 for more information. 

To manage an Audit PIN code: 
1. Log in to the Allworx server admin page, navigate to Phone System > Audit PIN Codes, and 

locate the Audit PIN Codes section.

2. Click one of the following links: 

To enable or disable the Audit PIN Code Verification: 
1. Log in to the Allworx server admin page, navigate to Phone System > Audit PIN Codes.

2. Locate the Audit Pin Code Configuration section and click modify.

1. Extensions may vary per system. If using a non-default Internal Dial Plan, consult the My Allworx Manager 
Phone Functions tab to determine what extensions to use for the corresponding feature.

add new 
PIN code

Enter the new PIN code and description in the respective fields, and then Click Add to save the 
changes or Cancel to disregard the request.
To change the PIN code length, see “Manage the Services” on page 46

Modify Change the current PIN code and description. Click Update to save the changes or Cancel to disregard 
the request.

Delete The server removes the PIN code from the list. 
1.  Confirm this is the PIN code to remove.
2.  Click Delete to remove the user from the list or Cancel to disregard the change.

Prerequisites

Access Permissions Allworx Server Administrator
Allworx System Administrator
Phone Administrator role

Feature Key Required No
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3. Select one of the following options from the drop-down list: 

4. Click the Update button to save changes or Cancel to disregard the request.

 

Enabled The Allworx server verifies that the PIN code is the correct length and loaded in the PIN code list 
on the Allworx server.

Disabled The Allworx server only checks for the correct PIN code length.

Click here to return to the “Install Checklist” .
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Chapter 4 Auto Attendants

Auto Attendants answer incoming calls 
automatically, and then directs the callers to the 
appropriate person or department using the 
dial-by-name or company phone directory.

Each Auto Attendant supports the Open and 
Closed greeting and up to seven custom 
greetings and one custom message for each 
Auto Attendant with a length limit of 15 minutes 
per greeting or message. Users with permissions to record and manage custom Auto Attendant 
greetings and messages and can assign each Auto Attendant to a different schedule. See “Number of 
Auto Attendants Supported” on page 6 for the number of Auto Attendants each Allworx server 
supports.

Example: use one Auto Attendant to answer calls for Sales and another Auto Attendant to answer calls 
for Support. Each Auto Attendant plays a greeting specific to the assigned department.

4.1 Setup Checklist
Follow the order of the steps to successfully setup the Auto Attendant.

4.2 Configure the Auto Attendant

To configure an Auto Attendant:
1. Log in to the Allworx server admin page, navigate to Phone System > Auto Attendants. The 

Auto Attendants display with the assigned extension (4301 to 43xx1 - where xx is the maximum 
number of Auto Attendants supported by the Allworx server) and Auto Attendant number. 

Step Description Installation Guide Link

1 Configure the Auto Attendant.  “Configure the Auto Attendant” on page 17

2 Create an extension and/or assign the Auto Attendant to an outside 
line, and then update the call route to the Auto Attendant.

“Extensions” on page 55 or “Manage Analog 
Central Office (CO) Lines” on page 98

3 Record the custom greetings and messages for each Auto Attendant. “Record Auto Attendant Greetings and 
Messages” on page 20

4 Configure the Auto Attendant greetings to change, per time of day. “Schedules” on page 121 

1. Extensions may vary per system. If using a non-default Internal Dial Plan, consult the My Allworx Manager 
Phone Functions tab to determine what extensions to use for the corresponding feature.

Prerequisites

Access 
Permissions

Allworx Server Administrator
Allworx System Administrator
Phone Administrator role

Feature Key 
Required

No
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2. Locate the Auto Attendant and click the additional information arrow , if necessary. Click one 
of the following links: 

3. Click Update to save the settings or Cancel to disregard the request. 

Auto Attendant Configuration Settings

modify Change the Auto Attendant configuration. Select the settings to update in the drop-down list. See “Auto 
Attendant Configuration Settings” on page 18 for more settings information.

reset Change the configuration to the factory defaults. Select an option:
•  Reset to default settings, but keep all custom recordings
•  Delete all custom recordings
•  Reset to default settings AND delete all custom recordings
Click Reset to update the settings or Cancel to leave the settings as is.

Features and Prompts

Description Enter description of the Auto Attendant.

Schedule Select the schedule created for switching greetings. See “Schedules” on page 121 for more information.

Include Remote 
Users

For multi-site networks - includes users from other sites in Dial-By-Name. 
•  Enabled
•  Disabled (Default)

Dial-By-Name Menu 
(#1)

Enable callers to select an Allworx user by typing the user’s name based on the setting in the Dial-By-Name 
Spell Option field. 
•  Enabled
•  Disabled (Default)

Dial-By-Name 
Prompt

Prompt: Press 1 to dial by name.
•  Do not play
•  Play (Default)

Dial-By-Name Spell 
Options

Select the spelling method for the Dial-By-Name option.
•  spell first or last name
•  spell last name
•  spell first name

Dial-By Directory 
Menu (#2)

Enable the caller to listen to a list of users and extensions, and then enter an extension.
•  Disabled
•  Enabled (Default)
Note: The system automatically disables Dial-By-Directory if there are more than 50 users assigned to the Auto 
Attendant

Dial-By-Directory 
Prompt

Prompt: Press 2 for a listing of all users and extensions.
•  Do not play
•  Play (default)
Note: The system automatically disables Dial-By-Directory if there are more than 50 users assigned to the Auto 
Attendant.

Dial-By-Directory 
List Order

Controls the order in which the directory is spoken.
•  List in extension order
•  List in name order

Dial It Now Prompt Prompt: If you know your party's extension you may dial it now.
•  Do not play
•  Play (default)
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Repeat Menu 
Behavior

Identifies what repeats when requested by the caller.
•  replay Custom Message only
•  replay Greeting Only
•  replay Greeting and Custom Message

Repeat Options 
Prompt

Prompt: Press * to listen to these choices again.
•  Do not play
•  Play (default)

Speed Dial Numbers (support for dialing 350-399, 34000-34999* from main menu)
(listed as *250-*299 AND *24000-*24999)
•  Allowed
•  Not Allowed (default)

Day Mode Menu 
Shortcuts

Night Mode Menu 
Shortcuts

Identifies if users can dial the Menu Shortcuts in Day or Night Mode for each Auto Attendant. 
•  Allowed (default)
•  Not Allowed 

Day Mode Internal 
Call Restriction

Night Mode Internal 
Call Restriction

Restricts what internal calls can be made from each Auto Attendant based on the day mode. 
•  Auto Attendant Default - blocks all calls except the following (examples are from the Default Dial Plan, 3-digit, 

not using extension mode):

•  Operator (x0)

•  Conference Center (x408)

•  Other Auto Attendants (x400, x43n)

•  Call Queues (x44n)

•  Message Center (x404)

•  User and System Extensions (x1nn, x2nn)

•  Speed Dial 3 and 5 digits (x350-300, x34nnn)

•  Leave a message (x3 + user extension)

•  Message Center for user (x6 + user extension) 

•  <List of available restrictions>

After Select the number of seconds (1 to 15) with no input, and then indicate the next step.
•  Replay Menu
•  Transfer to <select an extension/user>

Menu Shortcuts

The Allworx administrator can configure the Auto Attendant to enable dialing digits 0 through 9 as single-digit Menu Shortcuts. Dialing 
the digit transfers a caller to a designated extension, another Auto Attendant, Dial-By-Directory, or Dial-By-Name. 

To use the Dial-by-name or Dial-By-Directory option, enable the option and set the Dial-By-Name or Dial-By-Directory Prompts to Do 
not play.

Day Mode Menu 
Shortcuts

Night Mode Menu 
Shortcuts

Select an option from the drop-down list:
•  disabled - turns off the Menu Shortcuts option.
•  enabled - select an extension in the drop-down list for the corresponding digit. The default assignment is ‘0 – 

operator’* and does not provide the option of Dial-By-Directory or Dial-By-Name.
•  use Day Mode - the Menu Shortcuts are the same for both Day and Night Mode. Available on Night Mode 

Menu Shortcuts only.

* Extensions may vary per system. If using a non-default Internal Dial Plan, consult the My Allworx Manager Phone Functions tab to 
determine what extensions to use for the corresponding feature.
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4.3 Record Auto Attendant Greetings and Messages
Auto Attendants play built-in or custom greetings and messages. Users with Recording Manager 
permissions can record the greetings Offline up to 15 minutes in length, and then import the greetings 
into the system see “To import/export greetings and messages:” on page 21 for more information. Or, 
record up to nine greetings and one custom message for each Auto Attendant using the Message 
Center on the phone. 

To enable Recording Manager permissions, see “To modify or delete existing users:” on page 133 and 
update the following settings: 

The Allworx system plays the greetings, messages, and prompts in this order: 

• Business schedule greeting – for the current time of day (See “Manage the Greetings” on 
page 121.).

• Custom message (This does NOT change based on the business schedule)
• Other selected, built-in prompts.

To record a new greeting / custom message or manage the Auto Attendant schedule: 

1. Dial the Message Center extension (4041). 

2. Log in using the assigned extension and PIN code. 

3. Press 9 to manage greetings, and then press 1 to manage the Auto Attendant.

Roles Select System or Phone Administrator for access to Auto Attendants.

Recording Manager Select the specific Auto Attendants for the user.

Note: When routing a caller to an Auto Attendant after playing all prompts, if the caller presses * to hear the selections 
again, the system skips the business schedule greeting.

Note: To modify the greetings (Auto Attendant) or custom messages, the user (not the administrator) must have Allworx 
System Administrator or Allworx Phone Administrator role permissions.

Note: Allworx does not recommend using an Reach handset to record new greetings or queue messages as the ability of 
the server to record greetings is intolerant of network packet loss. As a result, recordings made via lossy networks 
may have impaired quality. Local or wired networks are best for making these recordings. 

Note: For systems with Dual Language Support: Users cannot change languages within the Message Center. To record 
new messages in a second language, select an option:
•  Setup an account configured for the secondary language, and then record the greetings using that account.
•  Temporarily modify the user’s default language to match the secondary language of the system.

1. Extensions may vary per system. If using a non-default Internal Dial Plan, consult the My Allworx Manager 
Phone Functions tab to determine what extensions to use for the corresponding feature.
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4. Press the number corresponding to the Auto Attendant (4301 to 43xx1 - where xx is the 
maximum number of Auto Attendants supported by the Allworx server).

5. Press 1 to manage the greetings for the selected Auto Attendant.

a. Enter the number (0 through 8) of the greeting to record.

b. Press 2 to record a new greeting. 

c. Record the new greeting and press ‘#’ when complete.

d. Press 1 to save the greeting.

6. Press 1 to record additional greetings or press # to go to the previous menu to manage other 
Auto Attendants.

7. Press 2 to manage the custom message for the Auto Attendant.

To import/export greetings and messages:
Import the greetings and messages recorded off-line onto the Allworx system. The files use a specific 
internal format and have a specific file name format - Example: aa#x.snd. The filename for the status 
message for Auto Attendant 2 is “aa20.snd”. 

See “Custom Recordings” on page 213 for more information.

To manage the Auto Attendant schedule:
This option is only available to users with recording manager permissions on Allworx systems.

1. Log in to the Audio Message Center and press 9 on the numeric keypad.

1. Extensions may vary per system. If using a non-default Internal Dial Plan, consult the My Allworx Manager 
Phone Functions tab to determine what extensions to use for the corresponding feature.

Greeting Sample Script

Greeting 0 
(Open)

Welcome to <your company name>, your best source for <product>. 
Dial 1 for store hours and directions. Dial 2 for Sales. Dial 3 for Service. Dial 0 to reach the operator.

Greeting 1 
(Closed)

Welcome to <your company name>, your best source for <product>. We are currently closed, but we will re-
open at <opening time>. Our hours are <hours of operation>. If you know your party’s extension, you may 
dial it now. You may also leave a message in our general mailbox at extension <number>.

Custom <Your company name> is the premier provider of <products>. We specialize in <specialty>. Our latest 
product is...

Digit Description

# Replace with the Auto Attendant number 1 through 9

x Replace with greeting number (0 through 9 - Use '0' for the Open greeting, '1' closed greeting) or “c” for Custom Message. 
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2. Select option 1 (To manage the Auto Attendant), and then select the Auto Attendant (4301 to 

43xx1 - where xx is the maximum number of Auto Attendants supported by the Allworx server) 
number to change.

3. Select option 3 (To manage the schedule). The following message plays, “The Auto Attendant 
is using schedule <number>. To select a different schedule, enter the schedule number 
followed by #.”

4. Enter the schedule number, and then enter the # sign. After successfully selecting a different 
schedule, the user hears, “The Auto Attendant has been changed to use schedule <number>.” 
The Message Center returns to the Manage Auto Attendant Menu.

If selecting a different schedule is unsuccessful, the user hears, “You must enter a valid 
schedule number.” The Message Center returns to the Manage Auto Attendant Schedule 
Menu.

4.4 Assign the Auto Attendant to an Outside Line
The default Auto Attendant determines the setting when selected in the configuration of the outside 
line. To assign the Auto Attendant to an outside line, see “Manage Analog Central Office (CO) Lines” 
on page 98 for more information.

Follow the same procedure for any of the outside lines, including SIP Gateways and SIP Proxies. 

1. Extensions may vary per system. If using a non-default Internal Dial Plan, consult the My Allworx Manager 
Phone Functions tab to determine what extensions to use for the corresponding feature.

Click here to return to the “Install Checklist” .
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Chapter 5 Call Park

Call Park feature places a call on a system wide 
hold via a designated extension number and 
retrieving the same call on any other handset. 

Example: park a call from one office, and then 
walk to another office to retrieve the call. 

Allworx servers support up to 59 parked calls at one time using Parking Orbit extensions between 701 

to 7091 and 4950 to 49991 and assigns the parked call the lowest available Parking Orbit number.

To configure the Parking Orbit: 
1. Log in to the Allworx server admin page, and navigate to Phone System > Call Park. 

2. Click one of the following options: 

3. Click Update to save the changes or Cancel to disregard the request. 

To configure the Allworx IP phone PFKs for parking orbits, see “Manage the Programmable Function 
Keys (PFKs)” on page 67 for more information.

1. Extensions may vary per system. If using a non-default Internal Dial Plan, consult the My Allworx Manager 
Phone Functions tab to determine what extensions to use for the corresponding feature.

Call Park > modify

Timeout (seconds) Enter a value in seconds for the call to timeout. Default is 600 seconds.

After timeout Sends the call to the next stop in the call route. Options include:
•  Transfer caller to handset that parked call, on busy <select an extension from the drop-down 

list>.
•  Transfer caller to extension <select an extension from the drop-down list>. Default is the Default 

Auto Attendant.

Multi-Site Parking > modify

Permit other sites 
to retrieve parked 
calls from this site.

Enables users at other sites to retrieve calls parked in its Parking Orbits. 
•  The server must participate in Multi-Site Parking Orbits. 
All sites that participate share 150 Multi-Site Parking Orbits at extensions between 4800 and 

49491. 
•  See the Allworx Advanced Multi-site User Guide for information on configuring Multi-site parking.
1.  Check the box to enable.
2.  Enter the number of parking orbits to use per site. The Call Park page displays the Number of 

Orbits and the Retrieve # for each site.

Click here to return to the “Install Checklist” .

Prerequisites

Access Permissions Allworx Server Administrator
Allworx System Administrator
Phone Administrator role

Feature Key Required No
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Chapter 6 Call Queues/ACD

Call Queues/ACD distributes calls to a specific 
set of users. 

The Allworx system manages and distributes the 
incoming calls that are too numerous for agents 
to answer immediately in a first-in-first-out order.

Available features:

• Provides feedback to call queues callers:

• greeting plays when calls enter the queue.

• configurable periodic status messages while waiting in the Call Queue.

• ringing for waiting customers to hear, as an alternative to the periodic status messages.

• Using an Allworx IP phone, agents can:

• log in and out of queues.

• receive calls from or answer calls in a queue.

• monitor the status of the queues.

• Configure the maximum wait time for a call before hanging up or transferring to: an Auto 
Attendant, an extension, another queue, or a user’s voicemail.

• Exit the queue at any time by pressing zero. Different exit routes can be set up for each queue.

• Statistics for all queues are available from My Allworx Manager, as an export file and streamed 
to a PC on the network using a TCP streaming port number configured on the Allworx server.

Allworx server Call Queues/ACD support

Note: The Call Queue feature works only with Allworx IP phones, no other manufacturer’s phones support this feature.

Note: Pressing the phone MUTE/DND button does not stop incoming queue calls.

Allworx Server Allworx Connect Server

6x12 6x 48x 320/324 530/536 731

Maximum calls in one queue 8 8 16 12 30 60

Total calls in all queues 16 16 64 12 30 60

Call queues X X X X X X

ACD queues X X X X

Prerequisites

Access Permissions Allworx Server Administrator
Allworx System Administrator
Phone Administrator role

Feature Key Required •  Call Queuing
•  Automatic Call Distribution
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6.1 Setup Checklist
Follow the order of the steps to successfully setup a Call Queue.

6.2 Set Up A Call Queue: Ring All
The Ring-All distribution rings all phones assigned a Queue Appearance PFK logged into the queue 
simultaneously. If there are any callers pending in the queue, all available phones ring according to 
the configured behavior. Caller ID information during inbound ringing and statistics related to specific 
agents is not available.

Step Description Installation Guide Link

Ring All Queue

1 Set the Distribution Mode set to Ring All.  “To manage the Call Queues/ACD settings:” on page 27.

2 Assign Queue Appearance PFK to phones assigned/
available to agents.

 “Manage the Programmable Function Keys (PFKs)” on 
page 67

3 Agents log in to queue with Queue Appearance PFK (by 
default, Queue Appearance PFKs are set to automatically log 
in when the phones start up). 

Allworx Server User Guide

4 (Optional) Assign the Queue Alarm PFK to any Allworx 
phones.

“Manage the Programmable Function Keys (PFKs)” on 
page 67

Automated Call Distribution Queuing

5 Set the distribution mode to one of the ACD features. “To manage the Call Queues/ACD settings:” on page 27

6 Assign a user as queue supervisor (the admin user is a 
queue supervisor).

“User Template Settings” on page 136

7 Queue supervisor assigns agents to single or multiple queues 
in My Allworx Manager. 

Allworx Server User Guide

8 Assign an ACD appearance PFK to the agent Allworx IP 
phone (ACD queuing requires Allworx IP phones).

“Manage the Programmable Function Keys (PFKs)” on 
page 67

9 (optional) Assign the Queue Alarm PFK to any Allworx 
phones.

10 Agents log in to queue with ACD Appearance PFK. Allworx Server User Guide

11 Enable Call Queue supervisor permissions. “User Template Settings” on page 136

All Call Queues

12 Configure calls to route to a Call Queue. “Manage Calls to Route to a Call Queue” on page 30

13 Route the calls using an Auto Attendant to the Call Queue. “Route a Call using Auto Attendant to a Call Queue” on 
page 30

14 View the Call Queue statistics. “Display Queue Statistics” on page 31

15 Record the custom greetings and messages for each queue. “Record Queue Greetings and Messages” on page 31

16 Import the custom greetings/messages for each queue. “Import Greetings and Messages” on page 32
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To place calls directly into the queue:
See “Extensions” on page 55. for more information about the steps below.

1. Create a system extension for each queue, such as a Customer Support system extension. 
Define the call route to immediately transfer calls to the Customer Support queue.

2. Define the call route of the outside line to direct calls to the Customer Support system extension. 

6.3 Set Up An Automated Call Distribution Queue
Automated Call Distribution Queues use any of the other available distribution features, and directs 
each call to a specific agent with an assigned ACD Appearance PFK. The Allworx 6x12 and Connect 
300 series servers do not support ACD queuing. The ACD Call Distribution settings include:

6.4 Manage Call Queues / ACD

To manage the Call Queues/ACD settings:
1. Log in to the server admin page and navigate to Phone System > Call Queues/ACD page.

2. Click one of the Call Queues / ACD options options:

3. Click the more information button ( ) to expand the queue. Click modify. Change the Call 
Queue / ACD settings. See “Call Queue /ACD Settings” on page 28. 

4. Click Update to save the updated Queue Streaming Settings or Cancel to disregard the 
request.

Linear Priority Distribute calls based on a prioritized list of agents. The queue supervisor sets the priority by assigning a unique 
ranking to each agent. As each call comes in, it goes to the available agent with the highest priority ranking.

Sequential 
Round-Robin

Distribute calls in a circular manner to the logged-in agents, and evenly distribute the calls so the agents have 
an opportunity to answer approximately the same number of calls.
•  Maintains a list of available agents. When a call gets to the front of the queue, the next agent on the list 

receives it. When agents log in, they are put at the bottom of the list. 
•  After the last agent on the list receives a call, the distribution option returns to the top of the list. If the agent in 

line to receive the next call is currently busy with another call, the call goes to the next agent on the list. The 
busy agent that missed the call moves down the list of agents to receive the next call when they are available. 

Fairness-Longest 
Idle

Distribute calls to logged-in agents that are idle for the longest time to evenly distribute the calls so that all 
agents spend approximately the same amount of time on calls.
•  Maintains a list of all available agents. When a call gets to the front of the queue, the next agent on the list 

receives it. 
•  Places agents at the top of the list after logging in. After completing a call, the agent moves to the bottom of 

the list. 

manage Provides a short cut to the custom recordings settings played by the Call Queues. See “Custom 
Recordings” on page 213 for more information.

View Provides a short cut to the Languages settings page. See “Languages” on page 87 for more information. 
This feature is only available to Allworx Server or Allworx System Administrators.
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5. Click modify to update the Queue Streaming Settings or the ACD Queue Busy Reasons. Click 
the Update button to save the changes or Cancel to disregard the request. 

Call Queue /ACD Settings

Queue Streaming 
Settings

Monitor the Call Queue statistics in real-time by streaming the data to a client application 
connected to a specified TCP port on the Allworx service LAN interface. 
•  Provides a mechanism for the development of a third party wallboard application. 
•  To set up the streaming queue data:
1.  Set the Queue Streaming field to:

•  Do not stream Call Queue Data

•  Stream Call Queue data

2.  Set the Queue Streaming Port to the appropriate TCP port setting (1 through 65535; the default 
is 16367).

When there is queue activity (e.g. callers enter, are serviced, exit queues, agent logs in or out, 
etc.) the data streams. Each record is a complete XML file. See the Allworx ACD Statistics 
Collection Internet Interface document for a complete definition of the record layout. 

To receive and view this data, use a Telnet application (e.g., HyperTerminal) configured to log 
data from the TCP port configured on the server for ACD data streaming. The client connections 
limit is 16.

ACD Queue Busy 
Reasons

Change the ACD Queue busy reasons. Enter the Queue Busy Reason description in the available 
field, and then restart the server for the changes to take effect.

Description Textual description of the queue (e.g., Sales, Tech Support). The system displays this description 
in other areas (e.g., Statistics, handset display screen, etc).

Distribution Mode - Ring All Select the Call Queue: Ring All option. 

Distribution Mode - ACD Select any option except the Ring All option. 
•  ACD: Fairness - Longest Idle
•  ACD: Linear Priority
•  ACD: Sequential Round Robin

Replay Status Message Enter a value (seconds) between successive status update messages. Entering zero (0) disables 
the status message. 

Maximum Wait Enter a value (minutes) callers can wait in a queue; after exceeding this period the call to the 
beginning of the queue. Entering zero (0) enables the caller to wait without a limit.

When queue answers call Select the option for the caller to hear while waiting in the queue:
•  Play queue prompts
•  Do no play prompts (caller hears ringback)

Queue Depth Alarm Threshold Enter a value (number of calls in the queue) to trigger the Queue Alarm PFK for yellow and red 
alarm levels. Entering zero (0) does not trigger an alarm. 

Wait Time Alarm Threshold Enter a value (seconds) to trigger the Queue Alarm PFK for yellow and red alarm levels.

Hold Music Selection Select the hold music source that callers hear while waiting in the queue from the drop-down list.

When caller leaves queue 
due to

Calls can exit the queue under any of the following conditions:
•  Maximum wait time expired
•  Queue is full
•  Caller presses 0
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To configure the Allworx IP phone:
Configure an Allworx IP phone Programmable Function Key (PFK) as a Queue Appearance. See 
“Manage the Programmable Function Keys (PFKs)” on page 67 for more information. The PFK 
monitors the status of a queue and answer calls in the queue. 

When caller leaves queue 
due to (con’t)

Click the more information arrow and select one of the following routes for each exit conditions:
•  Hang up
•  Transfer to extension <specify extension>
•  Transfer to voicemail for user <specify user>
•  Transfer to Call Queue <specify call queue>

ACD settings - only

Maximum Rings Enter a value (number of rings) agents have to answer a call. If the agent does not answer the call 
before the maximum number of rings, the system sets the agent to unavailable (No Answer), and 
the call returns to the front of the queue. The call rings the next available agent.
NOTE: the system does not log out agents for not answering calls from an ACD queue even while 
on another call.

Wrap Up Time Enter a value (seconds) the agent has available after ending a call before the system makes the 
agent available to receive subsequent ACD queue calls. Agents can dismiss/end the wrap up time 
from the handset. Reboot the agents phones to apply changes to wrap up time.

When no agents are 
logged in*

Select the option for callers entering the queue:
•  Force callers to leave queue immediately
•  Allow callers to wait in queue

When calls are received with 
all agents busy

Select the option for callers when agents are unavailable:
•  Allow callers to enter queue
•  Don’t answer, treat as if caller left queue

When all agents are in 
No Answer state

Select the option for call when all agents are unavailable due to the No Answer state:
•  Force callers to leave queue immediately
•  Allow callers to wait in queue

Last Agent in queue Select the option for the last agent:
•  Is allowed to logout of queue
•  Is NOT allowed to logout of queue
NOTE: If the last agent servicing a queue does not pick up a call within the maximum number of 
rings, the system sets the agent to unavailable (No Answer). Queue Supervisors can log any 
agent out, regardless of this setting.

Distribute calls to busy 
handsets

Select to enable or disable distributing calls to agent handsets that are currently busy with non-
ACD calls. A busy handset is an agent handset any active call.

Play greeting before call 
distribution

Select enabled for calls to wait for the greeting message to complete if an agent is available or 
disabled to distribute calls immediately upon entering the queue. In either case, the messages 
play until the agent picks up the call.

Queue Priority Select a lower number to indicate a higher priority. When an agent is logged into more than one 
queue, the next call comes from the highest priority queue where calls are waiting. 
For example, if the VIP Queue has priority 0 and the Support Queue has priority 3, the agent 
always gets calls from the VIP Queue first. The only time a call from the Support Queue goes to 
the agent is if the VIP Queue has no calls. Queues that have the same priority function the same 
way as previous releases.

Agents Click show to view and assign agents to the Call Queue. Also sets the order of linear priority 
distribution mode. Click hide for no display.
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6.5 Manage Call Supervision
The supervisor presses the Call Supervision PFK, enters an agent extension, and begins supervising 
the call. If the supervisor has a BLF PFK for the agent, press the Call Supervision PFK followed by the 
BLF PFK to initiate the session. There is no indication to the agent that supervision is in progress.

Call supervision is available via a PFK configured on the supervisor’s Allworx phone. See “Manage the 
Programmable Function Keys (PFKs)” on page 67 to configure the handset. Enable the agent phone 
for supervision by modifying the agent Call Supervision setting of the Handset Preference Group. 

6.6 Manage Calls to Route to a Call Queue
Calls enter a queue when routed by an extension. Select a queue for the final call route of an 
extension (refer to this extension as the “queue extension”). Route the incoming calls to the queue 
extension:

• route outside lines directly to the queue extension, see “Manage Call Routes” on page 57.

• configure an Auto Attendant with a shortcut to the queue extension and route incoming calls to 
the Auto Attendant, see Menu Shortcuts in “Auto Attendant Configuration Settings” on page 18.

6.7 Route a Call using Auto Attendant to a Call Queue
Inbound calls come into an Auto Attendant. If configured, the Auto Attendant plays a custom greeting. 
Example: “For Customer Support, press 2.” After pressing 2, the caller hears the queue greeting, and 
the system places the call into the queue.

To configure the Call Routing to an Auto Attendant, and then to a Call Queue:
1. Define the call route of the outside line to direct calls to the Auto Attendant. See “Manage Call 

Routes” on page 57 for more information.

2. Create a Customer Support extension. Define the call route to immediately transfer calls to the 
Customer Support queue. See “Add New Extension” on page 55 for more information.

3. Record an Auto Attendant custom greeting instructing the caller to press 2 to reach Customer 
Support. See “Record Auto Attendant Greetings and Messages” on page 20 for more 
information.

4. Configure the Auto Attendant menu shortcut for digit 2 to transfer calls to the Customer Support 
system extension. See “Auto Attendant Configuration Settings” on page 18 for more 
information.
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6.8 Display Queue Statistics
Allworx ACD Queuing offers a rich variety of statistics to monitor, track, and analyze queue activity. 
The statistics are available in three ways:

• view via My Allworx Manager.

• export to XLS file from My Allworx Manager.

• stream to an external device connected to server.

6.8.1 Display Queue Statistics Report
All users can see the agents of the logged in queues. The statistics are available for queues 
determined by if the queue is a Ring All queue or an ACD queue. See the Allworx Server User Guide 
for report information.

6.8.2 Display Live Calls
To display the live calls from the queue, see “Live Calls” on page 201 for more information.

6.9 Record Queue Greetings and Messages
Call queues play built-in or site-specific greetings and messages. Users with Recording Manager 
permissions can record the greetings Offline, and then import the greetings into the system (see 
“Import Greetings and Messages” on page 32 for more information) or record up to nine (9) greetings 
and one (1) custom message for each Call Queue using the phone through the Message Center. 

To enable Recording Manager permissions, see “To modify or delete existing users:” on page 133 and 
update the Recording Manager setting. Select the specific Call Queue for the user.

To record a new queue greeting and status message: 

1. Dial the Message Center extension, 4041 from the phone.

2. Log in using the assigned Allworx PIN followed by the # sign.

If configuring the system for Dual Language Support, the system associates the new greetings 
and messages with the current language. To record greetings for an alternate language, switch 
languages before proceeding to the next step.

Note: Allworx does not recommend using a Reach handset to record new greetings or queue messages as the ability of the 
server to record greetings is intolerant of network packet loss. As a result, recordings made via lossy networks may 
have impaired quality. Local or wired networks are best for making recordings. 

Note: For systems with Dual Language Support: Users cannot change languages within the Message Center. To record 
new messages in a second language, select an option:
•  Setup an account configured for the secondary language, and then record the greetings using that account.
•  Temporarily modify the user’s default language to match the secondary language of the system.

1. Extensions may vary per system. If you are using a non-default Internal Dial Plan, consult the Phone Features 
tab of the My Allworx Manager page to determine what extensions to use for the corresponding feature.
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3. Dial 9 to manage recordings, and then dial 2 to manage Call Queue.

4. Enter the number of the Call Queue to manage (0 through 9).

5. Dial 1 for the greeting or 2 for the status message.

6. Dial 2 to start recording. Begin speaking after the beep. 

7. Dial # to stop recording and select from the following options:

8. Hang up to end the session.

6.10 Import Greetings and Messages
Import the greetings and messages recorded Offline onto the Allworx system. The files use a specific 
internal format and have a specific file name format - Example: cq#x.snd. The filename for the status 
message for Call Queue 3 is “cq3s.snd”. 

See “Custom Recordings” on page 213 for more information.

Dial Greeting Dial Greeting

1 Manage Call Queue greeting # Return to the Auto Attendant

2 Manage Call Queue status message * Replay the options

Dial Greeting Dial Greeting

1 Save the greeting # Cancel the changes

2 Change the greeting * Replay the options

3 Review the greeting

Format Digit Description

# Replace with a Call Queue number 0 through 9.

x Replace with “g” for greeting or “s” for status message.

Click here to return to the “Install Checklist” .
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Chapter 7 Conference Center

Conference Center enables users to reserve 
conference bridges using My Allworx Manager 
while enforcing password restricted access to the 
conference for attendees.

The Conference Center terminates the call ff the 
conference call extends beyond the scheduled 
end time unless there are other scheduled 
conference calls. 

To manage the conference calls:
1. Log in to the Allworx server admin page, navigate to Phone System > Conference Center. The 

server displays a list of scheduled conferences. 

2. Locate the conference and click one of the following links: 

Server Type Termination

Allworx 6x, 6x12, 
Connect 300 and 500 
series Servers

A scheduled or unscheduled conference currently in use automatically terminates when another scheduled 
conference begins. 
•  An unscheduled conference does not terminate conferences in session. 
•  Supports one active conference at a time.

Allworx 48x, Connect 731 
Servers

When using all conference bridges and a new conference is scheduled to begin, the server terminates the 
unscheduled conference with the oldest start time first. 
•  If none of the unscheduled conferences are in use (i.e., all in-use conferences are scheduled 

conferences), the server terminates the conference farthest past the scheduled duration.
•  Initiation of an unscheduled conference does not terminate conferences in session.

end conference Terminates the in-process conference call.

modify Change the description, password, and moderator. Click Update to save the changes or Cancel to 
disregard the request.

Enabled / Disabled Check or uncheck the box to activate or deactivate the specified conference, respectively.

Delete Removes the conference call from the schedule. Click Delete to save changes or Cancel to 
disregard the request.

Click here to return to the “Install Checklist” .

Prerequisites

Access Permissions Allworx Server Administrator
Allworx System Administrator
Phone Administrator role

Feature Key Required Conference Center
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Chapter 8 Contact Information

Contact Information feature enables entering 
information about the primary business contact.

Providing this information is recommended but 
not required.

To manage the contact information:
1. Log in to the Allworx server admin page, 

and navigate to Phone System > Contact Information. The Contact Information page displays.

2. Click Modify and enter the contact information in the fields provided.

For activated Connect servers, there is an option to import the customer contact information 
from the registration information on the Portal.

3. Click Update to save change or Cancel to disregard the request.

Click here to return to the “Install Checklist” .

Prerequisites

Access Permissions Allworx Server Administrator
Allworx System Administrator
Phone Administrator role

Feature Key Required No
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Chapter 9 Dial Plan

Dial Plan manages the internal extension length 
and the Emergency Number Dialing. 
Additionally, Allworx administrators can 
customize the digits for users to dial to access to 
the Allworx server features.

9.1 Setup Checklist
Follow the order of the steps to successfully setup the Dial Plan.

9.2 Manage the Internal Extension Length

Configure the handset extensions from three (default) up to six digits. All existing extensions expand to 
the new length. After increasing the internal extension length to 5 or 6 digits, the extensions show 
available link is no longer available on the following web admin pages:

• Phone System > Users > add new user

• Phone System > Users > Modify

• Phone System > Extensions > add new extension

Step Description Installation Guide Link

1 Set up the Internal Extension Length before defining users, 
handsets, or extensions.

“Manage the Internal Extension Length” on page 37

2 Set up the Internal Dial Plan. “To manage the Internal Dial Plan:” on page 39

3 Set up the Service Groups. “Manage DID Routing Configuration” on page 40

4 Set up the External Dialing Rules (including 
Emergency Number Dialing).

“Manage External Dialing Rules” on page 42

5 Set up the Dialing Privileges Groups. “Manage Dialing Privileges Groups” on page 46

Note: This feature is compatible with Reach 2.0.7 (minimum) and Interact 2.3 (minimum)

Note: Define users, handsets, or extensions, and then increase the internal extension length.

Caution: Internal extension lengths cannot be decreased AFTER increasing extension length. It is highly recommended that 
Allworx administrators perform an OfficeSafe Backup before increasing the extension length.Once the system 
extension length has increased, Allworx administrators can only decrease the extension length by using an 
OfficeSafe Restore, which resets the Allworx server to the backed-up configuration. 

Prerequisites

Access Permissions Allworx Server Administrator
Allworx System Administrator
Phone Administrator role

Feature Key Required No
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In addition to the changes in user and system extensions, the following server configurations 
automatically update when changing the internal extension length: 

Extension Length changes do not affect the following server configurations1:

To change the extension length: 

1. Log in to the Allworx server admin page. Navigate to Phone System > Dial Plan.

2. Locate the Internal Extension Length section, and click modify. 

3. Select the number of digits to use for the extensions in the drop-down list. 

4. Click Update to save the changes or Cancel to disregard the changes.

5. Update other dial plan changes, as needed, and then click Reboot Phones to update the 
handsets to the new configuration.

•  Extension call routes including Internal Caller-ID checking •  Speed Dial PFK (differs from Personal Speed Dial PFK)

•  System Speed Dials (the Speed Dial extension doesn’t change 
but the dialed extension changes)

•  Default Extensions, extensions accessed by Shortcuts, and “Dial 
By Directory” listings of Auto Attendants

•  DID mappings •  Off hook digits dialed for handsets

•  Incoming outside line call routes •  Call Detail Records (prior records are unaffected by the change)

•  System Speed Dial extensions (350-399, 34000-34999) •  Conference Center (408)

•  Call Park extension and Parking Orbits (700-709) •  Paging extensions (460-469)

•  Auto-Attendant extensions (400, 4301-43xx*) •  Queue extensions (4400-4409, 4410-4419)

•  Door Relay (403) •  Modifying Internal Dial Plan

•  Message Center (404) •  Personal Speed Dials 
(users must modify since the phone stores the numbers)

* Where xx is the maximum number of Auto Attendants supported by the Allworx server.

1. Extensions may vary per system. When using a non-default Internal Dial Plan, consult the My Allworx Manager 
Phone Features tab to determine what extensions to use for the corresponding feature.

Note: Servers that are part of multi-site networks cannot change the Extension Length.

Note: Existing extensions change after modifying the system extension length. 

Caution: Internal extension lengths cannot be decreased AFTER increasing extension length. It is highly recommended that 
Allworx administrators perform an OfficeSafe Backup before increasing the extension length.Once the system 
extension length has increased, Allworx administrators can only decrease the extension length by using an 
OfficeSafe Restore, which resets the Allworx server to the backed-up configuration. 
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9.3 Manage Internal Dial Plan
The Internal Dial Plan specifies the first digit for user extensions and other PBX functions such as 
forwarding calls and accessing outside lines. There are two configuration modes for the Internal Dial 
Plan:

To manage the Internal Dial Plan:
1. Log in to the Allworx server admin page. Navigate to Phone System > Dial Plan.

2. Locate the Internal Dial Plan section, and click one of the following options: 

3. Select the leading digit from the drop-down list in the first column. The table displays examples 
of the dialing plan during the selection process

4. Click Update to save the changes or Cancel to disregard the changes.The Dial Plan page 
displays. Locate the top message about rebooting Allworx phones and click Reboot Phones to 
update the handsets to the new configuration. 

Internal Dial Plan Settings

Normal Mode User and system extensions are a continuous range of extensions numbers. The numeric range varies between 
1xx and 9xx. Example: three-digit extensions between 100 and 299 or between 700 and 899. 
System functions (Speed Dials and retrieving parked calls) are in other ranges not assigned to user extensions.

Extension Mode User and system extensions can be in any numeric range. The server reserves only the operator digit (e.g.,0) 
and the PBX external dial digit (e.g., 9). System functions begin with an asterisk (*). Example: extensions can 
range between 100 and 899 or 1000 and 8999.

modify Change the internal dial plan settings. 
•  Default: Normal mode 
•  Extension Mode: click the checkbox. 
NOTE: If the system is part of a Multi-site network, the Allworx administrator cannot change the Internal Dial 
Plan between Normal Mode and Extension Mode.

view Opens the My Allworx Manager log in page. Enter the user Username and Password, and then click Login. 
The Phone Functions Reference Card page displays in a new browser window.

User and System 
Extensions

Identifies the first number used for phone extensions.

Operator Identifies the number for callers to dial to contact the internal operator.

External Call access Identifies the number to dial first to gain access to an outside line. Follows the External Dialing Rules.

Enterprise calling Enables a third party SIP server to be the central hub for calls between multiple sites that have Allworx 
servers. This provides a centralized phone book and administrative service for the entire VoIP network. 

Internal station access Reserved for system

Speed dial numbers Identifies the number to indicate a speed dial number follows.

Message Center Short-cut access to the Message Center to:
•  manage presence and presence greetings
•  name recording
•  PIN
•  access and listen to voicemail messages (even from another Allworx phone). 
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9.4 Manage DID Routing Configuration
Enables Allworx administrators to disable or enable the DID-to-extension mapping feature. If disabled, 
the internally dialed DID numbers route via the external dialing rules.

To manage the Internal Dial Plan:
1. Log in to the Allworx server admin page. Navigate to Phone System > Dial Plan.

2. Locate the DID Routing Configuration section. 

3. Select an option from the drop-down list.

4. Click Update to save the changes or Cancel to disregard the changes. 

9.5 Manage Service Groups
A Service Group is a collection of services use for placing outside calls. The Allworx server uses a 
variety of services to place outside calls; some of these services are optimum for particular types of 
calls. Example: the SIP Proxy might be the least expensive way to make long distance calls, but the 
CO lines are best for local calls. The server creates several Service Groups automatically: 

The Allworx administrator can define additional Service Groups to control the use of services or set of 
services for certain dialed calls.

When initiating an outbound call using the Service Group, the server tries services in the group in 
top-down order until an idle service is found. The call made uses the first idle service in the list. 
Therefore, the last step in setting up a Service Group ensures that the order of the services reflects 
the preferred use priority. When one of the services in the group is a SIP proxy, the server considers 
the SIP proxy idle until reaching the Maximum Active Calls setting.

To manage the service group:
1. Log in to the Allworx server admin page, navigate to Phone System > Dial Plan.

Call Functions Identifies the initial number to dial to access various call functions (park/pickup/audit pin code).

Leave a voicemail for 
extension

Identifies the initial number to dial to access a voicemail box to leave a message for another user.

PBX Functions Identifies the initial number to dial to access various PBX functions - door relay, Conference Center, do not 
disturb, Auto Attendants, Call Queues, call retrieve, call forwarding, or paging.

• All Digital Lines • All Digital Lines, CO Lines & SIP Gateways

• All SIP Proxies • No Devices (use to prevent placing external calls)

• All Trunk Devices • All Digital Lines & CO Lines

• All SIP Gateways
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2. Locate the Service Groups section and click one of the following links:

9.5.1 Configure Remote Sites as Services

Select remote sites as services for handling outbound calls. If the line selection process results in a 
routing call to a remote site, the call connects using one of the remote sites’ outside lines. The dialing 
rules configured on the remote site determines which lines to use and how to dial the number (with or 
without area code).

The Allworx server automatically prevents configuring the dial plans on multiple sites accidentally to 
avoid routing a call back and forth among the sites. If a call comes to a server from a remote site, the 
receiving server does not forward the call to the same or other remote sites. If the dialing rule that the 
call is using on the receiving site includes any remote sites, the system skips the remote sites and uses 
another outside line service.

9.5.2 Configure Service Groups / Handset Outside Line Restrictions 
Service Groups direct outbound calls to specific services. The server selects the first idle service in the 
group. The handset configuration supports restricting the use of lines further when placing an outside 
call. The server uses the number dialed to locate the configured Service Group for the outbound call.

After finding the first idle service in the group, the Outside Line Selection Method in the handset Call 
Appearance Dialing Privileges Group is checked. If the idle service is restricted for the handset, it finds 
the next idle service and requires the handset to check again. This continues until the system finds a 
non-restricted idle service to place the call. If the server cannot find a non-restricted idle service, the 
caller hears a fast busy signal to indicate there are no available outside lines.

add new 
Service Group

Create an additional Service Group.
1.  Enter a Description for the new group.
2.  Move the preferred services into the Service Group box.
3.  (optional) User the Move Up or Move Down buttons to change the Services order.
4.  Click Add to save the changes or Cancel to disregard the changes, and reboot the phones to update the 

handsets to the new configuration. Requires no further action.

Copy Create a new dialing privileges group with the same settings as the copied group.

Modify Change the settings configuration. 
1.  Enter a Description for the new group.
2.  Move the preferred services into the Service Group box.
3.  (optional) User the Move Up or Move Down buttons to change the Services order.
4.  Click Update to save the changes or Cancel to disregard the changes, and reboot the phones to update 

the handsets to the new configuration. Requires no further action.

Delete Remove the current Service group from the server (the Allworx administrator cannot delete the default 
group). Confirm the decision and click Delete to remove the Service Group from the server or Cancel to 
disregard the request. Requires no further action.

Note: Remote sites should not be the only method available to place external calls. Loss of Internet connectivity between 
the local site and the remote site (at either end) may disable the ability to place calls including 911 Emergency calls.
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9.6 Manage External Dialing Rules
The external dialing rules indicate to the Allworx server what digit sequences are valid for dialing out 
on the public phone network. As a user dials digits on an Allworx phone, the server collects the digits, 
one at a time to place the call. Use the dialing Rules and Service Groups for Call Appearance, not for 
Line Appearance calls because the Line Appearance accesses outside lines directly.

Enhanced external dialing rules supports matching specific dialing sequences and then deleting, 
inserting, and/or appending digit strings to those numbers before sending the dial string to any SIP 
Gateway, SIP proxy, T1/PRI Digital Line, or CO line. This flexible dialing supports programming the 
dialing behavior of the Allworx server to match specific business needs. Examples:

The server dialing rules automatically detects when an outbound dialed number is associated with an 
internal extension (local or multi-site). When detecting this case, the system places the call to the 
internal extension. The system considers 10-digit DIDs for matching and attempts to match all 10-digit 
dialed calls as well as all 7-digit dialed calls, if the server home area code is set. If there are 
overlapping DID blocks on a local server, the server uses the first matching DID. In a multi-site 
network, the local server uses the DIDs for the local site first followed by the DIDs at the remote sites. 

Example: 789-456-0123 maps to extension 101 (external call access number is 9 in this example)

9.6.1 Manage the North American Numbering Plan Administration 
(NANPA)

The Allworx server routes calls using the Service Group assigned to the type of number dialed. When 
enabling or disabling NANPA, it changes the types of numbers dialed that the system supports.

To manage the NANPA settings: 
1. Log in to the Allworx server admin page. Navigate to Phone System > Dial Plan > External 

Dialing Rules.

2. Locate the North American Number Plan section, and click modify.

Number Description

Local number Users dial a 7-digit number (normally not 1 + <area code>). The server collects the 7-digits dialed, and then 
attempts to make the call. The server is not waiting for more digits.

Long distance Users normally dial 1 + <area code> + 7-digit local number. The server recognizes this case distinctly from 
the local number case, and collects all 11 digits before attempting to make the call.

Some local calling areas Require dialing a <area code> + 7-digit number (without the 1 prefix) to properly dial some numbers. This 
implies that these rules may vary depending on the local calling area with an installed Allworx server.

User Dials
Home Area Code 

set to 789
Call Placed to

9-1-789-456-0123 N/A Extension 101.

9-456-0123 Yes Extension 101.

 9-456-0123 No Phone number: 456-0123.
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3. Check the box to enable NANPA for installations in North America, and disable NANPA for all 
other locations. When disabling NANPA (unchecked) access the outside lines using the steps 
described in the Exceptions section, above. Click Update to save the changes or Cancel to 
disregard the request.

When enabling NANPA, the Allworx administrator cannot add, modify, or delete the default 
rules. The rules affected by enabling NANPA are service rules, operator rules, emergency rules, 
and 11-digit dialing rules. Exception: the Allworx administrator can add to the 11-digit dialing 
rules, if the total digits is equal to 11.To add, modify, or delete the rules, the Allworx 
administrator must disable NANPA. 

9.6.2 Manage the Home Area Code Requirements
Some features of the Allworx server and phones (example: redialing from call history and when 
mapping numbers to 11-digit forms to SIP proxies) require knowledge of the home area code. This 
required information is part of the dialing rules to support those features to operate properly.

To manage the home area code:
1. Log in to the Allworx server admin page. 

2. Navigate to Phone System > Dial Plan > External Dialing Rules > Home Area Code > 
Modify.

3. Enter the area code in the field provided.

4. Click Update to save the change or Cancel to disregard the request.

NANPA Enabled Requirements

Rule Leading Digits Total Digits Auto Delete Existing

Service Rule 211 3 Yes

Service Rule 311 3 Yes

Service Rule 411 3 Yes

Service Rule 511 3 Yes

Service Rule 611 3 Yes

Service Rule 711 3 Yes

Service Rule 811 3 Yes

Operator Rule Operator 1 Yes

Emergency Rule Emergency Any Yes

Rules beginning with 1 1 [any other digits] Not equal to 11 Yes 



Section 3 - Phone System

Page 44 1 866 ALLWORX * 1 585 421 3850
www.allworx.com

Revised: 03/25/2016

9.6.3 Select the Automatic Route
The dial method controls whether or not to include the area code when the placing the call. If the area 
code is not properly configured for the local rules, the system may not correctly place local calls. 
Configure the area codes to use the correct service for the local and other area codes and to use the 
correct number of digits when placing the call. 

To select the automatic route:
1. Log in to the Allworx server admin page, navigate to Phone System > Dial Plan.

2. Locate the External Dialing Rules > Automatic Route Selection section. 

3. Click one of the following links: 

4. Locate the message about rebooting Allworx phones and click Reboot Phones to update the 
handsets to the new configuration. 

Automatic Route Selection Rule Settings

Example 1:
Adding an area code with “Area code NOT dialed”. In this case, the user dials 1234567, the area code 

Bulk Edit Delete the checked route definitions.

add new rule Activate another rule. See “Automatic Route Selection Rule Settings” on page 44 for more settings 
information. Click Add to save the new rule or Cancel to disregard the request.

Modify Change the selected rule. See “Automatic Route Selection Rule Settings” on page 44 for more 
settings information. Click Update to save the changes or Cancel to disregard the request.

Setting Description

Leading Digits User dialed digits. For areas that require dialing the area code or other type exchange, this is the aaa (area 
code). For areas that require dialing 1 + area code (or other exchange), this is 1aaa (aaa is the area code/
exchange).

Total Digits Number of digits (1 to 24) including digits 0-9 dialed by the user for the pattern.

Delete Leading Digits Number of the first 0 to 24 caller-dialed digits deleted from beginning of the dial string before sending the 
request to a service group.

Insert Leading Digits Digits not dialed by the user. Inserted at the beginning of the dial string after deleting leading digits before 
the string passes to the remote device. It is possible to insert 0 to 24 digits (0-9), #, *, or pauses (P). 

Append Trailing Digits Digits added to the end of the dial string - 0 to 24 digits (0-9), #, *, or pauses (P).

Service Group Select an option from the drop-down list:
•  All CO Lines
•  All CO Lines & SIP Gateways
•  All SIP Gateways
•  All SIP Proxies
•  All Trunk Devices
•  Including any added service groups
•  No Devices
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is 585, and the output dial string is 15851234567.

Example 2:
Adding an area code with “Area code dialed”. In this case, the user dials 5851234567, and the output 
dial string is 15851234567.

Example 3:
Adding an area code with “1 + area code dialed”. The user dials 15851234567, and the output dial 
string is 15851234567.

9.6.4 Manage the Emergency Number Rules

Important: Prior to configuring the emergency dial plan, the emergency number rule defaults are:

To configure emergency number rules:
1. Log in to the Allworx server admin page, navigate to Phone System > Dial Plan.

Setting Description Setting Description

Leading Digits 0 Insert Leading Digits 1aaa

Total Digits 7 Append Trailing Digits 0

Delete Leading Digits 0

Setting Description Setting Description

Leading Digits aaa Insert Leading Digits 1aaa

Total Digits 10 Append Trailing Digits 0

Delete Leading Digits 0

Setting Description Setting Description

Leading Digits 1aaa Insert Leading Digits 0

Total Digits 11 Append Trailing Digits 0

Delete Leading Digits 0

Note: Do not enter an Emergency number that conflicts with other dial plan options as this may result in the emergency 
center not being called.

Note: Reboot Allworx phones when making changes to the Emergency values.

Caution: Do not attempt to place emergency (911) calls prior to activating the Connect server. 

Not Set Emergency Number: 911
Direct Dial: enabled (checked)

Set Uses the Emergency Number and Direct Dial settings as previously set by the administrator.
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2. Locate the External Dialing Rules > Emergency section, and click Modify.

3. Update the fields:

4. Click Update to save the changes or Cancel to disregard the changes.The Dial Plan page 
displays.

5. (optional) Locate the Emergency Call Email Notification line and click modify. Check box to 
enable email notifications of emergency calls, and then click Update to save the change or 
Cancel to disregard the request.

6. Locate the top message about rebooting Allworx phones and click Reboot Phones to update 
the handsets to the new configuration. 

9.6.5 Manage the Services

To manage the services:
1. Log in to the Allworx server admin page, navigate to Phone System > Dial Plan.

2. Locate the External Dialing Rules section, and then the Services table. Click Modify.

3. Select the Service Group affected in the drop-down list. For the Public SIP Director and PIN 
Code feature, specify the number of digits. 

4. Click Update to save the changes or Cancel to disregard the request.

5. Locate the message about rebooting Allworx phones and click Reboot Phones to update the 
handsets to the new configuration.

9.7 Manage Dialing Privileges Groups
A Dialing Privileges Group is a set of dialing permissions and handset Call Appearances with the 
same settings. Apply custom configurations to any or all of the site handsets by creating a Dialing 
Privileges Group, specifying the settings, and assigning handset Call Appearances to the group. 
Changes made to the group settings take effect immediately. Handset Call Appearance dialing 
permissions determine how to access outside lines, determine which outside lines to use, and enable 
or block phone numbers. 

To manage the dialing privileges groups:
1. Log in to the Allworx server admin page, navigate to Phone System > Dial Plan.

Emergency Enter the number to dial for emergency situations.

Dial Direct Enables users to dial the emergency number without the line access number. Check the box to enable.

Note: To change the PIN code length, the system cannot have any previously configured PIN codes.
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2. Locate the Dialing Privileges Groups section, and then click one of the following links:

3. Locate the section to update and click Modify:

View View and modify the current dialing permissions group.

Copy Create a new dialing privileges group.

Delete Remove the current dialing privileges group from the server. However, the Allworx administrator 
cannot delete the default group or groups with assigned handsets. Therefore, move all handsets 
into other groups to delete the group. 

Section Description

Dialing Privileges Group
When upgrading Allworx servers, create an additional Dialing Privileges Group for each unique combination of Outside Line 
Connection settings for the existing phones. 
NOTE: The system does not change settings for existing handsets in this process.
Dialing Privileges Group settings include the following: 
•  Emergency Service Group
•  Schedule 
•  Toll Restrictions
•  Outside Line Selection Method

Name Enter a new name in the field

Emergency Service 
Group

Select a group from the drop-down list.

Schedule Associate a schedule with each Dialing Privileges Group to specify different Toll and Internal 
Call Restrictions for the Dialing Privileges Group based on the schedule. This option supports 
additional flexibility by limiting which numbers specific handsets can dial at various times of 
the day. Example: 
•  Don’t let the lobby phone dial the door relay or paging zones. 
•  Don’t let certain employees dial the CEO. 
•  Don’t let any phone make long distance calls after business hours. 

Select a schedule option from the drop-down list, and then use the option drop-down lists to 
further refine the call restriction type. See the Toll Restriction and Internal Call Restriction 
sections below for the restriction options.

Seize Rule Select a rule from the drop-down list.

Outside Line Selection 
Method

Select one of the options:
•  Use External Dialing Rules for number dialed
•  User External Dialing Rules, but restrict to these services: check the appropriate check 

boxes. Shortcut: click check all or uncheck all.
•  Ignore External Dialing Rules and always use this service or Service Group: select an option 

from the drop-down list.

Schedule Option Restriction Type Available

Not Used •  Toll Restriction
•  Internal Call Restriction

<Available Schedule> •  Day Mode Toll Restriction
•  Night Mode Toll Restriction
•  Day Mode Internal Call Restriction
•  Night Mode Toll Restriction
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Toll Restriction
Define toll restrictions between different Dialing Privileges Groups.When programming a specific Dialing Privileges Group, the 
Allworx administrator selects which Toll Restrictions to apply to the Dialing Privileges Group. 

The server enables all numbers defined by the External Dialing Rules unless listed in the Blocked Numbers list. 
•  Numbers in the Exceptions list override the blocked numbers.If listing a number as both blocked and as an exception, the 

server enables calls to that number. 
•  Entries in the Blocked Numbers list need not be complete phone numbers but can be only the first part of phone numbers. 

The numbers entered are a pattern, which the Allworx server reads left to right. Once the pattern has been matched (see 
example) the number is blocked. Example: entering 1900 in the Blocked Numbers list prevents all 1-900 number calls. 

Entries in the Exceptions list should be more specific than those in the Blocked Numbers list. 
•  The Exceptions to the Blocked Numbers list does not need to have any entries to specify enabling similar numbers.
•  If the Blocked Numbers list contains 1 as an entry and the Exceptions to Blocked Numbers list contains 1800, then users can 

dial 1-800 numbers but no other long distance number. 
•  If the Blocked Number list contains a complete number (e.g. 19005553850) then the server blocks only that number. 

NOTE: When attempting to block the emergency number, the Allworx System Software requires a confirmation prior to 
accepting the request.

Add Create a new rule.

Click Add to save the change or Cancel to disregard the request.

Modify Update the rule.

Click Update to save the change or Cancel to disregard the request.

Delete Remove the rule from the list. Verify this is the rule to delete, and then click Delete to remove 
the rule or Cancel to disregard the request.

Note: Toll Restrictions (Default) cannot be deleted.

Internal Call Restrictions
Block internal calls (extensions, PBX functions, etc.) When programming a specific Dialing Privileges Group, the Allworx 
administrator selects which Internal Call Restrictions that apply to the Dialing Privileges Group. 

The server enables all numbers unless listed in the Blocked Numbers list. 
•  Numbers in the Exceptions list override the blocked numbers. 
•  If listing a number as both blocked and as an exception, the server enables calls to that number. 
•  Entries in the Blocked Numbers list need not be complete phone numbers but can be only the first part of phone numbers. 

Example: entering 12 in the Blocked Numbers list prevents calling internal extensions 1200 to 1299 or entering *4 in the 
Blocked Numbers list prevents calling all PBX functions.

Entries in the Exceptions list should be more specific than those in the Blocked Numbers list. 
•  The Exceptions to the Blocked Numbers list does not need to have any entries to specify enabling similar numbers.

Section Description

Enter new name Describe the new rule.

Blocked Numbers Enter the blocked numbers in the fields provided.

Exceptions to 
Blocked Numbers

Enter the exception numbers in the fields provided.

Update the name Describe the rule.
Note: The Toll Restrictions (Default) name cannot be changed.

Blocked Numbers Enter the blocked numbers in the fields provided.

Exceptions to 
Blocked Numbers

Enter the exception numbers in the fields provided.
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4. Click Update to save the changes or Cancel to disregard the request, and then reboot the 
phones to update the configurations.

Add Create a new rule.

Click Add to save the change or Cancel to disregard the request.

Modify Update the rule.

Click Update to save the change or Cancel to disregard the request.

Delete Remove the rule from the list. Verify this is the rule to delete, and then click Delete to remove 
the rule or Cancel to disregard the request.

Note: Internal Call Restrictions (Default) cannot be deleted.

Call Appearances Assigned to Group

Check the box next to a Call Appearance to include it in the group. When removing a Call Appearance from a user-defined 
group, it moves automatically to the default Group.

Click here to return to the “Install Checklist” .

Section Description

Enter new name Describe the new rule.

Blocked Numbers Enter the blocked numbers in the fields provided.

Exceptions to 
Blocked Numbers

Enter the exception numbers in the fields provided.

Enter new name Describe the new rule.
Note: The Internal Call Restrictions (Default) name cannot be 
changed.

Blocked Numbers Enter the blocked numbers in the fields provided.

Exceptions to 
Blocked Numbers

Enter the exception numbers in the fields provided.
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Chapter 10 Emergency Alerts and Caller ID

The 911 Alert sends audible and visual alerts to 
designated handsets immediately after making 
an emergency call from any local or remote 
handset and supports email and SMS message 
notification of emergency calls. The 911 Alert 
supersedes any handset functionality, except 
when the handset user is in an admin menu.

Important: Prior to configuring the emergency dial plan, the emergency number rule defaults are:

• To dial the emergency number without dialing the external line access digit, see “Manage the 
Emergency Number Rules” on page 45 for more information. 

• To configure handsets to receive 911 alerts, assign an Emergency Alert PFK. See “Manage the 
Programmable Function Keys (PFKs)” on page 67 for more information. 

10.1 Emergency Alerts
When any handset places an emergency call on the system, handsets with the emergency alert PFK 
produce an audible beeping and displays the information:

• owner of the handset which placed the call.

• station number of the handset the call originated from.

• date / time of the call.

The Allworx server automatically acknowledges active alerts by silencing all handsets beeping after 10 
minutes and removing the handset display alert information after 60 minutes. 

Caution: Do not attempt to place emergency (911) calls prior to activating the Connect server. 

Default Description

Not Set Emergency Number: 911
Direct Dial: enabled (checked)

Set Uses Emergency Number and Direct Dial settings as previously set by the administrator.

Status Pressing the PFK

Active Alert Acknowledges the alert, silences the beep, and removes the alert information from the display screen.

Inactive Alert Retrieves information of the last alert stored on the handset.

Rebooting the handset Removes stored alert details from the handset.

Prerequisites

Access Permissions Allworx Server Administrator
Allworx System Administrator
Phone Administrator role

Feature Key Required No
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Additional emergency calls placed from other handsets within 15 seconds results in the server 
disregarding the new alerts, and the handset stores the emergency call placed after the 15 second 
time period after the user acknowledges the first alert. Press the PFK or CLEAR soft key to 
acknowledge the alert.

Emergency alerts supersede any handset functionality (e.g. placing/receiving a call, logged into 
message center), except when the user of the handset is in an admin menu (e.g. viewing directory, 
CONFIG menu settings, changing presence setting). In this case, the PFK blinks. Once the user exits 
the menu screens, the handset repeats the alert audible beeping and information.

10.2 Manage Emergency Handset Caller ID
The Allworx server supports assigning an Emergency Caller ID (CID) number to each Allworx 
handset. When dialing an emergency number from the handset, the Emergency CID passes to the 
emergency call center instead of the normal CID. For employees not at the main site, the properly 
configured Emergency CID helps the emergency call center locate the handset placing the call.

To configure Emergency Caller IDs for specific handsets: 
• define an Emergency Caller ID and assign it to the handsets.

• give each Emergency CID a Location name and associate each with a Service Group to use 
when placing an emergency call. When selecting the Use External Dialing Rules service 
group, the server selects the outside line or service group with the area code of the Emergency 
CID number.

To manage the Emergency Caller ID numbers:
1. Log in to the Allworx server admin page, navigate to Phone System > Emergency CID, and 

locate the Emergency Caller ID Numbers section.

2. Click one of the following links:

Note: Calls do not disconnect when an Emergency alert is propagated to the handset.

Caution: Setting Emergency Caller IDs to place emergency calls on a CO line do not work. The Emergency CID does not 
override the Caller ID of the CO line. 

Caution: If using SIP trunks or PRI lines, check with the provider to determine the Caller ID numbers to use, if any, or to 
configure additional phone numbers as caller IDs for emergency calls. After setting up Emergency Caller ID numbers 
on the Allworx server, call the emergency phone number (e.g., 911) to test each number. Use a phone configured 
with the caller ID to ensure that the emergency calls connect, route to the correct emergency call center, and the call 
center can independently determine the handset location. Advise the call center that these test calls are non-
emergency calls to test the phone system. 

add new Caller ID 
Number

Create another emergency caller ID number.
1.  Enter the Caller ID number and Location. Use a descriptive handset name for the locations that 

use this caller ID.
2.  Select a service group from the drop-down list.
3.  Click Add to save the changes or Cancel to disregard the request. 
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10.3 Assign the Emergency Caller IDs

To assign using the server administration page:
1. Log in to the Allworx server admin page, and navigate to Phone System > Emergency CID. 

The page displays all handsets on the system in the table under the Handset Emergency 
Caller ID Number Assignments section. 

2. Locate the Handset Emergency Caller ID Number Assignments table, and then locate the 
handset.

3. Click Modify, and then select a Caller ID number from the drop-down list.

4. Click Update. If using the handset option, the system requires a phone reboot to display the 
changes on the server admin page. 

modify Update the Location and Service Group fields.
1.  Enter the new Location.
2.  Select a service group from the drop-down list.
3.  Click Update to save the changes or Cancel to disregard the request. 

Delete Removes the Caller ID number from the list. However, administrators cannot delete Emergency 
CIDs with assigned handsets. Assign all handsets to another Emergency CID prior to deletion. 
Confirm the number and click OK to save the changes or Cancel to disregard the request.

Note: Assigned Emergency Caller IDs via the phone admin page or its CONFIG menu overrides the CID number for the 
handset, if assigned on the server.

Note: When assigning an Emergency CID number to a handset from the Allworx server admin page, the Caller ID number 
does not display on the phone admin page or under the CONFIG menu. 

Click here to return to the “Install Checklist” .
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Chapter 11 Extensions

Extensions manage extensions or call routes - 
this includes special purpose call routing to these 
extensions. Additionally Extensions provide a 
short cut to manage users. 

11.1 Add New Extension
Enables adding an extension to the Allworx 
system directory.

To add a new extension to the directory:

1. Log in to the Allworx server admin page, and navigate to Phone System > Extensions > add 
new Extension and update the fields.

2. Locate the Call Route section, and click add a connection attempt. This enables forwarding 
the call to another number.

3. Locate {no selection}, the number of rings, and the Ring Type sections and select an option for 
each from the drop-down list. (Number of rings and Ring Type style are optional).

Ring Types
Enable handsets connected to the Allworx server to be set to ring with different patterns and 
tones. The table below defines the supported ring types.

Note: After increasing the internal extension length to 5 or 6 digits, the extensions show available link is no longer 
available.

System Extension Enter a requested extension number or click show available and click on an available number 
to select the extension. Click hide available to close the list of available numbers.

Description Enter a name for the extension, i.e., Conference Room.

Schedule Select a schedule for the extension to use for business hours from the drop-down list.

Analog Handset
Allworx Handsets
Families 1 - 4

Allworx Handsets
Family 5

Single Ring Single Single Ring Pitch A Single Ring Pitch E

Double Ring Double Ring [short, short] Double Ring Pitch A Double Ring Pitch F

Ring Type 1 Double Ring [short, long] Single Ring Pitch B Triple Ring [short, long, short] Pitch G

Ring Type 2 Double Ring [long, short] Double Ring Pitch B Quad Ring [long, long, short, short] Pitch H

Ring Type 3 Triple Ring [long, long, long] Single Ring Pitch Tone C Triple ring [long, long, long] Pitch I

Ring Type 4 Triple Ring [short, short, long] Double Ring Pitch Tone C Triple Ring [short, short, long] Pitch J

Prerequisites

Access Permissions Allworx Server Administrator
Allworx System Administrator
Phone Administrator role

Feature Key Required No
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Phone users can select a Ringtone Family within the phone CONFIG > Preferences > 
Ringtone Family menu. Selecting Family 1 (the default family) causes the phone to produce 
ringtones that are the same as the ringtones available in Release 7.3 and lower. Ringtone 
Families 2 through 4 have the same single/double ring pairs as Family 1 except that the 
frequencies of the ringtones are in different ranges:

On phones installed in adjacent offices, selecting different Ringtone Families help users more 
easily detect whose phone is ringing. To improve this further, choose different ring types for 
different phones in the Call Route configuration on the server.

4. (optional) Click add a destination and repeat steps 4 and 5 to ring multiple phones 
simultaneously.

5. (optional) Click add another connection attempt and repeat steps 4 and 5 to forward the call 
to another handset, if the first connection attempt does not answer. Continue repeating, as 
required.

6. Locate the Finally... box, and select an option for the call from the drop-down list, if the user or 
any of the connection attempts do not answer. To delete any of the connection attempts, click 
delete this attempt.

7. Click Add to save the change or Cancel to disregard the request.

Ring Type 5 Triple Ring [short, long, short] Single Ring Pitch Tone D Triple Ring [long, short, long] Pitch K

Ring Type 6 Triple Ring [long, short, short] Double Ring Pitch Tone D Triple Ring [long, short, short] Pitch L

Family Frequency Range of Pitches A through D

Family 1 Default Frequencies (Same as Release 7.3 and lower)

Family 2 Middle Frequencies

Family 3 High Frequencies

Family 4 Very High Frequencies

Family 5 Pitch ranges from very low to high. Uses more diverse cadences including triple and quad rings. On a given 
phone, if multiple ringing are used to differentiate between different call sources or intended destinations, 
select different Ring Types in the Call Route configuration. Then on the phone, select Ringtone Family 5 to 
produce the widest range of ringtones.

Hang up Requires no further action.

Transfer to Auto Attendant Select an option from the drop-down list.

Transfer to Call Queue Select an option from the drop-down list.

Transfer to Voicemail for user Select an option from the drop-down list.

Dial number Enter a new number to forward the call.

Analog Handset
Allworx Handsets
Families 1 - 4

Allworx Handsets
Family 5
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11.2 Perform a Search
Locate extensions based on extension, description, login name, or site. 

To perform a search:
1. Log in to the Allworx server admin page, and navigate to Phone System > Extensions.

2. Locate the search line and enter the search criteria. Press Enter. The table displays the 
information matching the search criteria.

11.3 Manage the Description
Click the description name as a short cut to manage the user. See “To modify or delete existing users:” 
on page 133 for additional information.

11.4 Manage Call Routes
The building blocks of a call route are the Connection Attempts and the Finally route. In a typical call 
route, there is one Connection Attempt and the Finally route. The Allworx server supports configuring 
the call routes for special purpose routing such as: 

To enable users to define the extension routing using the My Allworx Manager page, see “To modify or 
delete existing users:” on page 133 for more information.

To manage the presence call route:
1. Log in to the Allworx server admin page, and navigate to Phone System > Extensions. 

2. Locate the extension or the user and click View Call Routes. The page displays the presence 
settings and associated call route for each setting. 

Presence Specific Routing When on vacation, forward the call directly to voicemail (User extensions).

Multiple Destinations Ring multiple phones simultaneously.

Multiple Connection Attempts Ring a series of phones when the primary phone is not answered. 

On Busy Routing Ring alternate phone(s) when the line is busy (User extensions).

Follow-Me Anywhere Forward the call to a cell phone or home phone.

Caller ID Based Routing Separate call route dependent on the Caller ID of the incoming call (User extensions).

Hot Desk Routing Route the call to a logged-in phone after logging into a shared phone. Default is disabled.
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3. Locate the presence setting and click one of the following links:

add new call route Create a call route specific to the user. To update the call route:
1.  Locate the Call Route Selection section and check the box or boxes to add the new route to the 

selected presence.
2.  Use the Caller ID of the incoming call to a User extension to determine the call route. 

3.  Locate the Call Route section. Follow the instructions below in add a connection attempt.

Modify Update the current presence call routing. To update the call route:
1.  Locate the Call Route Selection section and check the box or boxes to add the new route to the 

selected presence.
2.  Use the On calls from all callers to determine the call route: 

NOTE: Create and save (Update button) the primary call route before creating or modifying the On 
Busy Route.
3.  Locate the Call Route section. Follow the instructions in add a connection attempt.

Delete remove the call route from the list. Click Delete Route to remove the call route or Cancel to disregard 
the request.

add a 
connection attempt

Forward the call to another extension. To setup the connection attempt:
1.  Locate {no selection} and select an available location* from the drop-down list.

•  For Follow-Me Anywhere**: Enter 9 or 781+PIN (to gain an outside connection) followed by the 
phone number in the text box that appears to the right. 
Examples†:9+1+aaa-xxx-nnnn, 9+1+xxx-nnnn, 78+ PIN+1+aaa-xxx-nnnn, or
78+PIN+xxx-nnnn

2.  (optional) Select the number of rings from the drop-down list. Click the ring style and select an 
option.

3.  (optional) Click add a destination and repeat steps 1 and 2 to ring multiple phones simultaneously.
4.  (optional) Click add another connection attempt and repeat steps 1 and 2 to forward the call to 

another handset, if alternate phones should ring when the handset(s) in the First connection 
attempt are not answered. Continue to repeating step 4, as required.

add a 
connection 
attempt (con’t)

5.  Locate the Finally... box, and select an option for the call if the user or any of the connection 
attempts do not answer.

To delete any of the connection attempts, click delete this attempt. 

external - Caller ID 
Number

enter the phone number with area code in the text box. Use the asterisk 
as a wild card.

internal - phones 
owned by

select the extension from the drop-down menu. 

Modify Primary 
Route

Updates the call route for all calls meeting the external caller criteria.

Modify On Busy 
Route

This avoids having callers hear a busy signal when calling an extension 
by configuring an alternative On Busy call route. The system ignores 
additional call attempts when configuring the busy route to use a call 
route instead of treating a busy call as no answer.

Hang up

Transfer to Auto Attendant Select an option from the drop-down list.

Transfer to Call Queue Select an option from the drop-down list.

Transfer to Voicemail for user Select an option from the drop-down list.

Dial number Enter a new number to forward the call.
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7. Click Update to save the changes or Cancel to disregard the request.

11.5 Delete an Extension

To remove an extension from the directory:
1. Log in to the Allworx server admin page, and navigate to Phone System > Extensions. 

2. Locate the extension or the user and click Delete.

3. Review the confirmation and click Delete to remove the extension or Cancel to disregard the 
request.

* Hot Desk Routes Hot Desking enables users to log in to shared phones, receive their calls on that phone, and place calls 
with their caller ID. Users can initiate the log in using a Hot Desk PFK or by selecting the Hot Desk 
Login option from the phone Config menu.
Users can add Hot Desk destinations manually or automatically to user call routes. If none are present 
when the user Hot Desks into a phone, then Hot Desk destinations are added as the first connection 
attempt to all Presence call routes.

** Follow-Me 
Anywhere

Users can forward calls to other phones outside of the Allworx System such as cell or home phones. If 
the recipient does not answer the call, the system directs the call back to the system in order to follow 
the rest of the configured call route. In following the rest of the call route, unanswered 
Follow-Me-Anywhere calls may eventually be directed to the Finally route, which enables callers to 
leave messages in the default voicemail inbox. If the preferred setting is having callers leave messages 
on a personal phone voicemail, do not use the Follow-Me-Anywhere features. Instead, use the Finally 
route to direct calls to a cell or home phone by entering the phone number into the Dial number text 
box.
NOTE: When an outside phone answers the call, the default is for the recipient to hear a prompt 
requesting to enter a ‘1’ to accept the call. However, the Allworx administrator can configure user 
extensions so that Follow-Me-Anywhere calls to their extensions require a Message Center password 
in order to accept the call. 
NOTE: The Follow-Me-Anywhere feature requires the recipient to listen to a message and enter a code. 
Therefore, increment the normal number of rings by at least two in order to give the recipient extra time 
to answer the call.

Click here to return to the “Install Checklist” .



Section 3 - Phone System

Page 60 1 866 ALLWORX * 1 585 421 3850
www.allworx.com

Revised: 03/25/2016



Allworx System Administrator Guide Version 8.1

1-866-ALLWORX * 585-421-3850 Page 61
www.allworx.com
Revised: 03/25/2016

Chapter 12 Handsets

Handsets manages analog, generic SIP, and 
Reach handsets, as well as configure an Allworx 
phone. 

The Handsets web admin page also provides 
access to manage the Allworx phone 
programmable function keys (PFKs) and the 
handset preference groups / templates.

12.1 Manage Analog Handsets
Use the following procedures to connect an analog handset to the Allworx server and to manage the 
available settings on the Allworx server for the analog handset.

To connect an analog phone via FXS Phone Port:
1. Plug the phone into one of the server FXS phone ports reserved for Inside Phone Extensions. 

2. Lift the phone receiver so that the phone is off hook, and refresh the browser window. The 
phone displays in the Analog Handsets section of the page. 

3. Hang up the phone receiver.

To manually connect an analog phone:
1. Log in to the Allworx server admin page, navigate to Phone System > Handsets. 

2. Locate the Analog Handsets section and click New Analog Handset, and click the additional 
information arrow , if necessary. The Analog Handset page opens. Update the fields.

3. Click Add to update the Analog Handset list or Cancel to disregard the changes.

Note: Analog phones plugged into Port Expander FXS ports do not automatically display on the Handsets page. Add the 
analog phones manually.

Port: Automatically filled in.

Owner Select the handset owner from the drop-down list.

Extension Optional. See TIP next to the field for more information.

Caller ID Number Select an option from the drop-down list.

Caller ID Name Automatically populates from Owner selection. Update as necessary.

Description Automatically populates from Owner selection. Update as necessary.

Prerequisites

Access Permissions Allworx Server Administrator
Allworx System Administrator
Phone Administrator role

Feature Key Required •  Generic SIP Handsets
•  Reach
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To manage the settings on an existing analog phone:
1. Log in to the Allworx server admin page, navigate to Phone System > Handsets, and locate 

the Analog Handsets section. Click the additional information arrow , if necessary

2. Click an option:

3. Click Update to save the changes or Cancel to disregard the request.

Analog Handset Settings

Modify Change the current analog handset settings. See “Analog Handset Settings” on page 62 for more 
information.

Delete The server removes the analog handset connection. Click Delete to confirm the change or Cancel 
to disregard the request.

Ring Click to test the analog handset connection.

Handset

Phone Type Automatically filled in.

Port: Automatically filled in.

Owner Select the handset owner from the drop-down list.

Internal Caller ID Name Automatically populates from Owner selection. Update as necessary.

Internal Caller ID Number Select an option from the drop-down list.

External Caller ID Number Optional. Enter information as necessary.

External Caller ID Name Optional. Enter information as necessary.

Description Automatically populates from Owner selection. Update as necessary.

Phone Status Visibility •  Normal
•  Hide Completely
•  Hide Status

Dialing Privileges Group Select an option from the drop-down list.

Handset Features

Hold Music Selection •  Line-In
•  None
•  moh_supplied.snd

Can Place Calls Check the box to enable.

Can Receive Calls Check the box to enable.

Second Call Handling Identifies how to manage a second incoming call.
•  Busy
•  Call Waiting
•  Not Busy

Message Waiting Stutter Dialtone Check the box to enable.

Message Waiting Light Check the box to enable.

Caller ID Display Check box to enable.
•  Caller ID Type I - check the box to enable.
•  Caller ID Type II - check the box to enable.
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12.2 Manage Handsets
Connect an Allworx handset, Reach handset, or generic SIP handset to the Allworx server and 
manage the available settings on the Allworx server for the handset.

To add a handset: 
When registering a phone with the server, it displays on the Handsets page with an expiration 
date/time to indicate a registered phone. 

If it is necessary to restart all of the Allworx handsets, click the Reboot Allworx Handsets button. 
Clicking this button ends all active calls. 

1. Log in to the Allworx server admin page, navigate to Phone System > Handsets, and locate the 
SIP Handsets section. Click the additional information arrow , if necessary.

2. Click one of the following links to add a handset:

Auto Off-Hook Dialing Enter the digits for the Allworx phone to automatically dial every time the user takes the phone off 
hook.

Auto Answer DTMF String Enter the DTMF digits sent when the user answers a call. The system sends these digits to the 
FXS device as soon as it answers the call. The following characters are available for use:

Note: If installing Generic SIP phones on the server, Internal Dial Plan changes can modify the configuration on the server 
such that the Generic SIP phones no longer register.

Note: The Allworx server feature key provides each Generic SIP handset a license to operate. Allworx administrators can 
add a small number of handsets without a key (2 on the Allworx 6x12 server, 4 on the Allworx Connect 300 series 
servers, 6 on the Allworx 6x and Allworx Connect 500 series servers, and 12 the Allworx 48x and Connect 731 
servers). 
•  Available feature keys provide one, five, or 10 licenses each. 
•  For larger numbers of Generic SIP handsets, install multiple feature keys.

Note: The Allworx 6x12 server maximum limit is two (2) generic SIP phones; the Allworx 6x12 server does not require a 
feature key.

add new 
Allworx Handset

1.  Locate the Allworx Handset section and fill in the fields:

DTMF Digits Timing Controls Variables

•  0 – 9
•  A – D
•  *
•  #

•  P generates a one second pause 
•  + increases the duration and gap of 

all DTMF tones by 50ms
•  - decreases the duration and gap of 

all DTMF tones by 50ms

•  $xN sends the last N digits (0 for all 
digits) of the dialed extension

•  $nN sends the last N digits (0 for all 
digits) of the DNIS number

Owner Select an option from the drop-down list.

Extension* Optional. Creates the extension with a call route to ring the handset.

Caller ID Number Select an option from the drop-down list.

Caller ID Name Enter the name to display on the caller ID.

Description Enter a meaningful name.
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8. Click Add to add the new handset to server or Cancel to disregard the request. 

9. FXS gateway only: Click Modify to configure each Call Appearance. For example: the Allworx 
administrator can assign users to each Call Appearance.

add new 
Allworx Handset
(con’t)

2.  Locate the Handset Configuration section and fill in the fields.

add new 
Allworx Reach 
Handset

If the link is unavailable, purchase more licenses. Fill in the fields:

add new Generic 
SIP Handset

If the link is unavailable, purchase more licenses and fill in the fields:

Locate the Handset Configuration section and fill in the fields.

* Login ID and Password are the credentials for the SIP handset to authenticate with the Allworx Server. 

•  If not specifying a Login ID, the server generates one when creating the handset and generates a handset User ID 
automatically.

•  Do not use the same Login ID on multiple phones.

Model Select an option from the drop-down list.

MAC 
Address

If there is an incorrect MAC address entry and the phone boots on the 
network, the server has a duplicate entry for this phone. The Plug and Play 
registration continues with the system using the correct MAC address and 
does not use the manually entered information. To locate the MAC Address 
information on the phone:
1.  Press the phone CONFIG soft key. Use the up and down arrows to scroll 

to highlight Current Status/Info and press the Select  button.
2.  Use the up and down arrow buttons to scroll to locate the MAC Address.
3.  Press EXIT soft key twice to return to the main screen.

Owner Select an option from the drop-down list.

Extension* Optional. Creates the extension with a call route to ring the handset.

Caller ID Number Select an option from the drop-down list.

Caller ID Name Enter the name to display on the caller ID.

Description Enter a meaningful name.

Owner Select an option from the drop-down list.

Extension
(Optional)

Creates the extension with a call route to ring the handset. If selecting an 
owner other than admin, the server automatically adds the handset to the In 
Office call route of the owner. If selecting an extension, the server creates 
the extension with a call route to ring this handset. Typically used in the 
case of a conference room or lab phone that does not require an owner.

Caller ID Number Select an option from the drop-down list.

Caller ID Name Enter the name to display on the caller ID.

Description Enter a meaningful name.

Number of 
Lines

Use a single, generic SIP handset to configure multi-port FXS gateways. Enter 
the number of gateway ports available on the gateway device (example: 6). This 
adds a generic SIP handset for each Call Appearance. Each Call Appearance 
represents a different gateway port.

Login ID* Enter a unique Login ID. If no Log in ID is specified, the server generates a Login 
ID when creating the handset.

Password* Select the password complexity by clicking the password requirements buttons. 
The Allworx server generates a new password upon request based on the 
complexity rules, and displays the new password when configuring the Generic 
SIP device. For existing Generic SIP devices, the system maintains the current 
password until the Allworx administrator requests a new password.
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To perform a search:
Locate handsets based on extension, description, owner, IP Address, or Caller ID. 

1. Log in to the Allworx server admin page, and navigate to Phone System > Handsets > SIP 
Handsets. Locate the search line.

2. Enter the search criteria. Press Enter. The handsets matching the search criteria display.

To review the configuration:
1. Login to the Allworx server admin page and navigate to Phone System > Handsets > SIP 

Handsets. Click the additional information arrow , if necessary.

2. Review the installed Generic SIP phone User IDs.

3. Determine if the registration configuration for each Generic SIP phone is the same or different 
from the current User ID on the server Handsets page. If there is a difference, modify the 
on-phone configuration to match the new User ID.

12.3 Manage Allworx Handsets
These procedures describe assigning a Handset Preference Group and applying a Handset Template.

To manage Allworx handset:
1. Log in to the Allworx server admin page, navigate to Phone System > Handsets > SIP 

Handsets. Click the additional information arrow , if necessary.

2. Check the Show boxes for Allworx Handsets and Reach Handsets. The table lists all installed 
Allworx desk phones and Reach handsets.

3. (optional) Click the Bulk Edit side arrow and check the box next to the handset to select it. Then 
click one of the following buttons:

Note: Allworx user guides frequently refer to dialing patterns based on the factory default internal dial plan. After making 
changes to the dial plan, the My Allworx Manager > Phone Functions tab automatically updates to the new digits. 
Distribute this sheet to all end users. See “To manage the Internal Dial Plan:” on page 39 for more information. 

Note: Changing the Operator to something other than “0” does not automatically change the Operator digit shortcut in the 
Auto Attendants. If changing the Operator digit, manually update the Auto Attendants shortcuts. See “Auto 
Attendants” on page 17 for more information.

Note: For Allworx handsets or generic SIP handsets: unregistered handsets display the registration information in gray italic 
font while registered handsets display the registration information in the standard black font. Additionally, the last 
handset reboot date/time and the last handset SIP registration time display for each handset.

Delete Removes the selected handsets from the server.

Assign Changes the Allworx Handset to the newly selected Handset Preference Group.

Apply Changes the Allworx Handset to the newly selected Handset Template.
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4. Review and update the settings per the table below:

Setting Description

Applies to:

Allworx
Desk 

Phone

Allworx
Reach 
App

 Generic
SIP 

Phone

<Handset 
Preference 
Group Name>

Name of the HPG assigned to the phone. Default setting: PBX 
Station (Default). Click the link for the group settings. See “Manage 
Handset Preference Groups” on page 72 for more information.

Yes Yes No

View 
Configuration

Modify the current settings. See “To manage the View 
Configuration:” on page 67 for more information.

Yes Yes No

Add Call 
Appearance

Create another handset Call Appearance. Multiple Call Appearances 
enable handling calls for multiple users with a single phone. 
•  Every automatically registered phone configuration includes one 

Call Appearance and two PFKs assigned to the Call Appearance. 
•  Adding a second Call Appearance creates another address to use 

in call routes.
Example: Administrative Assistant
The office administrative assistant, Susan Bell, must answer the 
phones of two executives: Tom Brown and Lisa Andrews. 
•  Susan has a Call Appearance for calls to her extension and a 

separate Call Appearance for each executive.
•  The Allworx administrator adds a Call Appearance PFK for each 

executive to Susan’s phone.
•  The call route for each executive is set to ring both the executive 

handset and the Call Appearance on Susan’s handset. 
•  The PFK corresponding to the executive receiving a call flashes so 

that Susan knows which executive line is ringing and can answer 
accordingly (e.g. “Good morning, Tom Brown’s office…”)

Yes No No

Reboot Restarts the phone. If the phone is in use, the reboot begins when 
the phone is idle. 
•  Reboot Allworx Handsets is available at the top of the SIP 

Handsets section to reboot all Allworx phones with one action. 
•  One handset reboots every 10 seconds until all phones reboot.

Yes Yes No

Replace Transfers all of the original phone configuration parameters and 
settings to a new phone.
•  Replace a defective handset with a new one. If the replacement 

has fewer PFKs than the original handset, the server copies the 
PFKs from the original handset, in order from the bottom, left of the 
PFKs, up to the number of PFKs on the replacement handset. 

•  The system replaces original unsupported handset PFK definitions 
on the replacement handset with default values.

Yes No No

IP Address IP Address assigned to the handset. If the PC has a network 
communications path to the phone, click the Handset IP Address link 
to open the phone administration page in a separate browser 
window; see “Access Phone Web Administration” on page 81 for 
more information.

Yes No No

Setup Displays the Reach Installation Assistance website. No Yes No

Modify Modify handset Call Appearance parameters. Yes Yes Yes

Delete Deletes the Call Appearance from the phone. If there is only one Call 
Appearance, the server deletes the phone from the system.

Yes Yes Yes

Ring Click to verify an operational phone connection. Yes Yes Yes
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5. Reboot the phone after changing any settings on the View Configuration page to update the 
phone to the new settings using Reboot described above or manually from the phone.

To manage the View Configuration:
1. Log in to the Allworx server admin page, navigate to Phone System > Handsets > SIP 

Handsets. Click the additional information arrow , if necessary.

2. Check the Show boxes for Allworx Handsets and Reach Handsets. 

3. Click View Configuration to see the SIP handset phone configuration parameters. In addition 
to the phone summary information, the following options display:

4. Reboot the phone to save changes.

12.4 Manage the Programmable Function Keys (PFKs)
Manage the PFKs by describing and assigning a PFK, reordering the PFK assignments, and managing 
the Call Appearance configuration.

To manage the PFKs:
1. Log in to the Allworx server admin page, navigate to Phone Systems > Handsets.

2. Locate the SIP Handsets section, and click the additional information arrow , if necessary.

3. Click View Configuration in the handset row. The Configuration page displays for the handset.

4. Locate to the Programmable Function Keys section, and click Modify. Notice the numbered 
row in the table corresponding to the individual phone PFK.

For handsets with more than 12 PFK buttons or Tx Expander, the user can assign options to 
more than 1 column of PFKs. There are links for the left/right sets of PFK buttons for the 
handsets and the TxExpander.

Handset Preferences 
Group

Displays the current preference group. Click modify to update the current preference 
group. See “Manage Handset Preference Groups” on page 72 for more information.

Template Options Save: keeps the current configuration as a template.
 Apply: select a different handset configuration.

Programmable Function 
Keys

Adjust the PFK assignment options. Click modify to update the current settings. See 
“Manage the Programmable Function Keys (PFKs)” on page 67 for more information.

Interact Appearances Adjust the settings for each appearance. Click modify to update the current setting. See 
“To manage the Call Appearance configuration:” on page 71.
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5. Optional. Click the Show PFK auto-assignment options to manage all unused PFKs at once. 
Click one of the following options: 

6. Click the key number drop-down menu, and select one of the features below for each PFK. 

Assigns Commits selected Stations to all unused PFKs. Check the top checkbox to select or deselect all options 
at once. Click Assign to save the updates or Cancel to disregard the request.

Reset Updates all the BLF PFKs to unused.

Assign Commits selected Line Appearances to all unused PFKs. Check the top checkbox to select or deselect 
all options at once. Click Assign to save the updates or Cancel to disregard the request.

Reset Updates all the Line Appearance PFKs to unused.

Reset All Updates all of the handset PFK definitions to unused.

ACD Appearance Automatic Call Distribution Appearance - users log in and out of the ACD queues. When logged in, the 
user receives and answers calls from the ACD queues. Pressing the PFK toggles between temporarily 
stopping and starting ACD calls to route to the agent. 

Busy Lamp Field 
(BLF)

Monitors and dials another specified phone when setting up the BLF function. When pressing the PFK, 
the behavior of this function depends upon the station Mode selection. 

See “Manage Handset Preference Groups” on page 72 to set station Mode.

Call Appearance Maps to available handset Call Appearances to place or receive calls. 
•  Supports using each Call Appearance for call routing and for managing calls independently and 

concurrently on the same phone.
•  Mapping more than one PFK to the same Call Appearance supports multiple active calls to that Call 

Appearance at the same time. The Call Appearance does not display as busy to the call route until all 
the PFKs defined for that Call Appearance are in use. This is similar to call waiting except the system 
uses the PFKs to alert and select a new call.

Example: Busy Receptionist
•  Requirements: A receptionist gets many phone calls each hour. She wants to answer each call while 

minimizing the possibility of any caller getting a busy signal.
•  Phone Configuration: There is one Call Appearance defined on the phone set up with 8 of the phone 

PFKs mapping to the phone Call Appearance (remaining PFKs support other functions).
•  Discussion: 

•  The first call comes in, the phone rings and the Call Appearance PFK flashes. 

•  A second call comes in. The phone rings and the second Call Appearance PFK flashes.

•  She presses the Hold button to place the first caller on hold and presses the second Call 
Appearance PFK to answer the second caller. 

•  She continues to place callers on hold and answer new calls or switches to another Call Appearance 
PFK to continue/terminate calls.

PBX Behavior The phone dials the designated extension.

Key System Behavior The phone places an intercom connection to the designated phone.
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Call Supervision Enables supervisors to dial in and monitor calls for designated handsets in three modes:

See “Manage Call Supervision” on page 30 for more information.

Emergency Alert Receive audible and visual alerts when any local or remote handset on the system makes an 
emergency call. See “Emergency Alerts and Caller ID” on page 51 for more information.

Function Does one set of functions:

Hot Desk Log in to shared phones, receiving calls, and placing calls using the caller ID. 
•  Users can initiate the login using a Hot Desk PFK (the PFK is solid red but goes off after a user logs 

in) or using the phone Config menu and selecting the Hot Desk Login option.
•  PFKs configured for phones do not change when a new user logs in. The Hot Desk PFK and all other 

PFKs remain as originally configured for the phone.

Line Appearance Monitors the status of an outside line, answers incoming calls on that line, and selects the line for 
outbound calls. When setting up this function for this PFK, the user specifies the line.
To enable outside lines available for selection:
1.  Navigate to Phone System > Outside Lines and go to the Analog (CO) Lines section.
2.  Select the Analog (CO) Line, and click Modify. 
3.  Go to the Outside Line section, and check the Enable Line Appearance check box.
4.  Click Update to return to the Outside Lines page.
Unique Allworx Functionality: an enhanced key-system capability relative to SIP devices and Digital 
Lines. Any SIP proxy, SIP gateway, or Digital Line (T1) bearer channel made available as Line 
Appearance selections when enabled on the respective configuration pages. Through this, the Allworx 
system presents a common key-system use model to all external voice circuit facilities including VoIP 
trunks going to an ITSP.

Messages Monitors the status of a designated handset Message Center voicemail inbox. Press to access the 
inbox. The PFK LED lights red to indicate a new message in the monitored inbox. The Allworx 
administrator must specify the monitored inbox when setting up the PFK.

Not Used No action. Select this choice to disable a previously defined PFK.

Barge in After connecting the call, both participants in the call hear the supervisor. The 
supervisor can transition to silent monitoring by pressing the phone Mute button.

Whisper (Available only when the receiving handset is a 9202E or 9204/9204G series 
handset) – Only the user hears sounds from the supervising phone, not the other 
participant. The supervisor MUTE button controls audio going to the user. The 
supervisor cannot initiate two-way communications with the other participant.

Silent Monitor Neither party in the call hear the supervisor. The Mute button on the supervisor 
handset lights red. The supervisor can speak to the participants of the monitored 
call at any time by pressing (disabling) the Mute button.

Centrex Flash Provides an analog hook flash signal to the CO (when connected to a CO line) to 
perform flash-related actions such as call transfer. This option is only available 
on Allworx 6x, 6x12, or 48x servers.

Headset Turns the Headset on and off. If the handset is off-hook with a headset 
plugged-in, this button toggles the audio between the headset and the handset. 
Note: If using an undefined Headset PFK, the phone speaker button operates 
the headset.

Info Get information regarding the other buttons on the phone.

Park Use a PFK to perform the Park operation. After defining a Park PFK, use the 
Hold button for the dedicated hold function and not the parking operation.

Personal 
Speed Dial

Dials a number programmed directly on the phone. The handset associates the 
uppermost Personal Speed Dial PFK to the lowest Speed Dial entry number.

Redial Redials the last dialed number. Unless the Line Appearance(s) Use of Dial Plan 
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Parking Orbit Assigns a call to any of the Parking Orbits. The PFK lights if there is a call in the parking orbit. 
•  Pressing the PFK retrieves the parked call in that orbit. Parking Orbit PFKs do not function if the 

server is part of a multi-site network and configured to enable other sites to retrieve its parked calls. 
•  Only Allworx IP phones configuration supports Parking Orbit PFKs and parked call reminders.
•  To park calls using analog phones or third-party IP phones is by transferring the call to extension 700. 

If doing an attended (or announced) transfer, the user hears the parking orbit number. 
•  To configure the Parking Orbit PFK:

•  Set the Parking Orbit for the PFK to monitor: 701 – 709 or 4950 - 4999 (extensions may vary per 
system. If using a non-default Internal Dial Plan, consult the My Allworx Manager Phone Functions 
tab to determine what extensions to use for the corresponding feature).

•  Set the Reminder Duration to ring the handset after parking the call longer than the elapsed time 
(enter 0 to disable the reminder or enter a time period from 10 to 600 seconds).

Park Set Monitor Use a PFK to monitor a configurable set of parking orbits or monitor the local parking orbits of a remote 
server in a multi-site environment. The PFK lights if parking calls in any of the set of orbits. 
•  Pressing the PFK displays a list of parked calls in the orbit along with Caller ID and other information. 
•  Users can retrieve one of the parked calls using the UP/DOWN arrow keys and the SELECT button. 
•  Example: use a single PFK to monitor all local park orbits and a single indicator for any call placed in 

a parking orbit. 
•  For multi-site network, use the check boxes to select the parking orbits available.

Push to Talk Provides a one-way, walkie-talkie-like capability. The configured PFK accesses a specific handset. 
•  The user speaks to the target handset user by holding the PFK down and speaking. 
•  To respond, the user of the target handset must place a regular call back to the originator.

Queue Alarm Maps to one of the 10 Call Queues in the system. It notifies the user of the queue activity levels 
(number of calls in the queue and/or longest wait time). The administrator can configure the queue 
alarm to include an audible alarm with the queue status displayed on the phone LCD.

The PFK lights yellow when there are no logged-in agents in the queue and the queue is set to force 
callers to leave the queue when no agents are logged in.

Queue Appearance Maps to one of the 10 Call Queues in the system. It automatically monitors the status of a Call Queue 
and used to answer calls that are in the queue.Configuration settings:

Call Queue Select one of the available Call Queues from the drop-down list.

Login to queue when 
phone reboots

Check the box to enable/disable automatic login after rebooting the phone.

Ring Type
(for more information, 
see “Ring Types” on 
page 55.

Select a unique ring type to distinguish calls to this PFK from other phone 
calls.
•  When set to No Ring, the Queue Appearance never rings. The agent 

uses the LED to monitor when there are calls in the queue. Press the PFK 
to service the next call in the queue.

•  Set to ring (Ring Type other than No Ring) enables the following fields, 
which control when the Queue Appearance rings:

•  Wait Period: Enter a value (seconds) a call must be in a queue before 
the Queue Appearance starts to ring.

•  Number of Callers: Enter a value (number of callers) that must be in a 
queue before the Queue Appearance starts to ring.

•  Wrap-up Time: Enter a value (seconds) the agent has available after 
ending a call before the system makes the agent available to receive the 
next ACD queue call. Agents can dismiss/end the wrap up time from the 
handset. Reboots the agent phone to apply changes to wrap up time.

•  Meet the following conditions for a Queue Appearance to ring:

•  Log in to the station.

•  Queue Appearance is idle.

•  Reach the wait period of number of callers thresholds.

•  Agent is not in the Wrap-up Time.
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10. Locate the next column and click define. Update the PFK settings by selecting an available 
option in the drop-down list. The Emergency Alert and Hot Desk assignments do not have a 
define link. There are no further options to select.

11. Click Done to save the change or Cancel to disregard the request. Repeat for each PFK, as 
necessary.

12. Use Location column use the icons to adjust the order of the programmable function keys. 

13. Click Update to save the changes or Cancel to disregard the request.

To manage the Call Appearance configuration:
The Call Appearance on the Allworx phone is for originating calls. The Call Appearance settings extend 
the number of the features available in programmable function keys by creating virtual keys within the 
Call Appearance software application. 

Ring Group Displays the status of and to answer a Ring Group call. When routing a call to a specified Ring Group, 
all phones ring with a PFK defined for that Ring Group. In addition, Allworx administrators can program 
an Allworx IP phone to display: 
•  Multiple Ring Groups per phone to track more than one Ring Group.
•  Multiple occurrences of the same Ring Group. This enables a user to take more than one call at a 

time from the same Ring Group to avoid missing additional calls while attending to the current call. 

Schedule Displays the mode (day or night) of the configured business schedule. 
•  The LED is off for day mode and solid amber for night mode. 
•  To configure switching the current mode and greeting of the schedule, see “Schedules” on page 121 

for more information.

Shared Call 
Appearance

Supports handling a set of one or more PFKs by the system as a single appearance shared across 
multiple handsets. All handsets in the Shared Appearance have common access to calls and call 
operations within the group of handsets.
•  Selecting this PFK assigns consecutive PFKs, one for each Shared Call Appearance line. 
•  If there are not enough consecutive PFKs available, the PFK assignment fails and an error message 

displays. 
•  If the Shared Call Appearance PFK assignment would overwrite existing PFKs, the system displays 

an error message and enables canceling the operation. 
•  Shared Call Appearance PFKs display consecutively on the PFK configuration page, the Allworx 

administrators can move the assignments to different PFKs limited only by the constraints within the 
particular handset model. 

Speed Dial Automatically dial an extension, PBX function, or System Speed dial. Specify the number when setting 
up the Speed Dial PFK.

Move up  Shifts the current PFK definition up one position.

Move Down  Shifts the current PFK definition down one position.

Delete Removes the PFK and shifts all PFK definitions below it up by one location. Because of the shift, 
PFK definition #1 in each bank of 12 shifts “up” to the bottom (to position number #12) of the bank 
to its left. The last PFK definition on the station becomes Not Used (position #12 of the last bank). 

Insert Shifts all PFK definitions below it down by one position. Because of the shift, PFK definition #12 in 
each bank of PFKs shifts “down” to the top (to position number #1) of the bank to its right. If the last 
PFK on the station (handset or Expander) was in use, its definition will “drop off” the end of the list 
and is no longer configured.
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• The additional virtual appearances are only available when connecting the Call Appearance 
feature to an Allworx IP phone. 

• When connected, the following features display as having additional PFKs beyond the physical 
keys available on the actual phone.

When routing calls from the Call Appearance to applications within the Allworx System (e.g., Auto 
Attendants, Call Queues, or Conference Center), the server uses or overrides the Call Appearance 
language, depending on the application language setting. The handset rings when any of these 
appearances ring.

1. Log in to the Allworx server admin page, navigate to Phone System > Handsets. 

2. Locate the Interact Professional username, and click View Configuration on the specific 
handset.

3. Locate the Interact Appearances section, and click Modify. This opens the Interact 
Appearances configuration page. 

4. Check the boxes to enable the displayed Interact Appearances. Click change to select a new 
Ring Type. For more information on Ring Type, see “Ring Types” on page 55.

5. Click Update to save the changes or Cancel to disregard the request.

12.5 Manage Handset Preference Groups
Each Handset Preference Group is a custom configuration of the handset settings and used to 
configure many handsets easily and efficiently by assigning handsets to the group. The Handset 
Preference Group section displays the available default and custom preference groups.The PBX and 
Key System Default groups contain the factory default handset options for the respective modes.

Use the following procedures to create, manage, and assign a Handset Preference Group.

To manage a Handset Preference Group:
1. Log in to the Allworx server admin page, navigate to Phone System > Handsets > Handset 

Preference Groups section. Click the additional information arrow , if necessary.

Click Show Handsets assigned to each Handset Preference Group to display the handsets 
assigned to each Handset preference group.

•  Call Appearance •  Line Appearance •  Ring Groups (formerly known as Call Monitors)

•  Shared Call Appearances •  Queue Appearance

Note: Settings for existing handsets do NOT change in this process.
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2. Select a default group, and click one of the following links: 

Handset Preference Group Settings

View Displays the Handset Preference Group current options. Click Modify to update. See “Handset Preference 
Group Settings” on page 73 for more information. Click Update to save the changes or Cancel to disregard 
the request.
NOTE: The system software does not enable modifying default Handset Preference Groups. Copy a default 
Handset Preference Group, and then click View > Modify. 

Copy Create a new Handset Preference Group.

Delete Remove the current Handset Preference Group from the server. If the Delete link is unavailable:
1.  Click View, and locate the Handsets Assigned To Group section.
2.  Click Modify, and deselect all the associated handsets.
3.  Click Update, and restart this procedure.

Setting Description
Applies to

Allworx 
Handsets

Reach App

Handset Preference 
Group Name

Description of the Handset Preference Group. Yes Yes

Station Mode Changes the phone behavior to PBX Behavior or Key System Behavior. 
It affects how some of the PFK functions work, see “Manage the 
Programmable Function Keys (PFKs)” on page 67.

Yes No

Interact CLID Selects which call information displays in the Interact and in TAPI-
compliant PC applications that receive calls using the TSP driver. 
Configure the phone to display one option:
•  dialed name/number.
•  regular caller ID name/number information.

Yes No

Call History Size* Specifies the number of calls the station keeps in the call history. If 
specifying a value of zero, the phone does not maintain a Call History to 
help preserve the privacy of the handset user.

Yes No

Clock Mode* Displays phone station clock.
•  Off disables the clock display.
•  12-hour format or 24-hour format. 

Yes No

Codec Preference 
Order

Check the box to select the codecs to use.Click and drag the codecs for 
the preferred codec usage order. Contact the service provider for the 
preferred CODEC order. 
6x12, 6x, 48x: CODEC preference choice must include G.711u.
G.722: is not supported for server audio. 
This setting defines codec selection order and does not support all 
codecs for all call types (example: accessing the Auto Attendant 
requires G.711). 
The phone attempts to use the first choice but uses the codec required 
to support the call.

Yes Yes
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Daylight Saving Time Specifies if the handset uses Daylight Savings Time (DST) to compute 
the local time. 

NOTE: For remote phones, use the DST setting of the actual location 
(available further down the page).

Yes No

Display Date Format Changes the date display order. Options include:
•  MM/DD/YY
•  YY/MM/DD
•  DD/MM/YY
NOTE: If the phone does not display the year (e.g., 9202e phone), the 
month and day matches the order of the selection without the year. 

Yes No

Display Language Changes the Allworx phone display language.
•  Requires Allworx System Software 7.6.6.5 or later. 
•  Requires the Dual Language Support feature key. The phone defaults 

to English during a Factory Reset, functional test mode, or if the Dual 
Language Support feature key is unavailable. 

•  Not available to change the phone display language within the phone 
configuration menu. 

•  Does not support the characters beyond the standard English 
characters, e.g., accented characters are unavailable for user names.

Yes No

Hold Button Mode* Controls the behavior of the phone Hold button: Yes No

Hold Reminder Mode* Reminds the handset user there is a call on hold. Select the reminder 
type from the drop-down list: 

Yes No

Hold Reminder 
Timeout*

Specifics a length of time a call is on hold before the call beeps. Yes No

Setting Description
Applies to

Allworx 
Handsets

Reach App

off Does not use DST.

on Follows US rules for DST.

use current server 
setting

The phone is in the same time zone as the 
server.

Hold Calls, 
Park Lines

Holds calls on Call Appearances. Parks calls on line 
appearances.

Hold then Park Press and release quickly to place the call on hold. If 
the button is pressed for longer, the call is parked.

Park then Hold Press and release quickly to park the call. If the 
button is pressed for longer, the call is held.

No Reminder Does not notify the user.

On Hook Beeps whenever the phone is put on-hook with the 
call(s) on hold.

Timer Beeps after holding the call for the specified period.

On Hook and 
Timer

Beeps after the holding call for the specified period or 
if placing the handset on hook.

Available If Hold Reminder mode is Timer or On Hook and 
Timer.

Unavailable If Hold. Reminder No Reminder or On Hook.

Default 120 seconds.
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Hold Music Selection Determines the hold music such as Line-In or a .snd file. Yes Yes

Jitter Buffer Size Alters the size of the jitter buffer. 
•  Variation in network audio packet; the phone experiences latency, 

resulting in a reduction in audio quality. 
•  Uses a jitter buffer to maximize the audio quality when jitter occurs. 

Yes No

Message Waiting 
Indication
(optional for stations 
with no owner)

Controls the voicemail message indicator on the phone for the handset 
owner. Select an available option:

Yes No

Messages Button 
Operation*

Controls the behavior of the phone Messages Button: Yes No

Missed Call Tracking* Displays the number of calls missed since last making or receiving a 
call. Select which missed calls to track: 
•  Call Appearances Only
•  All Appearance Types

Yes No

Mobile Data Access Enables the phone to access WiFi and Mobile Networks. No Yes

Off Hook Digits Dialed Enables the phone to dial specified digits automatically whenever the 
phone is off hook. 
•  Example 1: a service phone placed at a locked door or loading dock - 

disable all dialing, and the phone automatically dials a predefined 
number when it is taken off hook.

•  Example 2: the phone automatically dials 9* to get an outside line. 
Note:The phone always dials these digits when taking the phone off 
hook, so this might interfere with other uses of the phone. Example: if 
configuring the phone to automatically dial ‘9’, the user cannot use PBX 
features that don’t start with ‘9’ (e.g. Call Park, Call Forwarding, etc.).

Yes No

Paging Mode* Specify the conditions for hearing pages on this handset. Options:
•  Pages Always Accepted.
•  Pages Never Accepted.
•  Pages Only Accepted when the station is on-hook (default).

Yes No

PCP Keep-alive 
Interval

Adjust the communication time between the Interact or Interact 
Professional application and the Allworx handset, if there are network 
problems between Interact and the Allworx phone that are causing 
Interact to disconnect from the phone, extending this interval can avoid 
spurious disconnection and reconnection.

Yes No

Setting Description
Applies to

Allworx 
Handsets

Reach App

No Indication Provides no visual display on the handset.

Visual Illuminates the red LED on the Messages button.

Stutter Dial 
Tone

Emits a stutter from the phone when a dial tone starts 
for each call.

Both Provides a visual indicator and a stutter dial tone.

Displays 
Messages List

Press the Messages button to view and manage the 
voicemail using the phone display. Press the 
Messages button a second time to call the Audio 
Message Center to use audio menus to manage 
voicemail.

Calls 
Message Center

Press the Messages button to call the Message 
Center and use audio menus to manage voicemail.
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Phone Status Visibility Controls how the phone displays in the Interact Directory tab. Yes No

Redial Memory* Sets the length of time the redial memory persists in the phone station. 
Useful to maintain privacy on phones used in shared areas.

Yes No

RTP /RTCP Port Range Specifies the range of UDP ports used for Real Time Protocol audio. 
•  Typically 16384 to 32767 - where the low value must be even 

numbered and the high value must be odd numbered.
•  When placing remote phones behind third-party firewalls, under 

certain conditions, to create mapping rules for each phone behind the 
firewall, greatly restrict the UDP port range.

•  See “Px Expanders and Remote Phones” on page 157.

Yes Yes

SIP NAT Keep-alive 
Interval

Some NAT firewalls automatically time out and close connections to 
devices it protects. 
•  If a remote phone is behind such a firewall, then this setting prevents 

the timeout. 
•  The phone sends messages called keep-alive packets to the Allworx 

server at the specified frequency. 
•  Set the value to an interval that is shorter than the firewall timeout.

Yes No

Server RPC Timeout For use with Hot Desk login timeout. 
•  Adjustable from 3 to 30 seconds for network latency. 
•  Default value is 10 seconds. 

Yes No

SIP Port UDP port number used for the SIP protocol by the phone. Use the 
default value of 5060 unless the handset is behind a 
third-party firewall and the network requires a different value.

Yes Yes

Handset Network 
Template

Select Handset Network Profile Template from the drop-down list to 
download to the handset.

Yes No

Network Settings Determines if the handset uses the selected Network Template or relies 
on the network settings entered on the phone.

Yes No

Time Zone Specifies the time zone used to compute the local time. Yes No

Unannounced 
Transfer Mode

Specifies how the user completes unannounced (blind) transfers 
immediately after dialing the recipient phone number. 

Yes No

* Indicates using the on-handset configuration menu to override the setting.

Setting Description
Applies to

Allworx 
Handsets

Reach App

Normal Displays the extension and the phone status.

Hide Status Displays the extension and the phone status 
always shows as Idle.

Hide Completely Displays neither the extension nor the status.

Use Current Server 
Setting

Phones are in the same time zone as the 
server.

GMT <12-hour clock/
location>

All other phones, including a remote phone.

Requires 
hang-up

Enables the person initiating the transfer to hold on 
the line and speak to the recipient (i.e. perform an 
announced/attended transfer) before hanging up to 
complete the transfer.

Immediate Results in standard system software releases 7.3 
and lower unannounced (blind) transfer behavior. 
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Checkbox Parameters

Audible Dialing* Hear DTMF sounds on the handset or speaker when dialing the phone. 
When disabled, dialing operations are silent.

Yes Yes

Auto On Hold* Place an active call on hold when another call comes in (with a free Call/
Line Appearance PFK) when pressing the PFK for the new call. 
•  Avoids terminating the first call. 
•  Default: enabled.

Yes No

Auto Retrieve Calls* Enables automatic retrieval of a hold call by going off hook. 
•  If disabled, the phone connects to an open line (if available) when 

going off hook. 
•  Default: disabled.

Yes No

Call Supervision Monitor the handset by another handset with a Call Supervision PFK. Yes No

Call Timer Display* Enables the phone LCD displays call duration timers. Yes No

Caller ID Display Enables the phone to display any caller ID information. Yes No

Configuration Menu Enables the phone handset owner to access the configuration menu 
when securing phones located in common areas.

Yes No

DTMF Playout Send DTMF digits during an active call. Yes Yes

Intercom Auto Answer* Answer an incoming Intercom call automatically. 
•  Unchecked (unchecked) - the user must manually go off hook to 

answer Intercom calls.
•  Checked (default: enabled) - automatically answers Intercom calls 

with a live microphone after the alerting tone. 

Yes Yes

Keypad Dialing Initiate or transfer a call via the keypad. 
•  Does not prevent the keypad from functioning during an active call. 
•  Prevents the use of the keypad to initiate functions directly with the 

Allworx server (for example: dial number, Call Park, etc.).

Yes No

Line Appearance(s) 
Use Dial Plan

If not enabled when selecting a Line Appearance PFK to dial a phone 
number, the phone does not display the number, does not include the 
number in the call history, and does not enable the user to redial the 
number. 
A reason for disabling this option is if the CO lines on the system do not 
follow the North American Numbering Plan (including if the lines connect 
to another PBX). The use of this feature requires configuring the server 
dial plan. See “Dial Plan” on page 37).

Yes No

Off Hook Auto Answer* Answer any new call when it goes off hook. Yes No

Off Hook Ringing* Enables the phone to ring if there is an active, incoming call while the 
user is already on an active call. 
•  Disabled (default) - does not ring the phone station, if the user is on an 

active call. 
•  Does not affect the appearance LED indicators and the display 

operation. 

Yes Yes

On Hook Dialing* Dial a keypad number.
•  Does not require picking up the handset or pressing the speaker 

phone button. 
•  Enters speaker phone automatically, if the phone is on hook and the 

user dials a digit on the keypad.

Yes No

Setting Description
Applies to

Allworx 
Handsets

Reach App
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To assign handsets to the Handset Preference Groups:
When adding new handsets, the server assigns the handsets automatically to the Handset Preference 
Group in the active Handset Template. To save time, if the factory default options on the phone are 
not accurate for the site, create a custom Handset Preference Group and incorporate it into a new, 
active phone template before adding the site handsets.

To add handsets manually to Handset Preference Groups:
 

12.6 Manage Handset Templates
To save time and reduce errors while configuring phones, the Allworx server includes templates that 
store phone configurations for each phone type or create specific templates.

To see a list of current templates:
1. Log in to the Allworx server admin page, navigate to Phone System > Handsets.

2. Locate and open (click the additional information arrow , if necessary):

Quick Transfer Enables one-touch call transfers using BLF and Speed Dial PFKs. If 
disabled, pressing a BLF key during an existing call terminates the 
original call, standard in system software releases 7.3 and lower.

Yes No

SNMP Enables using the SNMP agent on the handset with network 
management tools.

Yes No

Visual On Call* Lights the handset Visual Ring Indicator when the handset is off hook. Yes No

Visual Ringing* Lights the Visual Ring Indicator when the phone receives an incoming 
call. If disabled, the user only hears ringing.

Yes No

* Indicates using the on-handset configuration menu to override the setting.

Note: If there is a change to the Display Language setting, the phone displays the current language at the beginning of the 
reboot and displays the new language at the end of the reboot.

View Configuration See “To manage the View Configuration:” on page 67 for more information.

Handsets assigned 
to Group

1.  Log in to the Allworx server admin page, navigate to Phone Systems > Handsets page.
2.  Locate the Handset Preference Groups section and click View. 
3.  Locate to the Handsets Assigned To Group and click Modify. 
4.  Select or deselect the user check boxes to add or remove the user from the Handset Preference 

Group. When removing a handset, it automatically moves to the server PBX Station or Key System 
Station default group. 

Handset Network Profile 
Templates

Displays the current network profile templates. Click View to see the available profile 
templates.

Handset Configuration 
Templates

Displays the list of Active Templates and Handset Templates. Click the phone model link in 
either table to view that template.

Setting Description
Applies to

Allworx 
Handsets

Reach App
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To manage Network Profile Templates:
The phone stores network and registration settings as a Handset Network Profile. Allworx 
administrators can select a Handset Network Profile to avoid manually changing phone settings for 
different situations such as connecting to a second Allworx server for disaster recovery purposes or 
temporarily connecting to the Allworx server from home by selecting a user or server profile.

1. Log in to the Allworx server admin page, navigate to Phone System > Handsets > Handset 
Network Profile Templates, and click the additional information arrow , if necessary.

2. Click one of the following links:

View Displays the Handset Network Profile Template settings. Users cannot change the default templates. For 
non-default templates, click Modify to update:

Note: 
Phone settings can override the Next Phone Reboot setting. To verify the Handset Network setting:
•  Press the CONFIG soft key on the phone, and then press the down arrow key to highlight Preferences. 

•  Press the Select button , and then press the down arrow key to highlight Server Profile Selection. 

•  Press the Select button . Two options display - Use Server Selection or Ignore Server Selection.
•  Select Use Server Selection enable the Handset Network Template setting to take effect, and press the 

Select button .
•  Press the EXIT soft key on the phone twice to get back to the main screen.
For each change, click Update to save the changes or Cancel to disregard the request.

To include a new profile associated with the template, click add profile and update the settings. For existing 
profiles, click modify to update the existing settings or delete to remove the template from the list.

Network Profile Settings

Template Name: Type a new description in the field provided. 

Next Phone Reboot use: Select an option from the drop-down list: 
•  Current Phone Settings
•  Phone Archived Profile
•  <Newly created profile(s)>

Next Phone Reboot use: Select an option from the drop-down list: 
•  Current Phone Settings
•  Phone Archived Profile

Profile Name: Enter a description.

Phone IP: Select an option from the drop-down list: 
•  DHCP
•  Use Phone Setting. 
It is not possible to assign a static IP address to a phone using a Handset 
Network Profile.

VLAN: Select an option from the drop-down list: 
•  Use Phone Setting
•  Disabled
•  Manual
•  Hub Debug Mode
•  CDP Enabled
•  LLDP Enabled
•  Auto Configure
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3. Select Add for more profiles following the steps above.

After creating a template, assign it to the phone using the Handset Preference Groups. Follow the 
procedure “Manage Handset Preference Groups” on page 72 for more information.

To change the handset configuration template:
The current, default template for each phone type lists in the Active Templates section. 

1. Log in to the Allworx server admin page, navigate to Phone System > Handsets > Handset 
Configuration Templates. Locate the phone model number, and click Change in the action 
column.

2. Select a Handset Template from the drop-down list to use as the default.

3. Click Update to save the change or Cancel to disregard the request.

To manage the Handset Templates:

1. Log in to the Allworx server admin page, navigate to Phone System > Handsets.

2. Locate and open the Handset Configuration Templates > Handset Templates section, and 
click the additional information arrow , if necessary, and then click one of the following links: 

View (con’t) Network Profile Settings

Click Add to save the new profile or Cancel to disregard the request.

Copy Duplicates the selected Handset Network Profile Template. Click Update to save the changes or Cancel to 
disregard the request.

Delete Removes the profile from the list. Verify the selected template, and then click Delete to remove the template 
or Cancel to disregard the request.

Note: Allworx administrators cannot change factory default handset templates.

<Template name> Click a default template to view the settings. Click a non-default template to view/modify the settings.

Auto NAT: For remote phone use. When enabled, the phone communicates the server via 
SIP. The server automatically sets up the NAT information at SIP REGISTER 
time of the device. The server uses the device NAT information and 
communicates to the phone what address is receiving packages with the device
and what address the server is receiving packets from so the phone can use it in
media negotiation. Select On or Off from the drop-down list.

Plug and Play Key: Enter a new key.

Boot Server Address: Enter the IP Address or Domain Name.

Time Server Address: Enter the IP Address or Domain Name.

Contact Server IP: Enter the IP Address.

Phone VLAN Settings Enter an ID and Priority number.

PC VLAN Settings Enter an ID and Priority number.
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3. Click the new Handset Template to open the View Template page and select an option:

4. Click Update to save the change or Cancel to disregard the request.

5. Navigate back to the Phone Systems > Handsets window, locate SIP Handsets, and click 
Reboot Allworx Handsets. This reboots the Allworx handsets for the changes to take effect.

To assign a handset template:
1. Log in to the Allworx server admin page, navigate to Phone System > Handsets.

2. Locate the SIP Handsets section, and click the additional information arrow , if necessary. 
Click one of the following links:

3. Locate the SIP Handsets heading and click Reboot Allworx Handsets. This reboots the 
Allworx handsets for the changes to take effect.

12.7 Access Phone Web Administration
Access each Allworx handset using a web interface to view stored configuration information of the 
handset, modify the handset configuration and personal speed dials, and view information (event log, 
call history, phone configuration parameters). The phone web admin page has the same look and feel 
as the Allworx server web admin page, but the password used to access the phone web admin page is 
NOT the same. 

Copy Creates a duplicate of the selected Handset Template.

Delete Removes the Handset Template from the list. IMPORTANT: The Allworx server does not enable 
deleting Factory Default or Active Handset Templates. Requires no further action.

edit name Enter a new description in the field provided. 

Handset Preference 
Group section

Click modify and select a Handset Preference Group from the drop-down list.

Programmable 
Function Keys

Click modify. The Modify PFKs window displays. See “Manage the Programmable Function Keys 
(PFKs)” on page 67 for more information.

Interact Appearances Click modify and check or uncheck the appropriate check boxes to enable or disable the Interact 
Appearances, respectively. 

+ Bulk edit feature - assigns the Handset Preference Group to multiple handsets at once.
1.  Click the check box in the left column to select the phones to apply the Handset Preference Group.
2.  Locate the Handset Preference Group line and select the Handset Template in the drop-down list. Click Apply. 

<User> 1.  Locate the line for the specific phone and click View Configuration. 
2.  Locate the Template Options section and select the preferred template in the drop-down list. Click Apply. 

Note: The server must be able to reach the phone IP Address. Typically, the server cannot reach remote phones.
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To access the phone administration:
1. Log in to the Phone Administration page. To learn the password, see “VoIP Server” on 

page 181 for more information.

2. Access the administration page of an Allworx handset using one of the following options.

12.7.1 Connect Allworx Desk Phones to the Allworx Server LAN
The procedures below describe connecting the Allworx phones to the same LAN as the Allworx 
server. If connecting to a different network, see “Px Expanders and Remote Phones” on page 157.

12.7.2 Manage DHCP IP Addressing
The Allworx phone default is DHCP client enabled. When connecting an Allworx phone to a network 
with a DHCP server, the phone receives the network setup information. 

Phone Registration and Installation
The phone registration requires updating the configuration with the IP Address of the Allworx server as 
well as the network setup. 

• If the network DHCP server is the Allworx server, the phone registers automatically.

• If the DHCP server is not the Allworx server, setup the DHCP server to provide the phone with 
the Allworx server IP Address. Use the TFTP boot server (option #66) in the DHCP data set. If 
the TFTP boot server is set properly, the phone needs no additional configuration.

• If the phone gets the IP address from a non-Allworx DHCP server and the DHCP server does 
not provide the TFTP boot server IP address, manually set the boot server IP address (the 
address of the Allworx server) on the phone. 

• If the DHCP server is the Allworx server or if using a properly configured third-party DHCP 
server, use Plug and Play feature to install the Allworx phone. See “Install with Plug and Play” 
on page 85 for more information.

1. Press the phone CONFIG soft key. Use the arrow buttons to highlight Network Settings, and 

press the Select button . If prompted for a password, enter allworx using the numeric 
keypad, and then press the Select button . The DHCP setting highlights.

2. Use the arrow keys to highlight Edit Boot Server. Press the Select button . Use the numeric 
keypad to enter the Allworx server IP address. Use the asterisk key (*) for periods. When done, 
press the Select button .

3. Press the EXIT soft key repeatedly until asked to save the settings. Press the YES soft key.

Allworx server web 
admin page

1.  Navigate to the Phone System > Handsets page. 
2.  Click handset IP address.

Browser 1.  Enter the IP address of the handset. 
2.  Find the IP address using the handset soft keys: CONFIG > Current Status > Info.
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4. Reboot the phone: press the CONFIG soft key, use the arrow keys to highlight Reboot Phone, 
and press the Select button . Answer Yes to the prompts. The phone reboots and connects 
using the DHCP and manually entered settings.

12.7.3 Manage Static IP Addressing
If assigning the phones static addresses rather than using DHCP, manually enter the following network 
settings on the phone:

• Boot server (the Allworx server IP address or domain name)

• Time Server (optional, can be an IP address or domain name)

• DNS Server IP

• Phone IP

• Netmask IP

• Gateway IP

To update the Static IP Address:

1. Press the phone CONFIG soft key. 

2. Use the arrow buttons to highlight Network Settings, and press the Select button . If 
prompted for a password, enter allworx using the numeric keypad, and then press the Select 
button . The Network Settings menu displays and DHCP highlights.

3. Press the Select button  until the DHCP setting is Disabled.

4. Use the arrow keys to highlight Edit Boot Server. Press the Select button . Use the phone 
keypad, enter the IP address or the domain name of the Allworx server. Use the asterisk key (*) 

for periods. When done, press the Select button .

5. Highlight, select, and enter the remaining settings from the list above. Press the EXIT soft key 
repeatedly until the system prompts to save the settings. Press the YES soft key.

6. Press the CONFIG soft key to reboot the phone, use the arrow keys to highlight Reboot Phone, 

and press the Select button . Answer Yes to the confirmation. The phone reboots and 
connects using the DHCP and manually entered settings.

12.8 Manage VLAN Settings
A network site using VLANs requires additional configuration. Change the setting to Manual to reduce 

Note: To abort an Allworx phone boot cycle:
•  Allworx System Software release 7.4 or higher: press the MUTE/DND button three times. 
•  Allworx System Software release 7.3 or lower (phone firmware version 2.3 or lower), press the RELEASE button 

three times.
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the phone boot time, if:

• the network settings VLAN is set to Auto Configure, and

• connecting the Allworx server to a switch port that does not support a discovery protocol.

The Allworx phones VLAN configuration options are as follows: 

To configure VLANs on the phone:
1. Press the phone CONFIG soft key.

2. Use the arrow buttons to highlight Network Settings and press the Select button . If 
prompted for a password, enter allworx using the numeric keypad, and then press the Select 

button . The Network Settings menu displays and DHCP highlights.

3. Use the arrow keys to highlight VLAN. Press the Select button  until the VLAN setting is 
Manual. Use the arrow buttons to highlight Phone VLAN Settings. Press Select . 

4. Enter the value for Phone VLAN ID, and press the Select button , and then Enter the value 
for Phone VLAN Priority, and press the Select button . 

5. Use the arrow buttons to highlight PC VLAN Settings. Enter the value for PC VLAN ID, and 
press the Select button , and then Enter the value for PC VLAN Priority, and press the 
Select button . 

6. Press the EXIT soft key repeatedly until prompted to save the settings. Press the YES soft key.

7. Press the CONFIG soft key to reboot the phone, use the arrow keys to highlight Reboot Phone, 

and press the Select button . Answer Yes to the confirmation. The phone reboots and 
connects using the DHCP and manually entered settings.

12.8.1 Create On-phone Archive Profile
The Allworx phone can store an On-phone Archive profile using the CONFIG menu on the phone. 
Download additional profiles to the phone from the server using the Handset Preference Groups. 

System software release 
7.2 or higher (phone firmware 
version 2.2 or higher)

Default to VLAN auto configure.

Automatically configured 
Allworx phone

The network utilizes LLDP-MED or CDP to set network host VLAN configurations.

Manually configured 
Allworx phone

If the phone is running an earlier version of firmware or if the network does not use LLDP-MED or 
CDP.

Note: If the phones are running an earlier version of the firmware or if the network does not use LLDP-MED or CDP, it may 
be more efficient to upgrade the phones prior to connecting to the site network. Do this in a lab by connecting the 
phones to an Allworx server that uses the system software release 7.2 or higher.
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To create the On-phone Archive profile:
1. Press the CONFIG soft key on the phone.

2. Use the arrow buttons to highlight Network Settings, and press the Select button . If there is 
already a connection between the Allworx server and the phone and the system prompts for a 
password, enter the password from the Allworx server admin Servers > VoIP page, and then 
press the Select button . The Network Settings menu displays.

3. Use the arrow buttons and the Select button , configure the network settings.

4. Press the ARCHIVE soft key. This saves the current network settings as the Archive profile. The 
Archive profile is when changing the Network Settings and/or rebooting the phone.

12.8.2 Install with Plug and Play
The Allworx administrator may add Allworx phones to the Allworx server using the Plug and Play 
installation. After setting up the network connection to the server, the phones register with the server 
during the next restart or power up. 

To add VoIP phones manually from other manufacturers, see “Manage Handsets” on page 63. 

• If there is difficulty configuring a phone, restore the phone to the factory defaults, and then 
reapply the settings. 

• If rebooting an Allworx IP phone on the network and a new version of phone software is 
available, the phone firmware requests to load the upgrade. 

• When first connecting to the Allworx system, assign an Allworx IP phone to a user or replace an 
existing phone. The following options are available: 

• When using Plug and Play to register a phone, the server displays the phone on the Phone 
System > Handsets page in the SIP Handsets section with the correct model and the MAC 
address.

Caution: The Plug and Play feature enables unauthorized users to add phones to the server without Allworx administrator 
knowledge. To avoid this, disable the Plug and Play installation feature of handsets. See “VoIP Server” on page 181 
for more information. Manually add phones to the system when disabling Plug and Play for security reasons or to 
configure the phone prior to plugging into the network (for example: pre-configure the server before an installation at 
the customer site).

Now > Add Assigns a user to the phone immediately. Select from the list of all system users or limit the list to 
those users with no assigned phones. Reboot the phone to complete the assignment.

Now > Replace Replaces a compatible, existing Allworx phone. Select from the list of the all Allworx system 
phones. The phone web administration password, if any, is required to replace a phone. See “VoIP 
Server” on page 181 to view or change the password. Reboot the phone to complete the phone 
replacement.

Later Defers the user assignment. If there is no existing phone configuration from within the Web Admin 
page, the user assignment prompts display on subsequent reboots.

Via Web Assign the user via the web administration. The user assignment prompt does not display on 
subsequent restarts.



Section 3 - Phone System

Page 86 1 866 ALLWORX * 1 585 421 3850
www.allworx.com

Revised: 03/25/2016

12.9 Test the Phones
Some suggested steps for verifying that a phone is set up correctly:

• dial 4001 for Auto Attendant.

• enter ‘#7’. The Auto Attendant plays back the phone configuration information.

• hang up. The phone rings back.

If any of these steps fail, check:

• physical wiring between phone and server.

• network settings.

• phone and server configuration.

1. Extensions may vary per system. If using a non-default Internal Dial Plan, consult the Phone Functions tab of the 
My Allworx Manager page to determine the extensions to use for the corresponding feature.

Click here to return to the “Install Checklist” .
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Chapter 13 Languages

Languages supports US English and one 
second language for audio prompts. The server 
language configuration supports playing prompts 
in one of two languages. Callers can switch 
between the two languages by pressing ‘##’.

Important points of dual language support:
• Factory-installed primary language: US English. 

• Additional languages: install a Language Pack (available from the Allworx Reseller Portal) and 
select it as either the Primary or Secondary language.

• Assign points of origin of new calls (Outside Lines, Users, and handset Call Appearances) a 
language. The default language is Primary.

• Configure the prompts in the following Allworx system call features to use the language of the 
call point of origin or override it with a specific language:

• Record and save custom greetings for Auto Attendants and Call Queues with a length limit of 15 
minutes per greeting separately for the primary and secondary languages. The custom 
recordings are not a part of the previously downloaded language pack. Therefore, if the primary 
or secondary language changes, the server continues to use the original primary custom 
recordings.To manage the custom recordings, see “Custom Recordings” on page 213 for more 
information.

• Incoming calls to the Allworx system from remote Allworx servers retain the language used by 
the remote system, unless overridden by language settings on the local server. 

Note: To change the handset display to Castilian 
Spanish or Canadian French, see “Handset 
Preference Group Settings” on page 73 for 
more information.

• Auto Attendants* • Call Queues*

• Leaving Voicemail • Phone Features (Call Park, Call Forward, Do Not 
Disturb extensions, Displays)

• Conference Center* • Follow Me*

• Message Center*

* If configured, callers can toggle between languages by pressing ##. Example: An Auto 
Attendant uses Spanish prompts. The prompt speaks in English “To switch to English, press 
##.”

Note: All interconnected Allworx servers must run the same release of software and use the same languages.

Prerequisites

Access 
Permissions

Allworx Server Administrator
Allworx System Administrator
Phone Administrator role*

Feature Key 
Required

Dual Language Support

*Not all features on the Languages page are available to Phone 
Administrators. 
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13.1 Install the Language Pack
The Allworx system default language is US English. After adding the Dual Language Support feature 
key to the system, the Allworx administrator can install one additional language. 

To install an additional language:
1. Download the language pack from the software download page of the Reseller Portal at 

www.allworxportal.com. 

2. Unzip the download and copy the language pack (.alp) file onto the PC.

3. Log in to the Allworx server admin page, navigate to Phone System > Languages and locate 
the Language Pack Installation and Removal section. Click one of the following options:

4. Restart the server for the changes to take effect.

13.2 Manage the Language Settings
Features such as Auto Attendants and Call Queues within the Allworx system play audio prompts. To 
configure outside lines, see “Outside Lines” on page 97. To configure specific handsets, see 
“Handsets” on page 61.

To control the language behavior of the prompts: 
1. Log in to the Allworx server admin page, and navigate to Phone System > Languages. Locate 

the Call Application Language Settings section.

2. Click modify. Locate the feature line and change the settings:

Remove Deletes the currently installed language pack. Be sure this is the language file to delete - there is 
no further action after clicking this button.

Choose File Select the appropriate language pack to install on the server. To install the language pack:
1.  Navigate to the location of the language file on the PC, select the .alp file and click Open.
2.  Click Install. After the installation is complete, locate the Server Language Configuration, and 

click Modify.
3.  Select the new language for the Primary or Secondary language.
4.  Select a second available language (e.g. US English) as the Primary or Secondary language, 

and then click Update to save the change or Cancel to disregard the request.

Answer 
Language

Prompts play in the selected language. Select an option from the drop-down list. 

Enable 
Language 
Change

Enables callers to switch languages when the call reaches an Allworx server feature. To switch languages, 
callers must press ##. To enable callers to change language for the preferred application, check the Display 
Language Change box. 

Automatic Prompts play in the current language. For calls from an outside line or Call 
Appearance, the system uses the call origin default language. If calls come from 
another application (e.g. the call came into a queue from an Auto Attendant), the 
system uses the language from the previous application (e.g. Auto Attendant).

Primary Language Overrides the current language.

Secondary Language Overrides the call current language, if installed.

file www.allworxportal.com
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Configuration Examples
Example 1: A company has clients that speak English or Spanish. English-speaking clients use one 
phone number while Spanish-speaking clients use another phone number. The server configuration is: 

Results:
• English-speaking clients call the English phone number (CO Line 1) and route to Auto Attendant 

1 to hear English prompts as well as a prompt to switch to Spanish. Callers dial the appropriate 
extension. All additional prompts are in English, i.e., leave a voicemail or the Follow-Me-
Anywhere prompt to record.

• Spanish-speaking clients call the Spanish phone number (CO Line 2) and route to Auto 
Attendant 1 hearing Spanish prompts as well as a prompt to switch to English. Callers dial the 
appropriate extension. All additional prompts are in Spanish, i.e., leave a voicemail or the 
Follow-Me-Anywhere prompt to record.

Example 2: A company has a Customer Support operation; the technicians speak English or French 
Canadian. The company has one incoming line for Customer Support calls. The server directs all 
callers to the same Auto Attendant. 

• English-speaking callers dial a shortcut to a support queue serviced by the English-speaking 
technicians. 

• French Canadian-speaking callers switch to a second Auto Attendant, and then dial a shortcut 
to a queue serviced by the French Canadian-speaking technicians.

Language 
Change Prompt

Change the prompt language when reaching an Allworx server feature (except for when leaving a voicemail 
message or when using phone features). Select an option from the drop-down list: 

Configuration Setup

Primary Language English

Secondary Language Spanish

CO Line 1, Default Language Primary, routed to Auto Attendant 1

CO Line 2, Default Language Secondary, routed to Auto Attendant 1

All Applications

Answer Language Automatic

Language Change Enabled

Language Change Prompt Always play

Play if needed The prompt does not play if the caller has already had a chance to change languages 
in a prior application. For example: if a Call Queue Language Change Prompt setting 
is If Needed and directs a routed call to the queue from an outside line, the language 
change prompt plays. If the call came through an Auto Attendant that enables 
language changing, the prompt does not play because the caller already had a 
chance to select a preferred language.

Always play Every time a call reaches the application, in addition to the prompts normally played, 
the prompt plays to change the language (“To switch to English, press ##”).

Never play The prompt to change the language does not play. Used when incorporating the 
prompt to change language to a custom greeting or message. Unavailable for 
Follow-Me-Anywhere prompts.
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The server configuration is: 

Results:
The server directs all callers to Auto Attendant 1 to:

Configuration Setup Configuration Setup

Primary Language English

Secondary 
Language

French Canadian

T1 Language 
(all lines)

English

Auto Attendant 1 Auto Attendant 2

Answer Language Primary Answer Language Secondary

Language Change Disabled Language Change Disabled

Shortcuts •  Dial 1 for x4302 (Auto Attendant 2)
•  Dial 2 for x4401 (Call Queue 1)

Shortcut •  Dial 1 for x4402 (Call Queue 2)

Custom Messages •  “For French Canadian, press 1” 
(recorded in French Canadian)

•  “To speak with Customer Support, 
press 2” (recorded in English)

Custom Message •  “To speak with Customer Support, 
press 1” (recorded in French Canadian).

Call Queue 1 Call Queue 2

Answer Language Primary Answer Language Secondary

Language Change Disabled Language Change Disabled

Option Result

Hear an English greeting Prompts to:
•  Press 1 for French Canadian.
•  Press 2 for Customer Support.

Callers press 1 Enter Auto Attendant 2 
•  Hear the full greeting and prompts in French Canadian.
•  Prompt to press 1 for Customer Support. 
•  Enter Queue 2 to hear the greeting and status messages in French Canadian. A French 

Canadian-speaking technician services the call.

Callers press 2 •  Enter Queue 1.
•  Hear the greeting and status messages in English. An English-speaking technician 

services the call. 

Click here to return to the “Install Checklist” .
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Chapter 14 Message Aliases

Message Aliases enable Allworx administrators 
to add user or group email addresses on the 
Allworx server. 

The Allworx server supports unified messaging, 
which supports:

• combining user voicemail and email 
messages into one inbox.

• forwarding messages to another email account or POP to an email client.

• using a phone to listen, delete, or forward voicemail messages. When deleting a voicemail 
message via a phone, the server inbox deletes the message.

• deleting unified messages from the server due to a POP or mail forward; the server also deletes 
the voicemail, and it is no longer accessible by phone.

14.1 Access Voicemail and Email Messages

To access voicemail and email messages from the server: 
• Forward messages to another email account.

• Use a POP3 or IMAP email client to transfer the messages to a PC. IMAP is only available after 
installing a Mobile VM feature key on the server. See “Email” on page 173 for more information.

14.2 Manage Message Aliases 

Use the server Message Aliases feature to forward any incoming message (voicemail or email) for a 
user to an external (non-Allworx server) email account.

1. Log in Allworx server admin page, navigate to Phone System > Message Aliases. 

2. Determine the Message Alias type (options are as follows):

Note: If saving a copy of each message on the server, users can exceed the server inbox storage space quota. To avoid 
this, users should manage old messages in the Message Center. To delete saved messages for individual users, see 
“Delete User Messages or Recordings” on page 134.

User Message Alias Message sent to a specific user; may include multiple addresses.

Group Message Alias Message sent to a specific group; may include multiple addresses.

Prerequisites

Access Permissions Allworx Server Administrator
Allworx System Administrator
Phone Administrator role

Feature Key Required No
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3. Click one of the following links:

14.3 Avoid Common Mistakes in Forwarding Messages
A common error is assigning the Allworx server domain name the same as an existing domain name. 
An Internet hosting service provides email for employees: user@mycompany.com. Configure the 
email application to POP the email off the hosting service email server for employees to get email. 

When installing the Allworx server, it receives a domain name of mycompany.com. This creates a 
problem when configuring the Internet DNS servers sending mail to user@mycompany.com to the 
external hosting service IP address, but the Allworx DNS server thinks it is responsible for handling 
email for the same domain name. 

The solution is to not use the same domain name for both servers.Put user@mycompany.com in the 
members list for the Allworx server to recognize the username and send the email to itself instead of 
the external IP address. 

To setup external accounts (SMTP, POP3 Client, IMAP Client), see “Email Server Configuration 
Settings” on page 173. When using personal email accounts for External SMTP Accounts or POP3 
Clients, see “User Template Settings” on page 136 for more information.

add new 
alias

Adds another message alias to the server.
1.  Locate the first field and:

2.  (optional) Locate the Message Center Alias field and click the drop-down list. Select the appropriate 
Message Center alias from the list.

3.  Check the Keep copy on server to keep a copy of the voicemail in the Message Center.
4.  Locate the Addresses field and enter the external email address. Click the tab button to add multiple 

addresses.
5.  Click Add to save the new message alias or Cancel to disregard the changes. 

Modify Updates an existing message alias.
1.  Locate the first field and:

2.  (optional) Locate the Message Center Alias field and click the drop-down list. Select the appropriate 
Message Center alias from the list.

3.  Check the Keep copy on server to keep a copy of the voicemail in the Message Center.
4.  Locate the Addresses field and enter the external email address. Click the tab button to add multiple 

addresses.
5.  Click Update to save the new message alias or Cancel to disregard the changes. 

Delete The server removes the message alias. 
1.  Locate the user in the Users list and click Delete in the Action column for the appropriate message alias. 

Read the pop-up message and confirm this is the user to remove from the business directory.
2.  Click Delete to remove the user from the list or Cancel to disregard the request.
No further action is necessary.

User Message Alias Select option from the drop-down list to update the user field.

Group Message Aliases Enter the group name.

User Message Alias Select option from the drop-down list to update the user field.

Group Message Aliases Enter the group name.
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Example 1 

Example 2 

 Example 3 

Example 4 

Requirements Tom (login name tom) does not expect to get email at the Allworx server address, but he uses an external email 
account (tom@yahoo.com). The Allworx server voicemail should go to the external email account and also be 
available from his phone.

Configuration Set up an Allworx server User Message Alias for Tom to forward all messages to the external email account, and 
keep a copy on the Allworx server. Create a new message alias to:
•  Set the email Alias to Tom.
•  Set members to Tom and tom@yahoo.com.

Commentary Tom uses the phone to delete old voicemail messages. If sending an email to the Allworx account, the Allworx server 
forwards it to an external account, leaving a copy on the Allworx server. If email accumulates on the server, Tom 
needs to connect with a POP email client to delete the old messages.

Requirements Tom is a remote user of the system and does not have a phone. The extension configuration sends all calls directly 
to voicemail. Tom wants to access all email and voicemail messages from his external email account 
(tom@yahoo.com).

Configuration Set up an Allworx server User Message Alias for Tom to forward all messages to the external email account. Create 
a new message alias to:
•  Email Alias is set to tom.
•  Members is set to tom@yahoo.com.

Commentary Tom gets all email and voicemail messages using the external email account. Since the system deletes the 
messages off the server after forwarding, Tom does not need to periodically delete anything.

Requirements Tom wants use the Allworx server for his email, and his phone to listen to voicemail messages. Tom does not want 
the voicemail sent to his email account.

Configuration Set up Tom’s Allworx server POP3 Mail Transfer configuration to transfer email messages. Set up Tom’s PC email 
application to POP email off the Allworx server without leaving a copy on the server.

Commentary The server deletes Tom’s email messages as soon POPping to his PC email application. The server keeps Voicemail 
messages until he deletes them via his phone.

Requirements Tom wants to use the Allworx server for email. He wants to use his phone to listen to voicemail messages and wants 
to send those messages to his email account.

Configuration Configure Tom’s Allworx server POP3 Mail Transfers for email and voicemail messages (default). Set up Tom’s PC 
email application to POP email off the Allworx server and leave a copy on the server until deleting the message on 
his PC.

Commentary Tom can to listen to voicemail messages on his phone or PC (via email). If he deletes a voicemail message using his 
phone, it remains on the PC. However, if he deletes a voicemail from the PC, it does not remain on the server, 
making it no longer available on his phone. Tom must periodically delete messages from the PC to avoid exceeding 
the server message quota.

Click here to return to the “Install Checklist” .
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Chapter 15 Music On Hold

Music on Hold provides audio to callers in 
queues, calls held on phones, and parked calls. 
It also supports configuring multiple file sources 
and playing different music to different callers.

Music can come from a Line-In source or from 
electronic files stored on the Allworx server. To 
use a Line-In source, consult the Allworx Server 
Installation Guide.

15.1 Filename Requirements
The Allworx server provides an electronic hold music file (default music file: “moh_supplied.snd”), and 
the Music On Hold file repeats as long as there are callers on hold. If a different style or a site-specific 
music track is necessary, import it onto the Allworx server. See “To import/export greetings and 
messages:” on page 21 for more information.

The system audio (e.g. Auto Attendant greetings) files must be Telephony, raw, mu-law (u-law), mono, 
8-bits per sample, 8KHz sample rate and use the file naming convention:

File name: moh_n_m.snd

• 'n' is a number between 1 and 30. This is a unique number among the Music On Hold files on 
the system. If importing a Music On Hold file that duplicates the number ‘n’ of a file that is 
already on the system, the system replaces the existing file.

• 'm' is a user defined string that uniquely identifies the file. Valid characters include ('A'-'Z'), ('a'-
'z'), ('0'-'9') and underscore.

• Example: moh_1_sales.snd or moh_2_service.snd.

To convert files into the required format for the Allworx server, see “Custom Recordings” on page 213. 

To assign individual Call Queues or ACD queues, see “To manage the Call Queues/ACD settings:” on 
page 27.

Note: Allworx recommends assigning the files to Handset Preference Groups instead of individual Call Appearances. 
Assigning the file to a Handset Preference Group updates the Hold Music Selection preference setting for the group. 
See “Handset Preference Group Settings” on page 73 for more information.

Prerequisites

Access Permissions Allworx Server Administrator
Allworx System Administrator
Phone Administrator role

Feature Key Required No
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15.2 Manage the Music On Hold

To manage the Music On Hold:
1. Log in to the Allworx server admin page, and navigate to Phone System > Music On Hold. 

The following sections display on the page:

2. Locate the Music On Hold Sources section. Locate the file type and click Usage. 

3. Click Update to save the change or Cancel to disregard the request.

File Statistics The memory allocation for imported music file.

Music On Hold Source Individual music file details, assigning music sources to Call Queues, Call Appearances, and 
handset preference groups.

Option Description

Line-In Default music source. Change the selection by going to a different music source, click Usage, 
and check the preferred client(s). Click check all to change all clients to the default option.

None Sets the client to use no Music On Hold. Clicking check all or uncheck all selects or de-selects 
all the clients, respectively. Or click the checkbox next to the individual client(s). Unchecking a 
box next to a client resets that client to the Line-In option.

moh_supplied.snd Sets the client to use custom, supplied files. Clicking check all or uncheck all selects or 
unselects all the clients, respectively. Or click the checkbox next to the individual client(s). 
Unchecking a box next to a client resets that client to the Line-In option.

Click here to return to the “Install Checklist” .
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Chapter 16 Outside Lines

Outside Lines support access to various 
communication lines. Allworx servers support placing 
and receiving calls over the following line types:

Additionally, the Allworx server and Allworx IP phones support a configuration like a Key System. 
Example Configuration:

16.1 Manage Anonymous Call Handling
Anonymous Call Handling is the call routing when the incoming Caller ID is private. Anonymous Call 
detection requires receiving Caller ID information that specifies the calling party has requested privacy. 
The Allworx server default routes anonymous calls normally, unless otherwise specified. 

To manage anonymous call handling:
1. Log in to the Allworx server admin page and navigate to Phone System > Outside Lines.

Allworx Server

Line Type 6x12 6x 48x Connect 

POTS/CO X X X X*

SIP Proxies X X X X

Px Expanders X X X

SIP Gateways X X X

T1/PRI X X**

T1/CAS - T1/RBS X X**

NFAS X

* Applies to Connect 324, 536, and 731 servers only.

** Applies to Connect 731 server only.

Requirement An insurance agency, Best Insurance, has 3 CO lines. 
•  The office has five employees, each having an Allworx phone. 
•  The system behaves like a Key System with a PFK on each phone mapped to each of the CO lines. 
•  Using the PFK, each employee can monitor and directly answer each of the CO lines. If unanswered, an 

incoming call should ring 6 times before routing to a central (not individual user) voicemail for the office.

Configuration 1.  Create a generic user on the system to receive the central voicemail for the office. Call the user “Best 
Insurance”.

2.  Create a system extension to route all incoming calls. Set up the call route so that it has one connection 
attempt with Key System Ring Delay so the Call Appearance (phone) that rings 6 times. 

3.  Configure the call route Finally Route to transfer to voicemail for user “Best Insurance”. For each CO line, 
check the Enable Line Appearance box in “Manage Analog Central Office (CO) Lines” on page 98. 

4.  Configure the call route for each CO line so all calls go to the created system extension. 
5.  Configure a Line Appearance PFK for each CO line on each Allworx phone. See “Manage the Programmable 

Function Keys (PFKs)” on page 67.

Prerequisites

Access 
Permissions

Allworx Server Administrator
Allworx System Administrator
Phone Administrator role*
Network Administrator role*

Feature Key 
Required

No

* Features are available to Phone Administrators or 
Network Administrators, but not both roles.
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2. Locate the Anonymous Call Handling section, and click the additional information arrow , if 
necessary.

3. Click modify. The Anonymous Call Handling window opens. Click one of the following options:

4. Click Update to save the changes or Cancel to disregard the request.

16.2 Manage Analog Central Office (CO) Lines
Central office (CO) lines connect and route telephone calls in the public switched telephone network.

Limitations with CO lines:
If connecting the parties from one CO (POTS) line to another CO (POTS) line, the announced call 
transfer feature does not work. Set up the handset so that all transfers are blind transfers by managing 
the Handset Preference Group > Unannounced Transfer Mode > Immediate option. See “Manage 
User Templates” on page 135 for more information.

To manage an Outside (CO) FXO Line:
1. Log in to the Allworx server admin page, navigate to Phone System > Outside Lines.

2. Locate the Analog (CO) Lines section, and click the additional information arrow , if 
necessary. Locate the Analog (CO) Lines table, and click one of the following links:

Outside (CO) FXO Line Settings 

Routed normally Default setting. Incoming calls continue to follow the specified call route. See “Manage Call 
Routes” on page 57 for more information.

Routed to extension Configure a new number to route private calls normally on the system. Select an extension/
user from the drop-down list.
NOTE: Not all ITSPs support Anonymous Call Handling.

New FXO 
Line

1.  Enter the settings information per “Outside (CO) FXO Line Settings” on page 98.
2.  Click Add to save the change or Cancel to disregard the request.

Modify 1.  Update the settings per “Outside (CO) FXO Line Settings” on page 98.
2.  Click Update to save the change or Cancel to disregard the request.

Delete Removes the Outside (CO) Line from the server. Click Delete to remove the line or Cancel to disregard the 
request.

Outside Line

Description DNIS display on phones that receive calls on this line.

Port Automatically filled in.

Enable Line Appearance Configure the handsets with Line Appearance PFKs for this line.

Default Language Select a language for systems configured with multiple languages to use with Auto 
Attendant and/or queue prompts for inbound callers.
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To setup Fax Server Support and route an outside line to the device:
The Allworx server provides the ability to send control information in the form of DTMF digits to devices 
connected to the server FXS ports. Use a phone extension phone and/or the dialed number (DNIS) 
along with arbitrary DTMF characters to control the following devices:

• Analog FAX servers (e.g. Multi-Tech FaxFinder)
• External paging amplifiers
• External voicemail servers

The server sends the digits immediately after the device answers and before audio from the calling 
source is available. To add the device and configure sending the DTMF digits, see “Manage Analog 
Handsets” on page 61. To receive incoming calls, route an outside line to the attached device port.

1. Create an extension that rings the port of the device. See “Add New Extension” on page 55 for 
more information.

2. Route an outside line to the extension.

Features

Line has Caller ID Service Display the Caller ID information.

Enable Echo Cancellation Only disable at the request of Allworx Customer Support.

Enable Comfort Noise Applies to Allworx Connects servers only. Enable or disable Comfort Noise Generation. 
Default is enabled, only disable at the request of Allworx Customer Support. 

Optimize for short loops Check for FXD/IADs less than 500 feet away, not typically selected.

Send digits as dialed Indicate sending outbound numbers dialed exactly as on the handset placing the call. The 
number converts into NANPA dialing form, so this box is not normally checked. However, 
in some cases, the service provider or proxy may be doing the conversion automatically 
and need to defeat the Allworx server’s conversion mechanism without processing per 
External Dialing Rules.

Prefix Digits Enter automatically dialed digits on the line prior to dialed digits by handsets placing 
outbound calls on this line.

CPC Disconnect timer Default 350 milliseconds.

Pre-dial delay Typically 500 milliseconds.

DTMF Duration Typically 100 milliseconds.

DTMF Gap Typically 100 milliseconds.

Default Auto Attendant Section

Select the attendant used to answer when 
calls received from this source are routed 
to an Auto Attendant.

Select an option from the drop-down list.

Call Route

Calls received from this CO line go to: •  Extension - select from the drop-down list.
•  Auto Attendant
•  Voicemail for user - select from the drop-down list.

Note: For specific device setup instructions for the Multi-Tech FaxFinder, please refer to the application notes located on 
the Allworx Partner Portal at www.allworxportal.com.

www.allworxportal.com
www.allworxportal.com
www.allworxportal.com
http://www.allworxportal.com
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16.3 Manage Direct Inward Dial (DID) Blocks
Direct inward dialing (DID) is a block of phone numbers for calling into a PBX without requiring a 
physical line for each number offered by a local telephone company. Working with the PBX, it maps 
each number to a PBX extension. Each PBX user has a unique outside number that rings the user’s 
phone directly, rather than directing the incoming call to an Auto Attendant. The maximum number of 
DID blocks is 2000.

Setup Checklist
Follow the order of the steps to successfully configure the Allworx server for DID service.

To create a DID Block:
1. Login to the Allworx server admin page, navigate to Phone System > Outside Lines.

2. Locate the Direct Inward Dial Blocks section, and click the additional information arrow , if 
necessary.

3. Click one of the following links:

Step Description Installation Guide Link

1 Create a DID block  “To create a DID Block:” on page 100.

2 Configure the call routing plan for the DID block.  “To configure a Call Routing Plan for the DID Block:” 
on page 101

3 Create a DID line for each DID trunk line plugged into the server.

add new 
DID Block

Creates a new direct inward dialing block. 
1.  Enter the following information:

•  Starting Phone Number (include area code and exchange)

•  Total number of phone numbers in DID block (specified by the telephone company)

•  DID Routing Plan - select the plan from the drop-down list.

2.  Click Add to save the changes or Cancel to disregard the request.
NOTE: If the site phone numbers are over a range of numbers, create DID blocks for each individual or 
grouping of phone numbers. 
•  It is suggested to create a larger DID block that spans multiple DID ranges, even if many of the numbers 

in the block are not in use for easier management of the blocks. 
•  Since there is a limit to the number of assigned DID blocks to any outside line (128 blocks per line), 

combining DID numbers into larger blocks avoids reaching this limit.

Modify Reconfigure the existing settings.
1.  Enter the following information:

•  Starting Phone Number (include area code and exchange)

•  Total number of phone numbers in DID block (specified by the telephone company)

•  DID Routing Plan - select the plan from the drop-down list.

2.  Click Update to save the changes or Cancel to disregard the request.

Delete Removes the DID Block from the system. Verify the DID block selection, and then click Delete to remove the 
DID Block or Cancel to disregard the request
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To configure a Call Routing Plan for the DID Block:
The server uses the Default Extension to map any unassigned phone numbers to an extension.

1. Create the DID block. See “To create a DID Block:” on page 100 for more information.

2. Log in to the Allworx server admin page, navigate to Phone System > Outside Lines. Locate 
the Direct Inward Dial Blocks section. Click the additional information arrow , if necessary. 

3. Locate the Routing Plan and click one of the following links:

Details Routing Plan Information 
1.  Click modify to change the existing settings.

2.  Click Update to save the changes or Cancel to disregard the request.
Phone Number to Extension Mapping
1.  Click modify to change the existing settings.

2.  Click Update to save the changes or Cancel to disregard the request.

Delete Removes the DID Block from the system. Verify the DID Routing Plan selection, and then click Delete to 
remove the DID Block or Cancel to disregard the request.

Description Enter a name for the routing plan.

Default Extension Select the extension from the drop-down list.

Default DNIS 
Name

Displays on calls to DID numbers when no specific DNIS Name is specified in the 
Phone Number to Extension Mapping section, indicated by $ in the DID-specific 
DNIS name.

Enter a Dialed Number Identification Service (DNIS). The DNIS name displays on the 
recipient’s Allworx phone. If there is no DNIS name entered, the originally dialed 
number displays on the phone. 

Default Prompt 
Language
(requires the Dual 
Language Support 
feature key)

Each outside line has a default language. When receiving calls over an outside line, 
the system assigns the default language for that line. Thereafter, when the call 
reaches some applications within the server (e.g. Auto Attendant, queue), the system 
uses or overrides the outside line language, depending on the application’s language 
setting. Select an option from the drop-down list:
•  Use Source of call
•  Primary Language
•  Secondary Language

Search Term Enter criteria and press enter. Displays all numbers meeting the criteria.

Bulk Edit Apply operations to more than one Phone Number. Click the check boxes next to the 
Phone Number, and then click Assign to:

•  Extension

•  DNIS Name

•  Default Prompt Language

<Phone Number> Click Modify and update the information:
•  Extension - Select the extension from the drop-down list.
•  DNIS Name - Leave the $ to use the DID Block Default DNIS name or enter a DNIS 

Name for this DID number.
•  Default Prompt Language - Select the language from the drop-down list:

•  Use Plan’s Default Prompt Language settings

•  Primary Language

•  Secondary Language

•  Use Source of call
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16.4 Manage SIP Proxies and SIP Gateways
Allworx servers support connectivity to external SIP-compliant devices such as Internet Telephony 
Service Provider (ITSP) servers and SIP gateways. The Allworx products interface with four different 
types of SIP devices based the ability to interact with the Allworx system. 

• SIP Gateways and SIP Proxies are different features with similar configurations. 

• The Allworx 6x12 servers do not support SIP Gateways.

 SIP devices include:

Limitations with SIP Outside Lines:
The following calling features are not available when using SIP trunks or SIP Gateways:

• Consultation and call transfer (using *# or *7) by users of Follow-Me-Anywhere call routes.

• Disconnecting calls (using *#) when accessing outside lines through the Message Center.

• These features ARE available when one of the parties in the call is using an Allworx phone or 
Px Expander.

To manage a SIP Gateway or SIP Proxy:
SIP Proxies and SIP Gateways have configuration settings specific to using the ITSP or device. 

1. Log in to the Allworx server admin page, navigate to Phone System > Outside Lines page. 

2. Locate the appropriate section and click the additional information arrow , if necessary. 

3. Click the link. Update the parameters (see table below) specifically for the ITSP service in use.

SIP Proxy Refers to a SIP Trunk, an external SIP service for routing calls. Access the SIP Proxy through the Internet or 
through the wide area network (WAN). 
•  To connect to a SIP proxy (or ITSP), configure the SIP Proxy on the Allworx server. 
•  Application notes for configuring Allworx servers with approved ITSPs are available on the Allworx Partner 

Portal www.allworxportal.com.

SIP Gateway A SIP-compatible device that extends the connectivity of the Allworx PBX. Examples are FXO, FXS or T1 
expander gateways. Typically, SIP Gateways connect to the Allworx server via an Ethernet interface directly 
to the Allworx server LAN.

Remote Allworx 
Servers (Multi-Site)

An Allworx server at another site configured to behave as if it is part of the local system. The Allworx 
administrator can configure the remote Allworx server to provide outside line services for the local server. 
See the Allworx Advanced Multi-site User Guide for information on configuring these services. 

SIP Gateway

add new SIP 
Gateway

Click to open the SIP Gateway dialog box. Update the parameters, and then click Add to save the request 
or Cancel to disregard the request. 

Modify Locate the SIP Gateway in the list and click Modify. This opens the SIP Gateway dialog box. Update the 
parameters, and then click Update to save the request or Cancel to disregard the request. 

Delete Locate the SIP Gateway in the list and click Delete. Verify the SIP Gateway selection, and then click Delete 
to remove the SIP Gateway from the list or Cancel to disregard the request. Requires no further action.

file www.allworxportal.com
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SIP Gateway and SIP Proxy Settings 

SIP Proxies

add new SIP 
Proxy

Click to open the SIP Proxy dialog box. Update the parameters, and then click Add to save the request or 
Cancel to disregard the request. 

Modify Locate the SIP Proxy in the list and click Modify. This opens the SIP Proxy dialog box. Update the 
parameters, and then click Update to save the request or Cancel to disregard the request. 

Delete Locate the SIP Proxy in the list and click Delete. Verify the SIP Proxy selection, and then click Delete to 
remove the SIP Proxy from the list or Cancel to disregard the request. Requires no further action.

SIP Gateway

Description Assign a name to the SIP Gateway - such as the ITSP name. 

Caller ID Name Display the name of handset or user. Enter a up to 47 characters in the field provided or check a box:
•  Use External Caller ID Name from handset
•  Use Caller ID Name from external sources

Caller ID Number Display the name of handset or user. Enter a up to 24 digits in the field provided or check one of the boxes:
•  Use External Caller ID Number from handset
•  Use Caller ID Number from external sources

Number of Line 
Appearances

Enter a number up to 99 that does not exceed the number of CO lines attached to the gateway.

Send digits as dialed Uses the digits as specified in the External Dialing Rules. Check the box to enable.

SIP Server The DNS name or IP address of the proxy server to connect to provided by the ITSP. The port number is 
usually 5060 but verify with the ITSP.

Default Prompt 
Language

Each outside line has a default language. When receiving calls over an outside line, the Allworx server 
assigns the default language for that line. Afterwards, when the call reaches some features within the server 
(e.g. Auto Attendant, Call Queue), the server uses or overrides the outside line language depending on the 
application’s language setting.
The language usage for Allworx audio messages and played greetings for inbound calls is through the SIP 
Proxy. This feature requires the Dual Language Support feature key. Select an option for the default 
language from the drop-down list:
•  Primary Language
•  Secondary Language

SIP Proxy

Description Assign a name to the SIP Proxy - such as the ITSP name.

User ID The ITSP typically assigns this value and is often the account phone number.

SIP Server / Port The DNS name or IP address of the proxy server to connect to provided by the ITSP. The port number is 
usually 5060 but verify with the ITSP.

Outbound Proxy / 
Port

DNS name or IP address of the outbound redirect server, if it differs from the SIP Server. The system does 
not require this in many cases.

SIP Registration 
Required

Use of the SIP proxy server requires a SIP registration. The ITSP assigns the Login ID and Password. If the 
ITSP uses a registrar server that is different from the SIP proxy server, enter the DNS name or IP address of 
this server in the Registrar name field.

Caller ID Name Displays the name of handset or user. Enter a up to 47 characters in the field provided or check a box:
•  Use External Caller ID Name from handset
•  Use Caller ID Name from external sources
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Caller ID Number Displays the name of handset or user. Enter a up to 24 digits in the field provided or check a box:
•  Use External Caller ID Number from handset
•  Use Caller ID Number from external sources

Maximum Active 
Calls

The Allworx server uses this number to limit the total number of the incoming and outgoing active calls with 
the SIP Proxy. Useful for controlling the network bandwidth, since the Allworx system understands that the 
SIP proxy is not a LAN local service.

Number of Line 
Appearances

Enter a number up to 99 that does not exceed the number of CO lines attached to the gateway.

Append Enterprise 
Prefix to Dial back 
number of incoming 
calls.

Adds the enterprise dial plan digits (8 by default, *8 for extension mode) to the beginning of the caller's 
extension of an inbound call from a proxy server.  This enables automatic dial back (e.g., selecting a call 
from the phone Calls list to contact the original caller) to function properly when the proxy server requires 
enterprise dialing for outbound calls.

Send Digits as Dialed Indicate sending outbound numbers dialed exactly as on the handset placing the call. 
•  The number converts into NANPA dialing form, so this box is not normally checked. 
•  In some cases, the service provider or proxy may do the conversion automatically and need to override 

the Allworx server conversion mechanism.

Digits Sent Number of dialed DTMF digits sent to the ITSP when making a call. 
•  If the number specified is fewer than the number of digits dialed, the Allworx server sends only the trailing 

digits. 
•  The default value is all digits.

Default Prompt 
Language

Each outside line has a default language. When receiving calls over an outside line, the Allworx server 
assigns the default language for that line. Thereafter, when the call reaches some applications within the 
server (e.g. Auto Attendant, Call Queue), the system uses or overrides the outside line language depending 
on the application’s language setting.
The language for Allworx audio messages and played greetings for inbound calls is through the SIP Proxy. 

SIP Registration - applies to SIP Gateway only

Gateway uses SIP 
Registration

If the gateway supports registration, select this option. 
•  Assign an arbitrary Login ID and Password for the gateway to use to register with Allworx. 
•  Use this preferred configuration, especially if the gateway uses DHCP to obtain its IP address so that the 

Allworx server always knows how to contact the gateway for outbound calls.

Gateway uses 
Static IP Address

Use if the gateway does not support registration or if not authenticating the gateway. Contacting the 
gateway through this mechanism requires the gateway to have a static IP address. The system does not 
enable DNS names for security reasons.

Advanced Settings* Checking the box enables the option.

Pad DTMF RTP 
packets

Some switches and routers discard any UDP packets shorter than 64 bytes. 
•  Enabled: the Allworx system pads the DTMF packet and expands the RTP header to make the packet at 

least 64 bytes long. 
•  Default: Disabled. 

Enable Early Media Some service providers send audio before answering an outbound call (using 183 Session Progress in SIP). 
Use this to relay announcements (e.g. Your call can not be completed as dialed) or remote ring back tones. 
•  Enabled: the Allworx system presents the audio to the caller when received. 
•  Disabled: the Allworx system disregards the early audio and generates a ring back tone internally. 
•  Default: Disabled. 

Supports SIP REFER Selects the method of transferring calls between multiple remote end-points through the service provider. 
•  Enabled: the Allworx system sends the SIP REFER to the service provider to enable them to connect the 

two end-points within the network without intervention by the Allworx. I
•  Disabled: the Allworx server acts as a proxy between the two remote ends of the calls. 
•  Default: Disabled. 
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Supports SIP Redirect This selects the method of redirecting forwarded inbound calls back to the service provider answering (e.g., 
system forwards all calls to a cell phone). 
•  Enabled: the system sends a SIP 300 redirect message. 
•  Disabled: the Allworx system negotiates the call setup for the service provider. 
•  Default: Disabled. 

Use E.164 format for 
phone numbers

Enabling this feature causes rewriting of phone numbers into the international E.164 format (e.g. 800-555-
1212 becomes +18005551212). 
•  Enabled: if required by the ITSP.
•  Default: Disabled.

Offer ‘100rel’ support Indicate the Allworx supports 'reliability of provisional responses (RFC 3262)'. 
Default: Disabled

Supports Symmetric 
Response Routing

SIP Proxy only - Some service providers assist the remote end in NAT traversal by supporting RFC 3581 
Symmetric Response Routing. 
•  Enabled: a remote handset behind a NAT firewall assumes the service provider can correctly detect the 

audio port to send traffic. 
•  Disabled: port-forward the handset through the NAT firewall, or use the Allworx for proxying of audio traffic 

(see “VoIP Server” on page 181). 
•  Default: Disabled. 

Allow SIP 
P-Asserted-Identity 

SIP Proxy only - The server asserts its identity with enabled proxies as well as proxy asserted identity from 
trusted devices to other trusted devices. 

Send SIP Division 
header row

SIP Proxy only. Select an option from the drop-down list:
•  never
•  always
•  on redirect

Obtain DID/DNIS 
number from [source]

For inbound calls, where the server gets the DID and DNIS information. Typically, this is set to [SIP To: 
header field].

Use [source] in 
Request URI of 
outbound calls

This defines the username parameter of the SIP Request Uniform Resource Identifier (URI) for outbound 
calls to the service provider. 
•  Most service providers expect to have the requested number or ID [dialed number] in this field, but some 

require the registered account information [address of record]. 
•  Typically this is set to [dialed number].

* These settings are specific to the ITSP. For instructions on configuring them for Allworx partner ITSPs, download the ITSP Application 
Notes from www.allworxportal.com.

Features

Prefix String Define the DTMF digits pre-pended to the dialed number string when placing outbound calls through the 
gateway (e.g., ‘9’ for dialing through another SIP PBX).

Default Auto Attendant

Select the auto-attendant to use from the drop-down list when routing inbound calls from this Proxy to an Auto Attendant. 

Call Route
Each outside line (CO Line, DID Line, SIP Proxy, SIP Gateway, or a Digital Line) has an associated call route. The Call Route section 
directs the call coming into the system through Digital Line 1 channel 01. 

Calls received from 
this SIP Gateway 
go to:

Click a radio button to select the option:

Extension Routes incoming calls to a User or System extension. Using a System Extension 
provides more call routing flexibility and enables using a common route for 
multiple lines. Select an extension from the drop-down list.

Auto Attendant Routes an outside line to a designated Auto Attendant defined in the Default 
Auto Attendant section. Requires no further action.

Voicemail for user Sends incoming calls directly to a voicemail box for a User. Select a user from 
the drop-down list.

www.allworx.com
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16.5 Manage Enterprise Dialing
Use the following procedures to configure the Enterprise Client and the Central Hub/Enterprise 
Server.

16.5.1 Configure the Allworx Enterprise Client
Configure each Allworx server as an enterprise client and direct inter-office calls to the central hub. 
The system creates a SIP Proxy for the central hub with the call routing set to Proxy is an enterprise 
server. 

The Enterprise Dialing rule is set to a service group that contains just the SIP Proxy entry for the 
central hub server. The number of digits to collect/send is set to cover the entire enterprise. See 
“Internal Dial Plan Settings” on page 39 for more information.

The Allworx dial plan uses an ‘8’ prefix1 to indicate forwarding the dialed number to the Enterprise 
Server. Example: dialing 81234 sends a SIP INVITE with a URI of <sip:1234@centralHubServer> to 
the Enterprise Server.

16.5.2 Configure the Central Hub / Enterprise Server
The central hub is a SIP proxy server that:

• accepts incoming INVITEs from the Allworx servers.

• determines the final destination for the request.

• forwards the request to the Allworx destination. 

• maintains an active list of Enterprise extensions and the mappings to extensions at each site. 

Calls received from 
this SIP Gateway 
go to:
(con’t)

1. Extensions may vary per system. If using a non-default Internal Dial Plan, consult the My Allworx Manager > 
Phone Functions tab to determine what extensions to use for the corresponding feature.

Routed using DID 
Block(s)

When using DID blocks for incoming calls, enable the DID block for the outside 
line or each preferred channel, if using digital lines. check the box to enable a 
DID block.
To configure the DID Lines:
1.  Configure each of the incoming lines using DID blocks.The following line 

types can use DID blocks:

2.  Click on Routed using DID Block(s) and check the block(s) to use for this 
outside line.

NOTE: For Digital lines, do this for each channel. If all channels use the same 
settings, check the Apply settings for this line to all lines with the same Port box.

•  T1/PRI •  SIP Proxy

•  T1/RBS •  SIP Gateway
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Example: an enterprise with four-digit dialing might have the following information in its databases. 

Configure the Enterprise extensions as follows (using three-digit extensions):

Example: Chris Jones in New York City dials 84689 to reach Mike Zwick. The SIP INVITE is sent 
to the central hub with a URI of <sip:4689@centralHubAddress>. The Central Hub validates the sender 
credentials and finds 4689 in the databases. It creates an INVITE with <sip:108@64.129.42.33:5060> 
as the URI and sends it to allworx2. Mike Zwick answers the phone and establishes the call.

Later, Chris Jones dials 81452 to reach Tom Roberts. The SIP INVITE is sent to the central hub 
with a URI of <sip:1452@centralHubAddress>. The Central Hub validates the sender credentials and 
finds 1452 in its databases. The recipient is on the same server as the sender (allworx1), so the hub 
responds with a 300 Redirect with a Contact header URI of <sip:111@66.64.219.38:5060>. The 
Allworx server (allworx1) initiates a call to extension 111. Tom Roberts answers the phone and 
establishes the call.

To access Enterprise Dialing: 

1. Log in to the Allworx server admin page and navigate to Phone System > Outside Lines and 
Click one of the following links:  

2. Locate the Call Route and check Proxy is an Enterprise Server to indicate the SIP Server is 
an Enterprise central server. Calls received from this proxy follow the server internal dial plan.

3. Click the Update button to save settings.

Site Account Name Account Password Current Address* Site Description

allworx1 ***** 66.64.219.38:5060 New York City office

allworx2 ******** 64.129.42.33:5060 Atlanta office

allworx3 ***** 129.116.21.193:5060 San Diego office

* IP Address and SIP Protocol port of the Allworx server. This can be static or updated through periodic SIP Registration. 

Enterprise Extension User User Extension Site

1234 Chris Jones 108 allworx1

1452 Tom Roberts 111 allworx1

4689  Mike Zwick 108 allworx2

5999 Jason Diaz 177 allworx3

Note: The steps for configuring and maintaining the SIP centralized server are well beyond the scope of this document. To 
deploy such an arrangement across sites requires detailed knowledge about the use and administration of SIP proxy 
servers. Contact Allworx Customer Support for an application note with additional helpful administration. 

add new SIP Proxy Adds another SIP Proxy to the Central Hub.

Modify Locate the SIP proxy that is the target for the Central Hub, click Modify to update the settings.
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16.6 Manage Digital Lines
Allworx refers to the integrated T1 interfaces on Allworx 24x, 48x, and Connect servers as Digital 
Lines. Connect servers have one T1 Digital Line interface. Allworx 24x and 48x servers have two T1 
Digital Line interfaces. There are differences in T1 port functionality between the 24x and 48x servers. 
For more information about Digital Lines or configuring the T1 line, see “Digital Lines” on page 147. 

To manage the Digital Lines:
1. Log in to the Allworx server admin page, navigate to Phone System > Outside Lines page. 

Locate the Digital Lines section and click the additional information arrow , if necessary. 

2. Locate the Digital Line and click modify. The Digital Line settings page opens. If the T1 option 
is unavailable, see “Configuration” on page 143 to enable the T1 port.

3. Update the settings, as required, and then click Update to save the changes.

Digital Lines Settings 

16.6.1 Allworx Port Expanders
See “Px Expanders and Remote Phones” on page 157 for more information.

Digital Line

Description DNIS display on phones that receive calls on this line.

Port Automatically filled in.

Default Language Select a language for systems configured with multiple languages to use with 
Auto Attendant and/or queue prompts for inbound callers.

Enable Line Appearance Configure the handsets with Line Appearance PFKs for this line.

Features

Line has Caller ID Service Display the Caller ID information.

Enable Echo Cancellation Only disable at the request of Allworx Customer Support.

Enable Comfort Noise Applies to Allworx Connects servers only. Enable or disable Comfort Noise 
Generation. Default is enabled, only disable at the request of Allworx Customer 
Support. 

Default Auto Attendant Section

Select the attendant used to answer when 
calls received from this source are routed 
to an Auto Attendant.

Select an option from the drop-down list.

Call Route

Calls received from this CO line go to: Click the radio button to select one of the following options:
•  Extension - select from the drop-down list.
•  Auto Attendant
•  Voicemail for user - select from the drop-down list.
•  Routed using DID Blocks(s):

Click here to return to the “Install Checklist” .
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Chapter 17 Paging

Paging provides communication over a speaker at 
specific areas in a building. The Allworx server 
supports up to 10 paging zones via a single paging 
circuit and one active page at a time. Any attempts to 
page during another page results in a fast, busy 
signal. The types of Paging are: 

• Overhead Paging - the audio exits through 
the LINE IN/OUT jack or terminal block of the associated server. If used at a site, connect the 
LINE IN/OUT jack or terminal block to a paging amplifier or a Public Address Announcement 
system.

• Zoned Paging - a set of phones emitting the same class of pages. Each handset can be in 
multiple zones. The system assigns any combination of zones to the Overhead Paging circuit for 
those pages also play the audio out to the LINE IN/OUT jack or terminal block.

17.1 Manage Paging Amplifier / Door Release Relay
Allworx server internal relay controls a door release mechanism. Users dial a phone extension for entry 
into a secured area. The relay contacts are available via the DB-9 connector (9-pin D shell serial type 
connector) or the Allworx server terminal block. See the Allworx Server Installation Instructions for 
more detailed information.

To manage the relay option mode:
1. Log in to the Allworx server admin page, and navigate to Phone System > Paging. 

2. Click modify. Select the operation mode from the drop-down list.

3. Click Update to save the changes or Cancel to disregard the request.

17.2 Manage Paging Zones
Use the following procedures to change the paging zone name, manage the paging zone settings, or 
manage the paging zone operation on handsets.

DB9 is connected to a 
Door Entry System

Dial extension 403* to remotely enable access. The relay activates for the duration of the 
phone call or five (5) seconds, whichever is shorter.

DB9 is connected to a 
Paging Amplifier

Automatically activates immediately preceding each overhead page, and then turns back off 
when the page is complete.

DB9 is unconnected. Disables the relay; it does not operate through either mechanism.

* Extensions may vary per system. If using a non-default Internal Dial Plan, consult the My Allworx Manager Phone Functions 
tab to determine what extension to use for the corresponding feature.

Prerequisites

Access Permissions Allworx Server Administrator
Allworx System Administrator
Phone Administrator role

Feature Key Required No

http://www.allworxportal.com
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To change the paging zone name: 
1. Log in to the Allworx server admin page, navigate to Phone System > Paging.

2. Locate the Paging Zone Names section and click modify to update the information:

3. Click Update to save changes or Cancel to disregard the change. Any changes to paging zone 
names require a handset reboot. Otherwise handsets with a PFK defined for those paging 
zones do not use the new name.

To manage Paging Zones on an Allworx handset: 
By default, the system enables each applicable line out and handset for Paging Zone 0 and disables 
all others. 

1. Log in to the Allworx server admin page, navigate to Phone System > Paging > Paging Zones 
section and click modify. A table of handset users and Paging Zones displays.

2. Check the appropriate boxes for each user and Paging Zone to enable the feature.

3. Click Update to save the changes or Cancel to disregard the changes.Any changes to paging 
zone assignments require a handset reboot. 

To manage the paging zone operation on handsets:
The Allworx administrator can enable or disable the Paging Zones on the handset configuration page. 
See “Handset Preference Group Settings” on page 73 for more information.

Link Description

Multi-Site Paging Groups

Modify Enter an updated description in the New Name field, and then click Update to save the change or 
Cancel to disregard the request.

Delete Deletes a multi-site paging group from any of the zones using the group. Click Delete to save the 
change or Cancel to disregard the request.

Add new group Enter a description in the New Group Name field, and then click Add to save the change or Cancel 
to disregard the request.

Paging Zone Names

Name Click in the Name field and enter an updated description.

Prepage Tone Play a tone before the paging message starts. The system default tone is enabled. Users placing a 
page hear a tone to indicate that the channel is open to begin speaking.

Multi-Site Group Enables handsets to become part of paging zones that span multiple sites. For Multi-Site Paging, 
see the Allworx Advanced Multi-Site User Guide for more information.

* Extensions may vary per system. If using a non-default Internal Dial Plan, consult the My Allworx Manager Phone Functions 
tab to determine what extension to use for the corresponding feature.

Click here to return to the “Install Checklist” .
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Chapter 18 Ring Groups

Ring Groups (formerly known as Call Monitors) 
are call routing destinations that enable ringing 
one call to multiple phones and multiple calls to 
a single Ring Group. Calls are answered in first 
in, first out order. 

A call enters a Ring Group when routed from a 
system or user extension. Configure the server 
so that inbound calls enter a Ring Group is the same as configuring any inbound call routing. Use the 
same features for the handling of any inbound call to route a call to a Ring Group by sending the 
outside call to the Auto Attendant or routing directly to the Ring Group extension.

Ring Groups Features:
• Up to ten available Ring Groups (numbered 0 through 9).

• Configure the Ring Group.

• Ring multiple Allworx IP phones on the system with a single call.

• Stack multiple ringing calls to a single Ring Group extension.

• Configure Allworx handsets for multiple Ring Groups.

• Configure Allworx handsets for multiple occurrences of the same Ring Group.

To configure calls to route to the ring group, see “Manage Call Routes” on page 57 for information on 
setting up call routes. Both user extensions and system extensions can be set up to route a call to a 
Ring Group.

To configure calls to route to an Auto Attendant, see “Auto Attendants” on page 17 for more 
information.

To configure a Ring Group PFK, see “Manage the Programmable Function Keys (PFKs)” on page 67 
for more information. 

To modify the description of the Ring Group: 
1. Log in to the Allworx server admin page, navigate to Phone System > Ring Groups.

2. Locate the Action section, and then select Modify.

3. Enter a new Ring Group Description in the description field. 

4. Click Update to save the changes or Cancel to disregard the request.

Click here to return to the “Install Checklist” .

Prerequisites

Access Permissions Allworx Server Administrator
Allworx System Administrator
Phone Administrator role

Feature Key Required No
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Chapter 19 Roles

Roles assigns user permission levels to users 
for delegating some of the administrative task 
management using the assigned Allworx 
username and password.

See “Role Permissions” on page 114 for the 
administrative tasks and delegation permissions. 

The available user roles include:

• Server Administrator: predefined 
system administrator with access to 
manage all functions of the server. The Allworx Server Administrator assigns roles, manages the 
server administrative functions, manages day-to-day phone system settings, manages the 
network and VoIP settings, and initiates system backups and/or restarts.

• System Administrator: access to manage the administrative functions of the server. The user 
permission setting does not enable this role to change the password of the Allworx Server 
Administrator. However, the Allworx Server Administrator can change the password of the 
System Administrator.

• Phone Administrator: access to manage day-to-day phone system settings including changes 
to system recordings as well as adding, changing, and deleting users, extensions, and 
handsets.

• Network Administrator: access to manage the Network and VoIP settings, as well as SIP 
proxies and SIP gateways outside lines.

• Support Technician: access to initiate system backups and restarts as well as managing 
logging operations. 

19.1 Manage the User Roles

To assign or remove user roles:
When changing the user role and the user is logged into the server, the user must log out and re-login 
in order to access the changes.

Note: To enable one user to have roles on different servers in a multi-site network, the Allworx administrator must create 
separate user accounts for the user on each server, and then assign the roles on each server. Use different 
usernames for each user account.

Note: The Allworx administrator can assign users to manage queue and Auto Attendant recordings. See “User Template 
Settings” on page 136 for more information.

Note: The Allworx administrator can assign users to manage individual queue settings or queue supervisor. See “User 
Template Settings” on page 136 for more information.

Prerequisites

Access 
Permissions

Allworx Server Administrator
Allworx System Administrator
Phone Administrator role*

Feature Key 
Required

No

* Not all features on the Roles page are available to Phone 
Administrators. These features require Allworx Server 
Administrator or Allworx System Administrator permissions.
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1. Log in to the Allworx server admin page, and navigate to Phone System > Roles. The Roles 
page displays. 

2. Locate the section of the role, and click the additional information arrow , if necessary. The 
Allworx Server admin page displays a list of users assigned to each role.

3. Click one of the following links: 

19.2 Role Permissions
Each assigned user role has access to specific management tasks. Use the table to identify the 
administrative management access level of each User Role.

show unassigned users Displays a list of assigned and available users to assign.

hide unassigned users Displays a list of assigned users.

Assign Role Enable role permissions to the user account. Designated users have access to the 
administration functions that are included in the roles. See “Role Permissions” on page 114 for 
more information.

Remove Role Remove the assigned role privileges the user account.

Allworx 
Server Page

Link Phone Network Support

Home Allworx Server Model Number Yes Yes Yes

Home Install Checklist No No No

Home Logout Yes Yes Yes

Phone System

Audit PIN Codes add new PIN Code > modify Yes No No

Configuration - modify Yes No No

Delete Yes No No

Auto Attendants Auto Attendant n modify Yes No No

reset Yes No No

Call Park Call Park Modify Yes No No

Multi-Site Parking Modify Yes No No

Call Queues / ACD manage the custom recordings link Yes No No

View the language settings No No No

Call Queue n Modify Yes No No

Queue Streaming Settings Modify Yes No No

Queue Busy Reasons modify Yes No No

Conference Center Conference X modify Yes No No

Conference X delete

Contact Information Modify Yes No No
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Dial Plan Reboot phones Yes No No

Internal Extension Length > modify No No No

Internal Dial Plan > modify No No No

Internal Dial Plan > view phone functions reference card No No No

External Dialing Rules > Modify NANPA No No No

External Dialing Rules > Modify Area Code / Exchange No No No

External Dialing Rules > Modify Emergency No No No

External Dialing Rules > Modify Emergency Call Email Notification No No No

Services > Modify No No No

Dialing Privileges Groups > View Yes No No

•  Modify Yes No No

•  Toll Restriction > Modify Yes No No

•  Call Appearances Assigned to Group > Modify Yes No No

Dialing Privileges Groups > Copy Yes No No

Dialing Privileges Groups > delete Yes No No

Service Groups “add new Service Group” No No No

Service Groups “modify” No No No

Service Groups “copy” No No No

Service Groups “delete” No No No

Emergency CID Emergency Caller ID number > add new caller ID number Yes No No

Emergency Caller ID number > Modify Yes No No

Emergency Caller ID number > Delete Yes No No

Handset Emergency Caller ID Number Assignments >  Modify Yes No No

 Extensions add new extension Yes No No

view call routes Yes No No

delete Yes No No

<username> Yes No No

Bulk Edit Yes No No

 Handsets
Analog Handsets

•  New Analog Handset Yes No No

•  Modify Yes No No

•  Delete Yes No No

•  Ring Yes No No

SIP Handsets •  Reboot Allworx Handsets Yes No No

•  add new Allworx Handset Yes No No

•  add new Allworx Reach Handset Yes No No

•  add new Generic SIP Handset Yes No No

Allworx 
Server Page

Link Phone Network Support
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SIP Handsets
(con’t)

•  Bulk Edit Yes No No

•  handset preference group Yes No No

•  View Yes No No

•  Copy Yes No No

•  Delete Yes No No

•  View Configuration Yes No No

•  Add Call Appearance Yes No No

•  Reboot Yes No No

•  Replace Yes No No

•  Modify Yes No No

•  Delete Yes No No

•  Ring Yes No No

Handset Preference 
Groups 

•  View Yes No No

•  Copy Yes No No

•  Delete Yes No No

Handset Network Profile 
Templates 

•  View Yes No No

•  Copy Yes No No

•  Delete Yes No No

Handset Configuration 
Templates 

•  Change Yes No No

•  Copy Yes No No

•  Delete Yes No No

Languages Manage the custom recordings Yes No No

Export Primary/Secondary Language Recordings Yes No No

Import Primary/Secondary Language Recordings No No No

Language Pack Installation and Removal No No No

Server Language Configuration No No No

Call Application Language Settings No No No

Message Aliases add new alias Yes No No

modify Yes No No

delete Yes No No

Music on Hold manage Yes No No

Usage Yes No No

Outside Lines
Analog CO Lines

Anonymous Call Handling < modify Yes No No

•  new FXO line Yes No No

•  modify Yes No No

•  delete Yes No No

Digital Lines > modify Yes No No

Allworx 
Server Page
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Direct Inward Dial Blocks •  add new DID block Yes No No

•  modify Yes No No

•  delete Yes No No

Direct Inward Dial 
Routing Plans

•  Details Yes No No

•  Delete Yes No No

SIP Gateways •   add new SIP Gateway No Yes No

•  modify No Yes No

•  delete No Yes No

SIP Proxies •   add new SIP Proxy No Yes No

•  modify No Yes No

•  delete No Yes No

Paging Paging Amplifier > modify Yes No No

Paging Zone Names > modify Yes No No

Paging Zones > modify Yes No No

Roles System Administrator [Assign Role] [Remove Role] No No No

Network Administrator [Assign Role] [Remove Role] No No No

Phone Administrator [Assign Role] [Remove Role] Yes No No

Support Technician [Assign Role] [Remove Role] No No No

Schedules Greetings > modify Yes No No

Schedule n > Copy Yes No No

Schedule n > Delete Yes No No

Schedule n > modify Yes No No

Schedule n > add holiday Yes No No

Schedule n > copy holiday Yes No No

Schedule n > delete holiday Yes No No

Schedule n > modify holiday Yes No No

Shared Appearance add new Shared Call Appearance Yes No No

Modify Yes No No

Show Handsets Yes No No

Delete Yes No No

Speed Dial add new speed dial number Yes No No

modify Yes No No

delete Yes No No

Users add new user Yes No No

add users from CSV file Yes No No

Modify Yes No No

Delete Yes No No

Allworx 
Server Page
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Users
(con’t)

more...

•  delete messages Yes No No

•  delete recordings Yes No No

•  Wipe remote devices Yes No No

<extension> Yes No No

Bulk Edit Yes No No

show/hide templates last applied to user Yes No No

User Templates > View Yes No No

User Templates > Copy Yes No No

User Templates > Delete Yes No No

Password Requirements > modify No No No

Network

Configuration modify No Yes No

Multi-Site modify No No No

advanced No No No

handsets No No No

delete No No No

test No No No

Port Expanders add a port expander No Yes No

delete No Yes No

replace No Yes No

handsets No No No

outside lines No No No

px description view No Yes No

View > Modify No Yes No

View > Delete No Yes No

View > Replace No Yes No

View > Handsets No No No

Port Expander > Outside Lines No No No

View > Reboot No Yes No

Static Routes modify No Yes No

VPN modify No Yes No

Servers

DHCP modify No Yes No

Active Leases No Yes No

Known Hosts No Yes No

Allworx 
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DNS flush the cache No Yes No

modify No Yes No

Email manage the email queue No Yes No

modify No Yes No

Reach Link modify No Yes No

SNMP modify No Yes No

VoIP modify Yes Yes No

Web modify No Yes No

Reports

About Yes Yes Yes

Allworx View Allworx View Settings > modify Yes No Yes

Auto Notification No No No

Call Details modify Yes No Yes

Completed Call Details Report 

•  delete Yes No Yes

•  View Report Yes No Yes

•  Export TSV Report Yes No Yes

•  Export XML Report Yes No Yes

Configuration Generate XML Report No No Yes

View No No Yes

Digital Lines Digital Line n > Clear Report No Yes Yes

Digital Line n > Refresh Report No Yes Yes

Live Calls Refresh Now No No Yes

Resource Summary check server compatibility Yes Yes Yes

System Events Download No No Yes

show Severity Filter No No Yes

Users <username> Yes No No

Delete Messages Yes No No

Maintenance

Backup modify No No No

Backup Now Yes Yes Yes

Custom Recordings File Export > File Naming Conventions Yes No Yes

Export Yes No Yes

File Import > Choose File Yes No Yes

Allworx 
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Feature Keys Install Yes Yes Yes

Submit Yes Yes Yes

Reach Yes Yes Yes

Generic SIP Handsets Yes Yes Yes

Interact Professional Yes Yes Yes

Import / Export Export Configuration > Export Yes Yes Yes

Import Configuration > <Choose File> No No No

Import Configuration > Load No No No

Restart Restart Now Yes Yes Yes

Restart Later Yes Yes Yes

[x] Restart Server Yes Yes Yes

[x] Restart Phones Yes Yes Yes

Time Modify Yes Yes Yes

Tools Network Diagnostics Yes Yes Yes

Syslog - System Events Yes Yes Yes

Allworx Technical Support Server Yes Yes Yes

Advanced Troubleshooting Yes Yes Yes

Network Address Translation (NAT) Information Yes Yes Yes

Four Wire Return Loss Measurements Yes Yes Yes

Network Statistics Logging Yes Yes Yes

Packet Capture Tool Yes Yes Yes

Telnet Yes Yes Yes

Advanced Troubleshooting > Advanced Diagnostics Yes Yes Yes

Update No No No

Click here to return to the “Install Checklist” .

Allworx 
Server Page

Link Phone Network Support



Allworx System Administrator Guide Version 8.1

1-866-ALLWORX * 585-421-3850 Page 121
www.allworx.com
Revised: 03/25/2016

Chapter 20 Schedules

Schedules plays the appropriate greetings of the 
Auto Attendants based on the time of day and 
switching between open and closed modes for 
call routes of system extensions automatically or 
manually.

The Allworx administrator can define multiple 
schedules and configure each system extension 
or Auto Attendant to follow any one of the defined schedules. A schedule consists of defined daily 
periods, associated open/closed modes, and Auto Attendant greeting names. The Auto Attendant 
plays the schedule greeting first, and then plays the custom message.

To assign a schedule to an Auto Attendant, see “Configure the Auto Attendant” on page 17 for more 
information.

20.1 Manage the Greetings
Each business schedule can use up to nine (9) different greetings. The greetings numbers are 0– 8. 

• Greeting 0: fixed description of Open.

• Greeting 1: fixed description of Closed. 

• Greetings 2 through 8: a unique, customer-defined greeting name for each greeting used on the 
Auto Attendants on the Allworx server.

To manage the greeting names:
1. Log in to the Allworx server admin page, navigate to Phone System > Schedules. 

2. Locate the Schedule and click Show Greeting Names for this schedule.

3. Click modify and enter the new name in the field.

4. Click Update to save the changes.

20.2 Manage the Schedules
Use the following procedures to manage the schedules and settings as well as assign the schedules.

To manage the schedules:
1. Log in to the Allworx server admin page, navigate to Phone System > Schedules. 

Prerequisites

Access Permissions Allworx Server Administrator
Allworx System Administrator
Phone Administrator role

Feature Key Required No
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2. Locate the schedule to manage and click:

3. Click Update to save the changes.

To modify the schedule: 
The purpose of a schedule is to change modes/greetings automatically, based on the Allworx server 
clock. It is possible to disable the automatic control to change the modes/greetings manually. 

At installation, the Allworx system defines the following schedules:

• Schedule 0 (open) - The Open default is Monday through Friday, 8:00 – 5:00 and assigns 
greeting 0. Users can modify but cannot delete this schedule.

• All other hours as Closed and uses greeting 1. Users can modify the schedule time and add 
schedules to accommodate business needs.

1. Log in to the Allworx server admin page, navigate to Phone System > Schedules.

2. Locate the schedule to configure and click the additional information arrow . 

3. Click:

Displays additional information and enables modifying the current schedule. See “To modify the 
schedule:” on page 122 for more information.

Copy Duplicates the current schedule. The new schedule name is Schedule <number>: Copy of schedule 
<number>.

Delete Removes the current schedule from list.

Show Greeting Names for this 
schedule

Displays the Open, Closed, and custom greeting names associated with the schedule.

Show resources using this 
schedule

Displays the Users, System Extensions, Dialing Privileges Groups, and Auto Attendants 
associated with the schedule.

Description:
Mode/Greeting 
Control:

Change the schedule name and toggling between automatic or manual greeting control. If 
selecting the Manual schedule, users must set the mode/greeting via the handset 
Schedule PFK. 
1.  Click modify. 
2.  Enter a new name in the description field.
3.  Locate the Mode/Greeting control and select an option from the drop-down list. 

4.  Click Update to save the change or Cancel to disregard the request.

Automatic Sets the mode/greeting automatically by the server according to the 
schedule. 

Manual Sets the mode/greeting by the handset schedule PFK. To change: the 
user of the handset can press the PFK to set the mode and greeting. 
See “Manage the Programmable Function Keys (PFKs)” on page 67. 
for more information.
NOTE: Even if configuring the schedule for automatic control, use a 
schedule PFK to override the current mode/greeting. If overridden, 
control of the mode/greeting returns to the schedule when the next 
defined time period begins.
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Schedule is 
currently set to Mode:

Change the schedule mode and greeting to use. If selecting the Automatic Schedule, a 
daily calendar opens to assign Start, End, Mode, and Greeting requirements, see 
“Manage the Greetings” on page 121.
To update this information:
1.  Click modify. 
2.  Click Mode and select an option (day or night) from the drop-down list.
3.  Click Greeting and select an option from the drop-down list (see “Manage the 

Greetings” on page 121 for more information).
4.  Click Update to save the change or Cancel to disregard the request.

<day of week> Available only with Automatic mode. Specify a schedule for each day of the week and 
assigning a greeting to use for each time period. To manage the time schedule and 
greetings:
1.  Click modify. Click:

2.  Locate the Mode column and select an option from the drop-down list.
3.  Locate the Greeting column and select an option from the drop-down list.
4.  Click Update to save the changes or Cancel to disregard the request.
To save steps modify one day and copy the changes to other days within the same 
schedule. Click copy and select the days that use the same periods.

Holidays Available only with Automatic mode. To add a holiday to the schedule: 
1.  Click add holiday. 
2.  Locate the newly added holiday and click modify.
3.  Enter the dates for the holiday. 
4.  Check the repeat yearly to enable. 
5.  (Optional) Click add period to enter specific start and end time periods to the holiday 

schedule.
6.  Click Update to save the changes or Cancel to disregard the request.
To duplicate a holiday schedule: 
Copy all of the holidays from one schedule to other schedules. This is useful when setting 
up holidays with new dates for a new year if several defined schedules are available. 
1.  Click copy holidays.
2.  Check the box(es) to use the currently selected holiday.
3.  Click Copy to save the request or Cancel to disregard the request.

Copy Duplicates the current schedule. The new schedule name is Schedule <number>: Copy 
of schedule <number>. Schedule is available to modify.

Delete Removes the current schedule from list. Requires no further action.

Click here to return to the “Install Checklist” .

add period (Optional) Enter specific start and end time periods to the daily 
schedule.

delete Removes the time period from the schedule.
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Chapter 21 Shared Call Appearance

Shared Call Appearance shares a set of one or 
more PFKs across multiple handsets. All 
handsets in a Shared Appearance have 
common access to calls within the group of 
handsets.

Example:
An incoming call rings on all handsets with the 
Shared Call Appearance.

• One user answers and places the call on hold.

• Another user retrieves the call the first user placed on hold.

There are two cases for Shared Call Appearances:

• Call Group – Users with similar business needs or tasks assigned to a group can answer any 
calls to the group shared appearance. A handset can place the call on hold and another handset 
can retrieve the call. 

• Executive/Assistant Arrangement – An appearance exists on the handsets of both an 
executive and assistant. The assistant answers the calls to the executive and places the caller 
on hold for the executive to pick up. The assistant always displays the state of all calls on the 
executive’s handset.

Shared Call Appearances support three distinct types of hold behavior:

Note: 9202E and Reach handsets do not support the use of Shared Call Appearances.

Shared Hold Any handset using the Shared Call Appearance can retrieve the call on hold. 
•  To place the active Shared Call Appearance phone call on hold, press the HOLD key. The LED flashes slow, green 

on all phones of the Shared Call Appearance; including the phone used to place the call on hold. 
•  All handsets in the Shared Call Appearance can retrieve the held call. 
•  The system delivers Hold Reminders to all phones in the Shared Call Appearance per the individual phone settings. 

If no one retrieves the call, all phones receive a notification per the individual HOLD reminder settings. 
NOTE: The Allworx server does not support including a call on a shared hold during phone-hosted conferences.

Privacy Hold Only the handset that placed the call on hold can retrieve the call. 
•  To place the call on “privacy” hold, quickly press the HOLD button twice. The phone has a fast, alternating green and 

red LED. 
•  The LED for all other handsets in the Shared Call Appearance become solid red for the Shared Call Appearance line. 
•  If the user does not pick up the call, the phone receives a notification per the phone HOLD reminder settings.

Bridged Hold The handset that placed the call on hold and one other handset that has the same Shared Call Appearance can 
retrieve the call. 
•  To place the call on “Bridged Hold”, place an intercom call to the handset within the same Shared Call Appearance. 
•  The second handset can select the flashing Shared Call Appearance PFK to resume the held call. 
•  If neither party resumes the call, the handset placing the call on hold receives a notification per the individual HOLD 

reminder settings.

Prerequisites

Access Permissions Allworx Server Administrator
Allworx System Administrator
Phone Administrator role

Feature Key Required No
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21.1 Setup Checklist
Follow the order of the steps to successfully setup the Shared Call Appearance.

21.2 Manage Shared Call Appearances
The Shared Call Appearance has all the attributes assigned to a normal call appearance (Caller ID, 
hold music, etc.). Outbound Caller ID is common for all outbound calls on a given Shared Call 
Appearance.  If deleting a Shared Call Appearance, the server removes it from all handsets.

To manage a Shared Call Appearance:
1. Log in to the Allworx server admin page; navigate to Phone System > Shared Appearances.

2. Click one of the following links:

Step Description Installation Guide Link

1 Add a new Shared Call Appearance. “Manage Shared Call Appearances” on 
page 1262 Modify the Shared Call Appearance information, as necessary.

3 Assign the Shared Call Appearance programmable function keys 
(PFKs).

“Assign Shared Call Appearance Programmable 
Function Keys (PFKs)” on page 127

4 Define the call routes. “Manage Call Routes” on page 57

add new Shared 
Call Appearance

1.  Update the Description field and the Number of Lines field (number of PFKS assigned to the 
handsets).

2.  Click Add to save the change or Cancel to disregard the request.

Show Handsets Displays the handsets assigned to the Shared Call Appearance. Click Close when complete.

Modify 1.  Update the Description field, and then update the information.

2.  Click Update to save the change or Cancel to disregard the request.

Delete Verify the Shared Call Appearance and click OK to delete it or Cancel to disregard the request. Reboot 
all affected phones to remove the Programmable Function Key.

Description Enter a new name.

Number of Lines The Number of Lines is not available for change as this affects 
the number of PFKs on all phones, rendering some phones 
unable to support the Shared Call Appearance feature.

Owner Select an available option from the drop-down list.

Internal Caller ID Enter up to 47 characters.

Internal Caller ID Number Select an available option from the drop-down list.

External Caller ID Name Enter up to 47 characters.

External Caller ID Number Enter up to 24characters.

Emergency Caller ID Number Select an available option from the drop-down list.

Dialing Privileges Group Select an available option from the drop-down list.

Hold Music Selection Select an available option from the drop-down list.

Can Place Calls Click the box to enable placing outgoing calls.

Can Receive Calls Click the box to enable receiving outgoing calls.



Allworx System Administrator Guide Version 8.1

1-866-ALLWORX * 585-421-3850 Page 127
www.allworx.com
Revised: 03/25/2016

21.3 Assign Shared Call Appearance Programmable 
Function Keys (PFKs)

When assigning a Shared Call Appearance PFK to a handset, the system assigns consecutive PFKs 
for each Shared Call Appearance line. The Allworx system notifies the Allworx administrator when:

• there are not enough consecutive PFKs available and the PFK assignment fails. 

• the Shared Call Appearance PFK assignment would overwrite existing PFKs.The Allworx 
administrator can choose to cancel the operation. 

After the server allocates consecutive PFKs for all the lines in the Shared Appearance, the Allworx 
administrator can move the lines to other PFKs within the constraints of the handset model. 

• If replacing a phone that is using a Shared Call Appearance, the replacement phone 
automatically shares the Shared Call Appearance.

• If the handset has enough PFKs available to accommodate all Shared Call Appearance lines.  

• If the handset does not have enough PFKs available, the Allworx system notifies the Allworx 
administrator, and the handset replacement finishes without adding the Shared Call Appearance 
to the new handset.

To assign a Shared Call Appearance PFK, see “Manage the Programmable Function Keys (PFKs)” on 
page 67 for more information. 

21.4 Define Call Routes
Each defined Shared Call Appearance is selectable as a destination in any extension call route. For 
more information, see “Manage Call Routes” on page 57. In multi-site networks, Allworx administrators 
can map defined Shared Call Appearances on one site to other sites to use as destinations in the other 
site call routes.

Click here to return to the “Install Checklist” .
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Chapter 22 Speed Dial

Speed Dial creates a dialing shortcut for users 
instead of dialing a lengthy number. 

The Allworx server supports:

• 50 three-digit speed dial numbers 
(example: 350 through 399).

• 1000 five-digit speed dial numbers 
(example 34000 through 34999). 

The Allworx system automatically generates speed dial numbers based on the Dial Plan.

To manage a speed dial number: 
1. Log in to the Allworx server admin page, navigate to Phone System > Speed Dial. 

2. Click one of the following links:

add new Speed 
Dial Number

Create a speed dial number:
1.  Select a Speed Dial Number from the drop-down list.
2.  Enter a name in the Description field. 
3.  Enter a number in the Number to Dial field. Use one of the number formats described in the TIP 

box. Click Start Over to clear the fields.
4.  Click Add to save the change or Cancel to disregard the request.

add Speed Dial 
Numbers from 
CSV file

Add Speed Dial numbers with a Comma Separated Value (CSV) file. 

1.  (Recommended) Perform a full system backup before adding multiple Speed Dial numbers.
2.  Create a CSV file using any text editor or Microsoft Excel with the Description, Number To Dial, 

and Speed # attributes. The Allworx server automatically matches the column types when the 
CSV file contains the values (exact matches) as column headings in the first row of the CSV 
file. Required attributes (columns): Description and Number To Dial.
Example: CSV file content - the first row is the header and the next two are Speed Dial 
import data:

3.  Click Choose File. Locate the file and click Open > Load > Process.
4.  (Optional) Check the box to Skip records with an existing Speed #. This is useful to avoid 

overwriting speed dial numbers. 
5.  Verify the column heading represents the data supplied. Use the drop-down list to assign the 

column headings. To exclude a column, select a heading value of Skip.
6.  Review the rows to add. Uncheck a row to exclude it from the import.

Prerequisites

Access Permissions Allworx Server Administrator
Allworx System Administrator
Phone Administrator role

Feature Key Required No

Description Number To Dial Speed #

Red Conference Room 1110 351

Blue Conference Room 1251 352
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7.  Click Add to import the users or Cancel to disregard the request. A message displays indicating 
the number of Speed Dial numbers successfully added and/or which Speed Dial numbers were 
skipped during the import. Additional details about skipped Speed Dial numbers may be 
available in the system events log.

8.  Click Done to return to the Speed Dial List or Continue to repeat this process.

NOTE: The Allworx system will not import any record from the data set that is missing required 
values or cannot be read by the Allworx system. The maximum field length is 1,024 characters and 
the maximum line length is 2,048 characters for each line in the CSV file.

Modify Update the speed dial information.
1.  Enter a new name in the Description field. 
2.  Enter a number in the Number to Dial field. Use one of the number formats described in the TIP 

box. Click Start Over to clear the fields.
3.  Click Update to save the change or Cancel to disregard the request.
NOTE: The Speed Dial Number can not be edited.

Delete Remove the Speed Dial Number from the list. Click Delete to remove the Speed Dial Number or 
Cancel to disregard the request.

Click here to return to the “Install Checklist” .
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Chapter 23 Users

Users manages adding users and user 
templates, deleting email and/or voicemail 
messages, deleting recordings of the username 
and/or presence greetings, wiping remote 
devices, and managing password requirements. 

The name area for each user displays a red dot 
() next to each user that has not recorded their 
name in the Message Center.

The User Template contains a set of common configuration settings to apply when creating or 
modifying users, but does not include all user settings. Some configuration settings are available at 
<user> > modify. 

The System User (Default) Template contains the factory default settings. For best results create a 
custom template (optional), and then apply the custom template or the default System User Template 
when adding multiple new users. 

23.1 Setup Checklist
Follow the order of the steps to successfully setup the users.

23.2 Manage Users
Use the following procedures to show or hide the template applied to each user, add a new user, and 
modify or delete existing users.

To show or hide the template applied to each user:
1. Log in to the Allworx server admin page, navigate to Phone System > Users.

2. Locate the Users section, and click the additional information arrow , if necessary.

3. Click the show or hide templates last applied to user to view or conceal the user template 
applied to each user. An exclamation point (!) indicates a template override.

Step Description Installation Guide Link

1 Add a new or modify the user template. “Manage User Templates” on page 135

2 Add a new user. “To add a new user:” on page 132

3 Configure or update the password requirements. “Define Password Requirements” on page 140

Prerequisites

Access Permissions Allworx Server Administrator
Allworx System Administrator
Phone Administrator role

Feature Key Required No
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To add a new user:

1. Log in to the Allworx server admin page, navigate to Phone System > Users.

2. Locate the Users section, and click the additional information arrow , if necessary. Click:

Note: After increasing the internal extension length to 5 or 6 digits, the extensions show available link is no longer 
available.

add new user Add users one at a time.
1.  Update the user settings. See “User Settings” on page 133 for more information. 
2.  Click Add to save the user or Cancel to disregard the request. The Users page displays, 

and the users table displays the last applied template to each user. 

Add users from 
CSV file

Add multiple users with a Comma Separated Value (CSV) file. 
1.  (Recommended) Perform a full system backup before adding multiple users.
2.  Create a CSV file using any text editor or Microsoft Excel and any combination of required 

and optional attributes. Required attributes (columns): Login Name, Last Name
The Allworx server automatically matches the column types when the CSV file contains the 
values (exact matches) as column headings in the first row of the CSV file.

Example CSV file content where the first row is the header and the next two are user import data:

3.  Click Choose File. Locate the file and click Open > Load > Process.
4.  (Optional) Enter a PIN and Password for the users. These values are for all records added. 

If not supplied, the user’s password defaults to the Login Name specified during the add.
5.  (Optional) Check the box to Skip records with a Login Name that already exists. This is 

useful to avoid overwriting existing users. Usernames are case sensitive; therefore, 
JYoung and Jyoung are separate login IDs.

6.  Select the template for user settings from the drop-down list.
7.  Verify the column heading represents the data supplied. Use the drop-down list to assign 

the column headings. To not include a column, select a heading value of Skip.
8.  Review the rows to add. Uncheck a row to exclude it from the import.
9.  Click Add to import the users or Cancel to disregard the request. A message displays 

indicating the number of users successfully added and/or which users were skipped while 
adding the new users. Additional details about skipped users may be available in the 
system events log.

10.  Click Done to return to the User List or Continue to repeat this process.
* If the extension is not included, the server uses the first available extension.
** If using Msg Alias, include the Login Name (as shown in the table above) as part of the Msg
    Alias field when saving a copy of the message on the server.
*** If the DID DNIS Name or DID Prompt Language parameters are not supplied in the CSV
     file, the Allworx system uses the values from the DID Routing Plan for the DID Number. 
**** Requires a DID block in place on the Allworx System before importing users with DID
       numbers from a CSV file.
NOTE: The Allworx system will not import any user record from the data set that is missing 
required values, cannot be parsed, or is conflicting with a user currently defined on the 
system, specifically matching login name, extension, or first, middle, and last name. The 
maximum field length is 1,024 characters and the maximum line length is 2,048 characters for 
each line in the CSV file.

Login 
Name

Last 
Name

First 
Name

Middle 
Name

Extension* Msg Alias** DID
Number****

DID 
DNIS 
Name***

DID 
Prompt 
Language***

ARader Rader Alice B 1008 ARader, group@widgetsinc.com 5855551212 AliceRader Primary

BOakley Oakley Bill C 1009 Group@widgetsinc.com 5855551234 BillOakley Secondary
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To modify or delete existing users:
When modifying templates already applied to users, changes are NOT automatically applied. To 
update the user settings, reapply the template to each associated user. 

1. Log in to the Allworx server admin page, navigate to Phone System > Users > Users section, 
and click the additional information arrow , if necessary.

2. Select an option:

User Settings

 Bulk Edit Performs the same change on multiple users, check the box on the left of the appropriate 
usernames, and then click the appropriate action button to apply to the users.

<extension number> Modify the call routes for the user. See “Manage Call Routes” on page 57 for more information.

Modify The add new user options and user template options displays. To modify the user:
1.  Click Modify, and update the options, as appropriate. See “User Settings” on page 133 and 

“User Template Settings” on page 136 for more information on the user template options.
2.  (Optional) Locate the User Template section and select a new User Template from the 

drop-down list. Click Set to apply all the settings to the user or click Merge to apply the settings 
of the new template while keeping the override settings. Merge does not change any override 
settings from the last applied template. 

3.  Click Update to save the changes or Cancel to disregard the request. 

Delete The server removes the user from the list, and the page refreshes with existing users. 
1.  Locate the user in the Users list and click Delete in the Action column for the appropriate user. 

Read the pop-up message and confirm this is the user to remove from the business directory.
2.  Click Delete to remove the user from the list or Cancel to disregard the change.

Displays the Welcome to Allworx page specific to the user. Copy and paste this information into an 
email window and send to the user.

Identification

Login Name Identify a username for the new user to log in to My Allworx Manager or other Allworx applications. 

Full Name Enter the first, middle, and last name of the new user, per company requirements.

Password Identify a password for the new user to log in to My Allworx Manager or other Allworx applications. 

If the user is already set up prior to upgrading the server, the default PIN code is the same PIN code prior to the 
upgrade.

Confirm Password Reenter the password for the new user. This step verifies the passwords match.

Require Password 
Change

Enables the user to log in once with the provided password. After a successful log in, the user must change the 
password.

PIN Used to log in to the Allworx system from a phone keypad, e.g., access voicemail messages or log in to a ACD 
queue as an agent.

Confirm PIN Reenter the PIN for the new user. This step verifies the PINs match.

Password The password must comply with the password requirements.

PIN Default keypad PIN code: 1234.
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When updating the remaining sections on the user page, see “User Template Settings” on page 136 
for more information. An exclamation point (!) indicates a template override.

23.3 Delete User Messages or Recordings 
Deleting the user email and/or voicemail messages/recordings permanently removes the data from 
the Allworx server. 

1. Log in to the Allworx server admin page, navigate to Phone System > Users. Locate the 
Users section, and click the additional information arrow , if necessary.

2. Locate the username, click more..., and then click an option:

3. Click Delete to save the changes or Cancel to disregard the request.

Require PIN Change Enable the user to log in once with the provided PIN. After a successful log in, the user must change the PIN.

Primary Extension Display the next available extension. To select a different extension: click show available, and then select an 
available extension number.
NOTE: After increasing the internal extension length to 5 or 6 digits, the extensions show available link is no 
longer available.

New User Options - only applies when adding a new user.

Assign Phone Click the drop-down arrow and select a Phone Assignment option.

Assign DID Number Click the drop-down arrow and select a DID Number option. Applies to the DID Routing Plan phone number to 
extension mapping. 

Presence Select the user presence. Options include:

Roles Assign additional administrative functionality to the user. See “Roles” on page 113 for more information.
NOTE: To enable one user to have roles on different servers in a multi-site network, the Allworx administrator 
must create separate user accounts for the user on each server, and then assign the roles on each server. Use 
different usernames for each user account.
NOTE: To assign users to manage queue and Auto Attendant recordings, or to manage individual queue 
settings or queue supervisor see “User Template Settings” on page 136 for more information.

User Template Select the template to use for the settings. Select an option from the drop-down list. Click Set to update the user 
settings or Merge to import the user settings (keeps current setting overrides).

Delete messages Select one email and one voicemail option to Delete. Options include:

Delete recordings Select the recording type to delete. Options include:
•  User’s name and all of the user’s Presence greetings
•  All of the user’s Presence greetings
•  User’s name

•  In Office •  On Vacation •  At Home •  Busy

•  At A Meeting •  On Business Trip •  Away

•  Delete all emails
•  Delete all read emails
•  Keep all emails

•  Delete all voicemails
•  Delete all saved voicemails
•  Keep all voicemails
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23.4 Wipe Existing User Remote Devices
The Wipe command removes the following information from a lost or stolen remote device: 

1. Log in to the Allworx server admin page, navigate to Phone System > Users.

2. Locate the Users section, and click the additional information arrow , if necessary.

3. Locate the username, and click the more... option. Select the Wipe remote devices option.

4. Type a new user password in the field provided. Confirm the password in the next field. 

5. Click Wipe to save the change.

23.5 Manage User Templates
User Templates contain a set of common configuration settings applied when creating or modifying 
users, but do not include all user settings. Some configuration settings are from the <user> > modify 
page. Prior to adding users on a new system, review feature options (e.g. Off-site Access to Outside 
Lines or the ability to create conferences) to determine which are necessary for all users.

To see the list of users for each template:
1. Log in to the Allworx server admin page, navigate to Phone System > Users.

2. Locate the User Templates section, and click the additional information arrow , if necessary. A 
table of available User Templates displays. 

3. Select View for the appropriate template, and navigate to the Template Last Applied To Users 
section for the complete list.

To manage User Templates:
1. Log in to the Allworx server admin page, navigate to Phone System > Users.

2. Locate the Users Template section, and click the additional information arrow , if necessary.

Application
Login 

Credentials*
Contact 

Information
Voicemail 

Information

Configuration 
(including 

backup settings)

Reach X X X

Interact X X X

* Requires the Allworx administrator to change the user password, which restarts the Reach application and Terminates the Interact 
application.

•  Device user must re-log in entering the credentials and using the new password. 

•  Reach users must reclaim a new license to restore the voicemail information and to send/receive calls. 
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3. Click one of the following links: 

User Template Settings

View The User Template page opens. The factory default templates are view only, and are not available to 
modify. To modify new templates:
1.  Click Modify, and update the template options, as appropriate. See “User Template Settings” on 

page 136 for more information on the user template options.
2.  Click Update to save the changes or Cancel to disregard the request. 

Copy 1.  Select the user template, such as System User (Default) and click Copy. A new User Template 
displays in the template list with the same user options as the selected template.

2.  Click View and follow the instructions above to modify the template.

Delete The server removes the template from the list, and the page refreshes with available User Templates. If 
the delete option is unavailable, click View to see the users assigned to the template. Reassign the 
users to another template, and re-try to delete the template.

Name Enter a title for the new user template.

System Features

Set Presence Using Schedule Control a user’s presence setting with the selected schedule. When the selected schedule mode is 
set to Day Mode, the user’s presence is In Office. This enables users to have unique call routing 
for Day and Night modes.When the schedule mode is set to Night Mode, the user’s presence is 
Away. Select an option from the drop-down list:
•  Disabled
•  Any schedule available on the Allworx server.

Users can override the presence setting using any of the current available methods. However, the 
presence changes as the schedule mode changes except for the On Vacation and On Business 
Trip presence status, according to the table below.

Enable Voicemail Check the box to enable callers to leave a voicemail message for the extension. If disabled, the 
user cannot log in to the Message Center, and other callers cannot leave a message. When setting 
up a Finally… call route, the user is not in the drop-down list for Transfer to Voicemail for user.

Limits the voicemails by the first limit reached among:
•  Maximum Number of Voicemails
•  Maximum Voicemail Storage Limit (Allworx Connect servers only)
•  Maximum Size Universal Inbox (6x, 6x12, and 48x servers only) 

Current Presence Presence after schedule 
change to Day Mode

Presence after schedule 
change to Night Mode

 In Office  In Office  Away

 Away  In Office  Away

 At Home  In Office  Away

 Busy  In Office  Away

 At a Meeting  In Office  Away

 On Vacation  On Vacation  On Vacation

 On Business Trip  On Business Trip  On Business Trip

Maximum number Voicemails Select an available option from the drop-down list.

Maximum Voicemail Storage Limit Select an available option from the drop-down list.

Call Answering maximum message 
record time

Select an available option from the drop-down list.
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Enable Voicemail
(con’t)

 

User has permission to modify 
extension’s call routes

Check to the box to enable the user to customize call routes in My Allworx Manager.

User has permission to create 
conferences

Check to the box to enable the user to schedule conference calls in My Allworx Manager.

User has permission to 
administer Allworx View

Check the box to enable administrative permissions in the Allworx View application.

System-wide Active Calls Display Phone displays caller ID information. Select an available option from the drop-down list.

Call Recording Allowed Check the box to enable the user to invoke Call Recording.

Record every call automatically Directs the Interact Professional application to automatically start the Call Recording feature from 
the time the Interact Professional user answers the call; the Interact Professional user still has 
control on the application interface to pause, resume, or stop the recording during the active call. 
•  Check the box to enable.
•  Requires enabling the Call Recording Allowed option.

Maximum size Universal Inbox Identifies the maximum space in <number> MBytes the user has for an Inbox. Select an available 
option from the drop-down list. Applies to Allworx 6x, 6x12, and 48x servers.

Default Prompt Language Identifies which language to use for incoming call prompts.

Enable Hot Desking Check the box to enable access to the Hot Desking feature. Specify:

Call Queue Supervisor Check the appropriate Call Queue boxes to enable supervisor permissions for the user.

Recording Manager Check the appropriate Auto Attendant or Call Queue boxes to enable recording manager 
permissions for the user.

Feature Eligibility •  Reach Eligibility Count - enter the number of eligible licenses that a user can manage directly 
from the Reach application without requiring the Allworx administrator to reserve the license.

•  Interact Professional Eligibility Count - enter the number of eligible licenses that a user can 
manage directly from the Reach application without requiring the Allworx administrator to reserve 
the license.

Message Center maximum message 
record time

Select an available option from the drop-down list.

User has permission for Off-Site 
Access to outside lines

Check the box to enable.

User has permission to send 
voicemail to all users

Check the box to enable.

Operator Extension Select an available option from the drop-down list.

End message recording Select an available option from the drop-down list.

Maximum Login Time Select an available option from the drop-down list.

Caller ID Name Enter the name callers at the opposite end see on the display.

Caller ID Number Enter the number callers at the opposite end seen on the display.
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Follow Me Calling Route inbound calls to an external number within call routes. 
•  When receiving a Follow-Me-Anywhere call on an external phone (e.g. cell phone, home phone), 

a prompt identifies the source of the call and explains how to accept the call. To enable:

•  If the user rejects or does not answer, the incoming call continues along the defined call route.
•  If connecting any of the parties via a SIP Trunk or SIP Gateway, the consult and transfer features 

do not work.

Reach Link •  User has permission to modify Reach Link settings - check the box to enable.
•  Allow voicemail when attempting to recover lost Reach calls - check the box to enable.
NOTE: In a multi-site network configuration: Reach Link functionality is limited to users and 
handsets configured on an Allworx server with the Reach Link feature key installed.

Auto Attendant Menus •  Check the Auto Attendant boxes to include the user in the Dial-By-Name and Dial-By-Directory 
menus.

POP3 Mail Transfers Configures the Allworx user for a POP3 request to transfer email to a POP3 client works as email 
and voicemail messages, email messages only, or no messages. Select an option. See “Email 
Server Configuration Settings” on page 173 for more information.
•  Email and Voicemail messages
•  Email message only
•  No messages

Voicemail Notification and Escalation

Sends SMS text messages to cell phones and/or email addresses when leaving a voice message in a specified voicemail inbox on the 
Allworx System. The SMS text messages provide the following information:

NOTE: The Allworx SMTP server sends the SMS text messages, which require a valid network path from the Allworx server to the 
destination mail server through the Internet.

Notification Mode Sends alerts each time the inbox receives a new voicemail.
To configure voicemail Notification alerts, enable the Notification Mode radio button and enter an 
SMS Email Address. 
•  The SMS Email Address is the address of the recipient to alert a new message is available. 
•  One entry per field; use a message alias to send alerts to multiple recipients. Acceptable entries:

•  NOTE: Find service provider domains at: www.notepage.net/smtp.htm (Check with the Service 
Provider for more information).

PIN required to 
accept call*

Requires entering an Allworx PIN code to answer the call.

Require caller to 
record name*

Requires the caller to state their name before ringing the Allworx phone.

Primary Phone Select a handset from the Primary Phone drop-down list. The Primary 
Phone selection is independent of the regular phone assignment and call 
routing. It can be any phone in the system.

* If checking both boxes, the prompt for calls to the user’s extension, “Call for (user) from (caller). 
To accept, enter your PIN followed by the pound sign.”

•  Allworx username associated with the voicemail inbox. •  Length of the recorded message.

•  Date and time the voicemail inbox received the message. •  Caller ID name and number of the caller leaving the voicemail (if 
available).

•  Username •  Email address

•  Message Alias
•  Cell phone number with service provider SMS text message 

domain (e.g., 7165552000@txt.att.net)

www.notepage.net/smtp.htm
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Escalation Mode The Voicemail Escalation feature distributes message alerts repeatedly until meeting the set 
number of retries or until retrieving any voicemail message. 
•  The system organizes recipients into levels so that after sending a specific number of message 

alerts to the recipient(s) at one level, the system begins sending the alerts to the recipient(s) at 
the next highest level. 

•  Example: A doctor’s office has an “on call hours” voicemail box. When leaving voicemail 
messages in this box, the system sends the notification to the assigned doctor to answer after 
hour emergencies. If the doctor does not retrieve the call within X minutes, the system sends an 
escalation message to the next set of backup doctors.

Enable the Escalation Mode radio button and update the fields:

Email Forwarding

External Outgoing Mail (SMTP) 
Server Configuration

Check the box to override the server configuration for the user. To configure:
1.  Check the box to enable. Enter the following information:

2.  Click Send Test Email.

VPN Settings Check the box to enable. Enter a VPN password in the field, and then confirm it.

Level Order for alerting recipients a caller left a message in the voicemail inbox.

SMS Email 
Message

Address of the recipient(s) to alert when a new message is in the voicemail 
inbox. Only one entry per field, use a message alias to send alerts to multiple 
recipients.
The following are acceptable entries:
•  Username
•  Message Alias
•  Email address
•  Cell phone number with service provider SMS text message domain 

(e.g., 7165552000@txt.att.net)
Note: Find a list of service provider domains at: www.notepage.net/smtp.htm 
(Check with the Service Provider for more information).

Notification 
Period

Elapsed time before sending another SMS message to the recipients identified 
in the Level option.

Maximum 
Retries

Maximum number of attempts sent to the recipients of the level before the 
message alerts proceed to the next level. 
•  This does not include the initial SMS message. 
•  The server makes one more attempt to the recipients than the entered value.
•  Escalation message alerts stop after sending the maximum number of 

messages to the last populated level in the table.

Continue 
Notifications

Recipients continue to receive message alerts in conjunction with the next level 
or levels once escalation occurs.

Server Address Enter IP Address or DNS name.

Server Port Enter a value.

Display Name Enter a value.

Sender’s Email Address Enter an email address. 

Use authentication Check the box to enable, and then enter the User Name and 
Password.

Secure Connection Select an available option from the drop-down list:
•  None: No secure connection.
•  SSL: Uses SSL without sending the STARTTLS message at the 

beginning of the connection prior to doing the SSL handshake.
•  TLS: Uses SSL WITH sending the STARTTLS message at the 

beginning of the connection prior to doing the SSL handshake.

mailto:7165552000@txt.att.net
www.notepage.net/smtp.htm
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23.6 Define Password Requirements
Users enter PIN codes or passwords to access phone functions and applications. The Allworx 
administrator can require more stringent password requirements for all accounts, and users to change 
the PIN or password at the next login by using My Allworx Manager.

To change the password requirements:
1. Log in to the Allworx server admin page, navigate to Phone System > Users.

2. Locate the Password Requirements section, and click the additional information arrow , if 
necessary. A message displays indicating if Strong User Passwords are or are not required, 
and the current password requirements.

3. Click modify to change the settings.

4. Click the Update button to save the changes or Cancel to disregard the request.

Phone Functions requiring a Pin Code
•  Message Center (Audio and Visual)
•  ACD Agent Login
•  Hot Desk Login
•  Follow Me

Applications requiring a Password
•  Interact / Interact Professional
•  Reach
•  My Allworx Manager

Default Settings Require Strong Passwords Settings

•  Default setting: Require Strong Passwords is 
unchecked.

•  Only contain letters (A-Z, a-z), digits (0-9), and special 
characters (above).

•  Minimum length of 4 characters / Maximum 
length of 128 characters

•  Check the Require Strong Passwords box to enable, and then 
select the strong password requirements:

•  Minimum password length (6 to 128 characters)

•  Require lower case letter(s)

•  Require upper case letter(s)

•  Require numeric character(s)

•  Require special character(s)

•  If the password does not already meet all the updated 
requirements, the server requires the user to change the 
password at the next login.

Click here to return to the “Install Checklist” .
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Part 4  Network 

The Network sections describe setting up and customizing the network for the Allworx server specific to 
the business requirements.Each chapter explains:

• necessary access permissions and feature keys.

• necessary equipment to perform the procedures.

• necessary procedures to setup and customize the Allworx server network.

The various Network pages on the server web admin site support the Allworx administrator to set up, 
configure, and manage the settings of the following features:

• Configuration 

• Multi-Site 

• Port Expander 

• Static Route 

• VPN 
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Chapter 24 Configuration

Configuration supports customizing the network 
settings for the business needs. 

Prior to configuring the network:

• review the security advisories available 
at: https://allworxportal.com/
support_training/advisories.aspx.

• perform a backup of the View database prior to changing the network configuration (see the 
Allworx View Users Guide for more information).

To manage the network configuration:
1. Log in to the Allworx server admin page. Navigate to Network > Configuration.

2. Click modify. The modify page opens.

3. Update the settings:

For security purposes, the Allworx administrator can no longer manage the Allworx server from 
the Public interface IP Address. The Allworx server requires all updates from a LAN IP Address.

Allworx Network Mode

LAN Host Mode Another device on the Local Phones interface of the Allworx server is the primary router to the 
Internet. The NAT and Firewall functionalities are not available on the Allworx server.

Enable NAT Network Address Translation. Enables devices attached to the LAN(s) of the Allworx server 
with private (non-globally routeable) IP Addresses to communicate on a wider network using 
the server WAN IP Address. This conserves IPv4 Addresses and protects devices on such 
LAN networks from all unsolicited Internet traffic.

Enable Firewall Protects the Allworx server and all services running on it from unsolicited Internet access, 
enabling access onto to the ports that the administrator deems necessary.

Enable Stealth Mode The Allworx server does not respond to unsolicited connection attempts at all, as if the server 
did not exist, instead of responding with the standard ICMP Port unreachable message.

Prerequisites

Access Permissions Allworx Server Administrator
Allworx System Administrator
Network Administrator role

Feature Key Required No

Previous Configuration Current Feature

LAN Host mode LAN Host Mode

NAT Firewall Enable NAT

NAT/Firewall with DMZ Enable NAT 
Enable Firewall

NAT/Firewall with Stealth DMZ Enable NAT 
Enable Firewall
Enable Stealth Mode

Standard Router

https://allworxportal.com/support_training/advisories.aspx
https://allworxportal.com/support_training/advisories.aspx
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VLAN Configuration
•  The Allworx Network Stack supports up to 16 user-defined VLANs shared between the Ethernet ports. Any VLAN shares the 

full bandwidth among all the VLANs on that port. Virtual Network Interfaces provide the ability to define multiple virtual 
interfaces on a single physical interface so the Allworx administrator can separate voice and data. Each virtual interface 
enables a separate IP address and 802.1Q VLAN tagging setup. The Network Configuration page has an updated section 
for configuring VLAN settings for the Ethernet ports.

•  There is always at least one configured VLAN, which acts as the phone LAN. The phone VLAN can be on any Ethernet port 
- tagged or untagged. The system does not require configuring any other VLAN interfaces. Any Ethernet interface without 
enabled VLANs (and without configured PPPoE) is unused.

•  Each interface has a uniquely assigned VLAN Tag/ID. The Allworx administrator may configure one interface per physical 
port as untagged without specifying the VLAN Tag/ID. By default, the WAN port has one untagged interface - VLAN Tag/ID 
unspecified, and the LAN port (ETH0 on Connect servers) has one untagged interface - VLAN Tag/ID unspecified. Both 
ports cannot use the same VLAN Tag/ID. 

•  The Allworx administrator cannot delete the first VLAN in the list because of the assigned Local Phone network. At a 
minimum, there is always one Ethernet port with a configured VLAN (tagged or untagged) for local phones, but the Allworx 
administrator can disable all other network interfaces.

SNMP
•  The server SNMP daemon listens on all VLAN interfaces, and uses the firewall to block access from the public interface. 

See “SNMP Server” on page 179 to enable or disable SNMP for all interfaces.

Upgrades
During the first major software upgrade to Allworx System Software 8.0 and later the software imports the settings from a 
previous version of the Allworx System Software and creates two VLANs.

add VLAN Adds a new VLAN to the list. Users may define up to 16 VLANs.

Enabled Check the box to enable the VLAN port. The Allworx System Software checks the LAN ports 
by default.

Port Indicate the Physical Ethernet Port. Options include LAN or WAN.

Tag/ID Check the box to tag the VLAN. Manually enter the VLAN (802.1Q) tag.

Description/IP Address The Allworx System Software identifies LAN phones as Local phones and VLAN phones as 
public.The first Public VLAN description is fixed, and subsequent description fields are 
user-defined. Options include:
•  DHCP
•  Static <IP Address>
•  <Net mask drop-down>

Services Check the box to enable the services. The first local phone VLAN BLF broadcast is always 
enabled, and subsequent BLF check boxes are user-defined. 

Action Click delete to remove the port from the list.

Public Interfaces

VLAN If a VLAN interface is serving as the Public interface, click the radio button. Select the 
appropriate interface from the drop-down list.

PPPoE (on WAN Port) If using PPPoE (on WAN Port), click the radio button. Enter the PPPoE Username, PPPoE 
Password, and the PPPoE Service Name. If necessary, update the PPPoE MTU.

T1 Port If using T1 as the gateway, click the radio button. 

LAN/untagged •  Imports the IP settings from the legacy LAN IP settings.
•  Imports the Network Mode settings from the previous software version.

WAN/untagged •  Imports the WAN/untagged VLAN IP settings from the WAN settings, if the WAN settings 
were “Use either a DHCP Server” or “Use Static Settings”, and the new WAN setting selects 
VLAN. Otherwise, the WAN/untagged VLAN has its default settings and the WAN setting 
remains unchanged.

•  Imports the Network Mode settings from the previous software version.
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Default Route

Gateway Enter or verify the IP address.

External IP Address Enter or verify the IP address.

Allworx Interface Blocking Rules (Optional)

<Select Interface> Select an available option from the drop-down list.

add rule Saves the new rule to the server.

delete rule Removes the rule from the server.

Firewall (Optional, if enabling the firewall)
The Allworx System Software supports a simple firewall between any two possible network interfaces to prevent unauthorized 
access. The Allworx administrator can add rules consisting of the pairs of interfaces. The Allworx System Software drops 
packets normally routed between the interfaces that are in such a rule. These rules are in effect regardless of the state of the 
Firewall and NAT check boxes, and do not effect spoof ports.

Allworx Reach and Remote 
Allworx Handsets (UPD 2088, 
TCP 8081)

enabled

Allworx View (54441) enabled

DNS Client (UDP 4069) enTCP abled 

DNS Server (UDP 53) enabled

HTTP (TCP 80) disabled

HTTPS: Secure Allworx 
Administration (TCP 8443)*

disabled

HTTPS: Secure Allworx My 
Allworx Manager (TCP 443)*

disabled

IMAP4 (TCP 143) disabled

Multi-Site Voicemail 
(TCP 26)

disabled

POP3 (TCP 110) disabled

PPTP (TCP 1723) disabled

SIP (UDP 5060, TCP 5060) enabled

SNMP (UDP 161) enabled

SNTP Client (UDP 4068) enabled

* Feature is only available on the Connect servers.

Network Address Translation Rules (Optional, if enabling NAT)

Public IF Port # Enter the port information.

Protocol Select an option from the drop-down list.

IP Address Enter the IP address.

Local Port # Enter the port information.

Host Information

Host Name Enter the Host information

Fully Qualified Domain 
Name (FQDN)

Enter the information.
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4. Click Update to save the changes or Cancel to disregard the request. Restart the Allworx 
server for the new settings to take effect.

Click here to return to the “Install Checklist” .
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Chapter 25 Digital Lines

Digital Lines are the integrated T1 interfaces on 
Allworx 48x and Connect 731 servers. Access 
the T1 Digital Line interfaces through the 
connectors labeled T1-A and T1-B on the 
Allworx servers.

The service provider provisions the line to the 
interface, which dictates the configuration of the 
Digital Lines.The settings must match the 
expected configuration of the service provider or 
for proper operation. Configure the line or lines 
in use before physically connecting the server to the T1 line.

When using a Digital Line for circuit switched voice operation (PRI or RBS modes), the preferred 
method is to set all the Digital Line parameters including the functional definition for each time slot on 
T1 line. After setting this configuration, each slot configured to support circuit switch voice calls display 
as a new outside line. That is, logically treat each separate slot configured for circuit switched voice 
calls as a separate telephone line. The differences include:

Allworx 24x or 
Connect Server

The T1-A interface operates as:
•   Primary Rate ISDN line.
•  T1 data line for connectivity to another site or to an Internet Service Provider.
The T1-A interface supports both circuit switched voice calls and TCP/IP data. The T1-A interface also 
supports Robbed Bit Signaling (RBS) operation. Use the dedicated T1-B interface as a data connection. 
Use the data connection for connectivity to another remote site on a dedicated T1 line or for connectivity to 
a service provider for Internet access.

Allworx 48x Server One or both of the T1 interfaces:
•  operate as Primary Rate ISDN lines, Robbed Bit Signaling (RBS) lines, and /or T1 data lines for 

connectivity to another site or to an Internet Service Provider, 
•  support both circuit switched voice calls and TCP/IP data. 
Use the data connection for connectivity to another remote site on a dedicated T1 line or for connectivity to 
a service provider for Internet access.

PRI Support The Allworx server supports Primary Rate ISDN using the National Standard ISDN format (NI-2), Lucent 
Custom 4ESS, Lucent Custom 5ESS, and Nortel DMS-100 switch types. 
Always configure the Allworx server ISDN interface as the user side equipment with the intention of hooking 
to the service provider Central Office (CO) network side equipment. The Allworx server interfaces have a 
fully integrated CSU/DSU, typically intended for a direct, short haul connection to the service provider smart 
jack. Consult the product installation instructions for further information.
NOTE: When using PRI operation it is important to define exactly one PRI D channel for the Digital Line and 
a minimum of one PRI B channel. Match the configuration provisioning defined by the Central Office with a 
typical configuration having 23 B channels on slots 1 through 23 and one D channel on slot 24.

Prerequisites

Access Permissions Allworx Server Administrator
Allworx System Administrator
Network Administrator role
Support Technician role

Feature Key Required No

Servers Allworx 48x and Connect 731
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NFAS Support Non-Facility Associated Signaling (NFAS) is a PRI that multiple T1 lines share the same D channel. The 
Allworx server supports NFAS using the National Standard ISDN, Lucent Custom 4ESS, Lucent Custom 
5ESS, Nortel DMS-100 switch types.
NOTE:
The configuration must match the provisioning defined by the Central Office. 
•  A typical configuration has:

•  Twenty-three B channels on slots 1 through 23.

•  One D channel on slot 24 of the primary T1 line.

•  Twenty-four B channels on slots 1 through 24 of the secondary T1 line. 

•  To configure NFAS on the Allworx system, connect the NFAS line with the D channel to the T1-A port. 

Robbed Bit Signaling / 
Channel Associated 
Signaling Support

The Allworx server supports classical T1 Robbed Bit Signaling (RBS) trunk lines on a time slot by time slot 
basis, sometimes referred to as T1 Channel Associated Signaling (CAS). The system supports the following 
modes: 

For the above selections, operational use is the same as the corresponding analog interface types. The 
system implements the precise signaling protocols for each interface in conformance with the procedures 
documented in EIA/TIA-464C. Inbound Caller-ID is supported on the FXO modes, if the CO supports it. See 
“Digital Lines” on page 147 for more information.

Robbed Bit Signaling / 
Channel Associated 
Signaling Support

For primary CO line connectivity, the preferred slot choice is the FXO Ground-Start slot to minimize the 
possibility for glare conditions, especially when call volume is high. Allworx does not guarantee that the 
network provides an explicit disconnect signal in FXO Loop-Start mode. Example termination methods:

Data Support NOTE: The Allworx administrator can configure and reconfigure the digital lines without a system restart, 
but changes to the Network Configuration settings do require a system restart after updating them.
NOTE: Since the data support is fully symmetrical, it is possible to connect two Allworx servers back-to-
back between their T1 interfaces. Do this either on the same site or across sites using a dedicated T1 line 
that spans between the two sites via the service provider.
The Allworx server configuration enables the Allworx server to carry TCP/IP packets using PPP 
encapsulation on any combination of slots constituting a full or fractional T1 interface. Even when 
configuring a T1 interface for circuit switched PRI operations, use extra (non-voice) slots for dedicated data 
connections as long as the remote end service provider enables this configuration.
Each T1 interface that has data slots configured on it constitutes a single logical serial channel using HDLC 
encapsulation of PPP packets per RFC-1662, using any combination of slots for data on each Digital Line, 
there can be only one logical data interface definition per T1 line.

•  FXO Loop-Start •  E&M Feature Group B •  E&M Wind Start

•  FXO Ground-Start •  E&M Immediate Start

User hangs up phone. Normal call termination.

User hangs up phone under the 
supervision of the Auto Attendant.

No terminating signal can cause the call to remain live for an 
extended period of time (tens of seconds) after the original call 
termination.

Line-side answer supervision The network provides an explicit signal acknowledging that 
the far end has picked up during an outbound call. 
•  Not all FXO lines support this supplemental feature.
•  Because not all network equipment can produce this state, 

calls cannot rely upon it and disregards the state.
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25.1 Restrictions
• Designate one interface as the logical Public interface for the Connect 731 server. Select the 

Ethernet Public Interface or the T1 interface for routing TCP/IP traffic. Select either Ethernet 
VLAN or T1-A port as the data WAN interface for the system even though it is possible to 
provision multiple interfaces simultaneously. 

• Designate one interface as the logical Public interface for the Allworx 24x, 48x, and Connect 
servers. Select the Ethernet Public Interface, T1-A, or T1-B ports for routing TCP/IP traffic. 
Select either Ethernet VLAN, PPPoE, T1-A, or T1-B ports as the data WAN interface for the 
system even though it is possible to provision multiple interfaces simultaneously. 

25.2 Configure the Digital Lines

To configure the digital lines:
To change the Digital Lines setting, see “Manage Digital Lines” on page 108 for more information. 

To configure the T1 line on the Allworx server:
1. Log in to the Allworx server admin page, navigate to Network > Digital Lines.

2. Locate the Digital Line and click Modify. If using an NFAS line, check the Enable NFAS box.

It is important to provision Digital Lines not in use as Disabled. The disabled state is the factory 
default setting for each T1 line. 

Description Description of the Digital Line interface. Use this description in all other places referring to this line, 
such as in the Outlines Lines view and configuration pages of the phone system.

Line Mode The provisioned operational mode for this interface - T1 mode and Disabled are available. 

Line Code/DS0 
Channel Speed

Supports both B8ZS and AMI modes. Allworx strongly recommends using B8ZS mode, if the service 
provider supports it. 
•  Select the setting that matches the service provider setting, but order the lines as B8ZS, if the CO 

switch enables it.
•  In AMI mode, clear channel data service is not available and only a 56K data rate is available on each 

slot. Generally, a PRI line should always be set to B8ZS mode.

Framing The Allworx server supports both Super Frame (D4) and Extended Super Frame (ESF) modes. Select 
the setting that matches the service provider configuration, but Allworx recommends having the service 
provider use ESF mode, if available.

Clock Source Specify the Digital Line data clocking source reference for this interface. 
•  Network clocking is almost always the preferred setting because the service provider is the source of 

the timing reference and the Allworx interface will be the slave to that network clock. 
•  Internal timing mode indicates that the Allworx device is the source of the clocking time reference. 

This mode is useful to hook two devices back-to-back. One end needs to provide the clock reference 
and the other must slave to that master. 

•  The exact terminology may vary from device-to-device. For this setting on Allworx devices, Network 
mode means it is the slave and Internal Mode means it is the clock master.
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Loopback Mode Place the interface into a diagnostic mode for testing purposes. For best results, always select Normal 
Operation. The use of the test modes is beyond the scope of this document.

Line Build Out Determines the pulse shape and transmit power levels used on the analog output of the Digital Line 
interface. 
•  The dB settings are for long haul configurations and the distance settings for short haul 

configurations. 
•  Always use the short haul settings since Allworx equipment is intended for use with a local smart jack 

only and not for driving the physical T1 lines on the telephone poles directly.
•  Select the length setting that matches the cabled distance between the Allworx server and the service 

provider’s demarcation point. If this setting is improperly configured line errors may be very common 
or problematic and affect system reliability.

PRI Switch Type Select the Primary ISDN (PRI) switch type that is in use by the service provider. 
•  Select NONE if there is no connection of this interface to a PRI based service.
•  If this parameter is improperly configured the telephone service will most likely work, however there 

will be subtle problems when certain type of conditions occur such as calling cell phones, busy 
numbers, or during network congestion. Additionally, this may affect Caller ID functionality as well. 
Verify the correct setting from the service provider to set this parameter accordingly.

Voice Channel 
Selection Order

Determines the order the Allworx PBX attempts to seize a line for outgoing calls within each service 
group assigned to this Digital Line. This setting is not critical but having it properly set dramatically 
lowers the probability for a condition called glare where both the PBX and the Central Office attempt to 
put the same slot into service simultaneously for two unrelated calls.
•  Set this selection to be the opposite direction that the service provider uses for incoming calls. 
•  Example: If the service provider:

•  Hunts incoming calls starting from slot 1 towards higher numbered slots looking for the first 
available channel for a new incoming call, configure the PBX for Descending Mode. 

•  Starts at the top and hunts toward lower-numbered slots, select Ascending Mode. 

Caller ID Name Since most PRI lines hook directly into the international SS7 telephone signaling network, it is possible 
to have parties see any Caller-ID string. 
•  For analog phone lines, the CO determines this string. For PRI lines, the Allworx server determines it. 
•  Set the caller ID name field to the preferred value for called parties to see when placing outgoing calls 

on this Digital Line. 
•  The service provider may override these settings.

Caller ID Number The phone number presented to called parties for outgoing calls. See name setting above for more 
information.

Prefer Originally 
Dialed Number 
(RDNIS) for display

This causes displaying T1/PRI originally-dialed/redirected phone number on Allworx phones, if the 
original call was redirected and the CO provides the original call information.

Normal 
Operation

Transmit and receive lines that connect normally and disables all loop back features 
modes.

Local 
Unframed

Does an internal analog loop back on the local interface so that transmit data 
immediately loops back to the receive path. 
•  This mode is useful for verifying that the physical interface is operating correctly on

the Allworx unit. 
•  Although not strictly required, Allworx recommends using B8ZS, ESF, and Clock 

Source Internal for such tests.

Remote 
Frames

Synchronizes and decodes incoming data at the frame level. These decoded frames
are then re-framed locally and sent back out on the transmitted output line.

Remote 
Unframed

Decodes incoming data at the bit level from analog voltages to digital bits and directly
sent out as a stream of bits back towards the source on the transmitted output line. 
No attempt is made to synchronize or verify the data at the frame level.
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Prefer Originally 
Dialed Number 
(RDNIS) for DID 
lookup/call routing

This causes using T1/PRI originally-dialed/redirected phone number in DID routing, if the original call 
was redirected and the CO provides the original call information.

Channel 
Assignments

Select the operating mode for each time slot per the provisioning defined by the service provider or 
device connected to the Digital Line. Improper selections causes poor results. Select an option from the 
drop-down list or locate the Set all channels to: and select an available option. 

Disabled Indicates an unused time slot on this Digital Line.

PRI B Channel Bearer channel for ISDN PRI operation used for carrying voice calls. Selecting 
this mode defines a new outside line for the PBX for each configured slot.

PRI D Channel Data-signaling channel for ISDN PRI operation used for transporting call control 
information between the PBX and the Central Office. 
The Allworx server always operates as user equipment on a PRI line. 
If enabling PRI operation on this line, configure exactly one slot as the PRI D 
channel. Typically, this is slot 24. 
When using NFAS, the D channel must be on the T1-A port.

T1 E and M 
Immediate Start 
RBS

Circuit-switched Ear and Mouth mode Robbed Bit Signaling trunk that uses 
Immediate Start signaling. 
Defines a new outside line for the PBX for each slot configured in this mode. 
This mode is symmetrical.
Used to hook the PBX back to back to tie PBXs between sites on a leased line.

T1 E and M Wink 
FG-B RBS

Circuit-switched Ear and Mouth mode Robbed Bit Signaling trunk. 
•  Defines a new outside line for the PBX for each slot configured in this mode. 
•  This mode is symmetrical and used to hook PBXs 

back-to-back to tie PBXs between sites on a leased line. 
•  Only use DTMF signaling. 
•  The system does not support Multiple Frequency (MF) signaling.

T1 E and M Wink 
FG-D RBS

Circuit-switched Ear and Mouth mode Robbed Bit Signaling trunk. 
•  Defines a new outside line for the PBX for each slot configured in this mode. 
•  This mode is symmetrical and also used to hook PBXs back-to-back to tie 

PBXs between sites on a leased line. 
•  Only use DTMF signaling. 
•  The system does not support Multiple Frequency (MF) signaling.

T1 FXO 
Loop-Start RBS

Circuit-switched Foreign Exchange Office style interface mode that digitally 
emulates the standard analog telephone line interface that uses Loop-Start 
signaling. 
•  Defines a new outside line for the PBX for each slot configured in this mode. 
•  If call volume is high, this mode is less desirable than FXO Ground-Start 

Operation. This connects to the service provider interface that is operating as 
the FXS side of the interface. 

•  This mode is NOT symmetrical.

T1 FXO Ground-
Start RBS

Circuit-switched Foreign Exchange Office style interface mode that digitally 
emulates the standard analog telephone line interface using Ground-Start 
Signaling. 
•  Defines a new outside line for the PBX for each slot configured in this mode. 
•  The Ground-Start operation is able to minimize the possibility of glare 

especially when call volumes are high, making it more preferable than Loop-
Start. 

•  This is intended to connect to the service provider interface that is operating as 
the FXS side of the Ground-Start interface. 

•  This mode is NOT symmetrical.
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3. Click Update to save the changes or Cancel to disregard the request.

Channel 
Assignments
(con’t)

Click here to return to the “Install Checklist” .

56K Data 
Channel

Specifies this slot provides 56Kbits/sec of bandwidth for the Digital Line logical 
data connection. 
•  This mode is typically used if 64K clear channel service is not available. 
•  Only use this mode for data connections when selecting AMI Line Code mode

64K Data 
Channel

Specifies that this slot provides 64Kbits/sec of bandwidth for the Digital Line 
logical data connection. 
•  Use this when clear channel data service is available. 
•  Do not select this mode if selecting the Digital Line’s AMI Line Code mode.
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Chapter 26 Multi-Site

The Multi-Site feature supports the ability to 
integrate multiple sites seamlessly. Allworx 
administrators can join up to 99 Allworx servers 
in a Multi-Site network with up to 1000 users and 
up to 1000 system extensions across all sites. 
The total number of Multi-Site Users and 
Multi-Site System Extensions varies with the 
maximum users licensed on each Allworx 
server. 

The Multi-Site feature supports increased multi-site network security and reduces the time necessary 
to rebuild or rejoin a multi-site network.

26.1 Setup Checklist
Follow the order of the steps to successfully setup the multi-site network.

26.2 Manage the Multi-Site Network
Prior to setting up the multi-site network or for tips to configure the Allworx Phone system for a 
multi-site network:

• read the Allworx Advanced Multi-Site Setup Guide for details

• View customers: perform a backup of the View database prior to changing the multi-site 
configuration (see the Allworx View Users Guide for more information).

Step Description Installation Guide Link

1 Verify the Internal Dial Plan is the same on all servers in a multi-site 
network. The Allworx system does not enable sites to join the network if 
the Internal Dial Plan is different from the Controller site Dial Plan.

 “Dial Plan” on page 37

2 Configure and enable multi-site on the Controller before enabling any 
of the Branch sites. Doing so enables the Branch sites to register 
immediately.
NOTE: The Allworx system does not permit using Allworx 6x12 servers 
as a Controller site.

“To configure the sites:” on page 154

3 Configure and enable the branch sites.

4 Build/rebuild (available on the Controller site only) or rejoin (available 
on the Branch site only) the multi-site network.

5 Manage the voicemail transfer settings. “To manage the voicemail transfer settings:” on 
page 155

Prerequisites

Access Permissions Allworx Server Administrator
Allworx System Administrator
Network Administrator role

Feature Key Required •  Multi-Site Primary 
•  Multi-Site Branch
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To configure the sites: 
1.  Log in to the Allworx web server admin page.

2. Install the Multi-Site Primary and Multi-Site Branch feature keys. See “Feature Keys” on 
page 217 for more information. Verify that Multi-Site Primary displays in the Currently Installed 
Feature list. If it is not in the list, obtain a Multi-Site Primary key from the Allworx Distributor.

3. Navigate to Network > Multi-Site, and then click:

Link Description

Configuration

modify Update the current settings. 
1.  Specify a multi-site role for this server: 

•  In the Site List section, a message displays <Controller Site IP Address> contacted. Pending 
acceptance from admin at site. This indicates the Branch site sent a request to the Controller site to 
join the multi-site network. The Branch site stays in this state until the Controller site manually accepts 
this request.

•  The message <Controller Site IP Address> is being contacted, indicates the Branch site is waiting 
for a response from the Controller. 

•  Click Refresh to verify if the “Pending acceptance” message displays. If the refreshed page 
continues to display the is being contacted message, there is a problem. 

•  Verify the Controller site configuration and verify the network communications between sites.

2.  Click Update to save the changes or Cancel to disregard the request.
NOTE: If the Branch Site Internal Dial Plan or Extension Length is different from the settings on the 
Controller site, the system does not enable the Branch site to join the network.

advanced Only change the site identifier at the direction of Allworx Customer Support.

Go Offline Disconnects the server from the multi-site network. If a server is Offline, the other active sites receive a 
notification, which clears the server credentials and prevents the Offline site from communicating with 
the other servers on the multi-site. 

Rebuild Rejoin all active sites and those without a pending accept status. Sends a request to Branch servers in 
the list to resend connection information.

When rebuilding a Multi-Site network (either by deleting or using the Rebuild button), local handsets 
owned by remote users become “unowned” phones and display (none) in the owner column on the 
Phone System > Handsets > SIP Handsets page. 

Rejoin Send a request to the Controller server to re-establish a connection in the multi-site configuration 
without disabling the server and re-entering the branch server data. For servers that fail a join attempt.

Disabled Ends the server multi-site connections. If a server becomes disabled, the other 
active sites receive a notification, and the Allworx system removes the disabled 
site from the database.

Controller Site Enter a descriptive site name for this site. The name displays on the Admin page 
of all sites as the home location for extensions, users, and handsets.

Branch Site Enter the public IP Address or the domain name of the Allworx server at the 
Controller site. The name displays on the Admin page of all sites as the home 
location of extensions, users, and handsets.
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To manage the voicemail transfer settings:
Configure the firewall settings for transferring voicemail between sites.

1. Log in to the Allworx web server admin page. 

2. Navigate to Network > Multi-Site and locate the Voicemail Transfer Settings section.

Site List
A list of sites available to add to the multi-site configuration.

Pending Sites A list of available sites to add to the multi-site configuration.
•  Accept - adds the server to the multi-site configuration.
•  Deny - does not add the server to the multi-site configuration.
NOTE: After accepting the sites, the Active Sites table updates from the Pending Sites table. Notice the 
status that displays in the Inbound Link and Outbound Link columns. It may take a few minutes for all 
servers to report an Active status. “Active” indicates that the Controller site and the Branch site 
exchanged all required information (i.e. users, extensions, and handsets). 

Active Sites Displays the handsets available on the branch site. Click:

Mapped Handsets
Displays a list of handsets mapped from the branch site to the controller site.

Conflicts
If there are cases where the same defined extension phone number was on more than one server, then conflicts in the data 
result during the data exchange between sites. Another kind of conflict occurs if users defined on more than one server have 
the same username. Check and resolve conflicts and resolve on each server:
Entries in the Username and User Extension Conflicts table indicate either an Ext conflict or a Login Name conflict. Look up 
the extension at each of the conflicting sites. 
•  If users on different sites are using the same extension, change one of the user’s extensions on all but one of the conflicting 

sites to resolve the conflict.
•  If users on different sites are using the same Login name, delete one of the conflicting users and re-add it with a different 

username. Note that this deletes the configurations and saved voicemails for the deleted user. 
For any entries in the System Extension Conflicts table, delete the extension from one of the conflicting sites to resolve the 
conflict. Remember the call route of the deleted extension, and then add a new extension with that same call route.
Verify that all conflicts have been resolved on all servers.

Link Description

handsets •  hide - collapses the list of sites.
•  modify - map the specified handsets. Click the checkbox next to the handset 

model to enable. Click Update to save the changes or Cancel to disregard the 
request.

delete Removes the site from this and all other servers. Click Delete to remove the site 
or Cancel to disregard the request.

test If any tests fail, the most likely cause is the configuration of network devices 
between the sites. Check the firewall settings, port assignments, static routes, 
and port forwarding between the current site and the remote test site.
•  hide - collapses the list of available tests.
•  HTTP
•  BLF
•  SMTP
•  SIP
•  Audio Call
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3. Click modify and update the settings.

4. Click Update to save the changes or Cancel to disregard the request.

TCP/IP Port Enter the Allworx server IP address LAN TCP/IP Port.

Maximum Sessions Enter the total number of active voicemail or email transfer sessions across the multi-site 
network at one time.

Single Message Size 
Limit (bytes)

Enter the maximum message size in bytes for one message. Entering a 0 equals no limit.

Maximum Messages 
Per Session

Enter the maximum number of messages per each session. Entering a 0 equals no limit.

Click here to return to the “Install Checklist” .
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Chapter 27 Px Expanders and Remote Phones

Px 6/2 Expander expands the system analog 
capability by adding six (6) FXO and two (2) FXS 
ports to most Allworx servers. Allworx 
administrators can use the Plug and Play 
installation feature for locally connected units. 
For detailed installation instructions, see the 
Allworx Px 6/2 Expander Installation Guide.

For remote installation use the approach similar 
for remote Allworx phones. 

Allworx defines a remote device as a Px Expander or phone on a different Local Area Network (LAN) 
from the Allworx server. 

Example:
An Allworx server is at the company main office but an employee has a home office phone. 

The Allworx administrator configures:

• the server for calls to and from the phone as though the employee is at the main office. 

• the analog phones or CO lines on a remote Px Expander to integrate into the server network 
and dial plan.

27.1 Setup Checklist
Follow the order of the steps to successfully setup the Px Expander.

Caution: Allworx cannot guarantee proper routing of 911 emergency calls from remote Allworx phones or analog handsets 
attached to remote Allworx Px Expanders. Do not configure remote handsets to place 911 calls.

Caution: During a network connection interruption between the Px Expander and the Allworx server it is not possible for regular 
use of the Px Expander FXO and FXS ports. The only option to place calls through a Px Expander without a functional 
network connection to the Allworx server is plugging an analog phone into the Power Fail port. The CO line connected 
to FXO port 1 routes the calls placed using this phone. No other ports are functional.

Step Description Installation Guide Link

1 Install and configure the Px Expander. For more detailed information, see Allworx 
Px 6/2 Expander Installation Guide.

2 Configure the Px Expander. “To mange a Px Expander:” on page 158.

3 Configure the FXS and FXO ports. “Manage FXO and FXS Ports” on page 159.

4 Change the network settings on a handset (using soft keys) or Px 
Expander.

“Change the Network Settings” on page 160.

5 Update the firewall settings. “Devices Behind a Firewall” on page 161.

Prerequisites

Access Permissions Allworx Server Administrator
Allworx System Administrator
Network Administrator role

Feature Key Required No

Servers Allworx 6x, 48x, and Connect



Section 4 - Network

Page 158 1 866 ALLWORX * 1 585 421 3850
www.allworx.com

Revised: 03/25/2016

27.2 Manage the Px Expander
Displays a list of all Px Expanders on the Allworx server. 

To enter the Boot Server IP Address and Plug and Play Secret Key into the phone, press the Config 
soft key and select the Network Settings menu. See “VoIP Server” on page 181 for more information. 

To enter the information into an Allworx Px 6/2 Expander, see the Allworx Px 6/2 Expander Installation 
Guide for more information.

To mange a Px Expander:
1. Set up and configure the Px Expander per the Allworx Px 6/2 Expander Installation Guide.

2. Log in to the Allworx server admin page, navigate to Network > Port Expanders.

3. Click one of the following links:

add new Port 
Expander

Activate a Px Expander on the server. See “Px Expander Settings” on page 159 for additional 
information. Click Add to save the change or Cancel to disregard the request.

<Port Expander 
name>
(available after 
adding a port 
expander)

Click one of the following links:

Delete Removes the Px Expander from the server. Click Delete to save the change or Cancel to disregard the 
request.

Replace Replace the Px Expander with another Px Expander while automatically transferring all the 
configuration parameters and settings to the new unit. 

Handsets Jumps to the Handsets page to configure the Px Expander FXS ports.

Outside Lines Jumps to the Outside Lines page to configure the Px Expander FXS ports.

<IP Address> Opens the Allworx admin page of the Px Expander in a separate browser window. Use this link to view 
the event log or view/modify the on-board settings.

Reboot Restart the Px Expander after making configuration changes to the expander or any of its ports. The 
reboot starts as soon as all of the Px Expander ports are idle. 

Modify Update the Px Expander settings on the server. See “Px Expander Settings” on 
page 159 for additional information. Click Update to save the change or Cancel to 
disregard the request.

Delete Removes all related configurations and port definitions from the system.

Replace Replace the Px Expander with another Px Expander while automatically transferring 
all the configuration parameters and settings to the new unit. Use this when 
replacing a defective Px Expander.

Handsets Jumps to the Handsets page to configure Px Expander FXS ports.

Outside Lines Jumps to the Outside Lines page to configure Px Expander FXS ports.

<IP Address> Opens the Px Expander information page in a separate browser window. 

Reboot Restart the Px Expander after making configuration changes to the expander or any 
of its ports. The reboot starts as soon as all of the Px Expander ports are idle. 
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Px Expander Settings

27.3 Manage FXO and FXS Ports
After installing an Allworx Px Expander, the Allworx administrator can configure the FXS and FXO ports 
on the Handsets and Outside Lines pages, just like the server ports. On the Dial Plan page, the system 
adds Px Expander FXO ports to the default service groups. Create new custom service groups or 
modify existing service groups to include the Px Expander FXO ports.

27.4 Phone/Px Expander behind a Third-Party Firewall
Remote phones and Px Expanders work even when behind a firewall. There are exceptions, which 
require additional configuration steps. To avoid most problems with firewalls, route remote audio traffic 
through the server; however, this uses server connection bandwidth. 

Setting Description

MAC Address Hardware identifier for the Px Expander. It cannot be changed.

Description Name given to the Px Expander. During Plug and Play installation, the Description is set to the Px Expander 
MAC address. Allworx recommends changing it to something more meaningful to the site or configuration.

Codec Preference 
Order

Set the preferred codec order for the Px Expander. The server does not support all codec for all call types 
(for example, accessing the server Auto Attendant requires G.711). Codec is the method of encoding/
decoding the audio sent and received. 
•  The two possible codec are G.711 and G.729A. G.711 preserves voice quality but takes more bandwidth. 

G.729A takes less bandwidth but reduces voice quality.
•  This setting defines the order of codec selection. 
•  The Px Expander attempts to use the first choice but uses whichever required codec to support calls.

RTP Media Range 
(Port to Port)

Specifies the range of UDP ports used for Real-Time Transport Protocol communications. 
•  When placing remote Px Expanders behind third-party firewalls, under certain conditions restrict the UDP 

port range to create mapping rules for each Px Expander behind the firewall. See “Phone/Px Expander 
behind a Third-Party Firewall” on page 159 for more information.

SIP NAT 
Keep-alive Interval

Some NAT firewalls automatically time out and close connections to devices. 
•  If a remote Px Expander is behind such a firewall, this setting prevents the timeout.
•  Messages called keep-alive packets are sent from the Px Expander to the Allworx server at the frequency 

specified. 
•  Set the value to an interval shorter than the firewall timeout.

SIP Port UDP port number used for the SIP protocol by the Px Expander. Use the default value of 5060 unless the Px 
Expander is behind a third-party firewall and the network requires a different value.

Time Zone Specify the time zone that the handset uses to compute its local time. 
•  If the Px Expander is in the same time zone as the Allworx server, select use current server.
•  If the Px Expander is remote, use the time zone of its actual location.

Daylight Savings 
Time

Specify if the Px Expander will use Daylight Savings Time (DST) to compute its local time. 
•  If the Px Expander is in the same time zone as the Allworx server, select use current server.
•  If the Px Expander is remote, use the DST setting of its actual location.

Jitter Buffer Size Alters the size of the jitter buffer. Jitter is a variation in network audio packet latency experienced by the Px 
Expander, resulting in a reduction in audio quality. The Px Expander uses a jitter buffer to maximize the 
audio quality when jitter occurs. 
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By default, all audio traffic from remote phones and Px Expanders runs through the Allworx server. 
When calls to and from remote devices go out over SIP trunks or over the Internet to other remote 
devices, the bandwidth usage is 180 Kbytes per call, which is double a regular incoming call.

This traffic degrades the call audio quality using the Internet. However, enabling audio between 
devices to go directly from one to the other, rather than through the server reduces this effect. See 
“VoIP Server” on page 181. Disabling it reduces server bandwidth usage. However, if doing this and 
the phone or Px Expander is behind a firewall, the firewall requires configuration.

27.5 Change the Network Settings
If the remote device does not register with the server or if calls to / from the server do not connect, 
change the settings on the firewall and the phone or Px Expander to enable communications. 

To change the network settings on a handset (using soft keys) or Px Expander:
1. Use the phone soft keys, navigate to Config > Network Settings menu for phones, and locate 

the Config Mode page for Px Expanders. 

2. Change the following settings:

3. Log in to the Allworx server admin page and navigate to Network > Port Expanders.

4. Click Port Expander Description. Set the RTP port range for the phone or Px Expander to 
16384 or 16393. Forward the required IP ports through the Firewall at the remote site, per the 
table: 

Port Type WAN LAN Protocol

BLF 2088 2088 UDP

SIP 5060 5060 UDP/TCP

RTP 16384 - 16393 16384 - 16393 UDP

DHCP Disabled

Remote Plug and Play key See “Phone/Px Expander behind a Third-Party Firewall” on page 159.

Boot Server IP See “Phone/Px Expander behind a Third-Party Firewall” on page 159.

Phone/Port Expander IP Select an address consistent with the remote site network.

Netmask IP Network Mask of the remote site network.

Gateway IP Gateway IP of the remote site network.
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27.6 Devices Behind a Firewall

27.6.1 Multiple Remote Devices behind the Same Firewall
If there is more than one remote Allworx device behind a firewall, change the firewall settings and the 
phone or Px Expander to enable the configuration.

1. Use the phone soft keys, navigate to Config > Network Settings menu for phones, and locate 
the Config Mode page for Px Expanders. 

2. Change the following settings:

3. Log in to an Allworx server admin page and navigate to Network > Px Expanders.

4. Click on the Port Expander Description. Allocate 10 ports for each device in the standard 
range (e.g. phone1: 16384 to 16393, phone2: 16394 to 16403). Select a different SIP port for 
each device, starting at 5060 (e.g. phone1: 5060, phone2: 5061). 

5. Forward the required IP ports through the firewall at the remote site, per the table. 

DHCP Disabled

Remote Plug and Play key See “Phone/Px Expander behind a Third-Party Firewall” on page 159.

Boot Server IP See “Phone/Px Expander behind a Third-Party Firewall” on page 159.

Phone/Port Expander IP Select an address consistent with the remote site network.

Netmask IP Network Mask of the remote site network.

Gateway IP Gateway IP of the remote site network.

Configure the VoIP settings See “VoIP Server” on page 181.

Port Type WAN LAN Protocol IP Address

BLF 2088 2088 UDP 192.168.2.7

SIP 5060 5060 UDP/TCP 192.168.2.7

SIP 5061 5061 UDP/TCP 169.168.2.8

RTP 16384 - 16393 16384 - 16393 UDP 192.168.2.7

RTP 16394 - 16403 16394 - 16403 UDP 169.168.2.8

Note: Map the BLF port for one of the remote devices. The device that gets the BLF messages from the server forwards the 
BLF information to every other Allworx desk phone in that subnet.
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27.6.2 Different Remote Site Phones, Each with a Firewall
This is very similar to “Multiple Remote Devices behind the Same Firewall” on page 161. because it is 
necessary to do the mappings on each site firewall. 

• Map the correct RTP port range for the device that is on the configured firewall. 

• Map the BLF port (2088) for one device on each firewall.

27.7 Paging with Remote Phones
Remote phones do not receive pages. Users can send pages from a remote phone, but do not hear 
the zoned or overhead pages. To enable paging to a remote phone, set up a VPN between the Allworx 
server and the remote phone. See “VoIP Server” on page 181 for more information. This document 
does not cover the configuration the site firewall for the VPN due to the many possible variations.

Click here to return to the “Install Checklist” .
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Chapter 28 Static Routes

Static Route occurs when a router uses a 
manually-configured routing entry, rather than 
information from a dynamic routing protocol to 
forward traffic. 

This chapter describes customizing the static 
routes for the business needs.

To manage the Static Routes:
1. Log in to the Allworx server admin page, and navigate to Network > Static Routes. 

2. Click modify and update the settings:

3. Click Update to save the changes or Cancel to disregard the request. Restart the Allworx server 
for the new Network Static Route settings to take effect.

Destination Enter a descriptive name in the field.

Netmask Select an option from the drop-down list.

Gateway Enter the Gateway IP Address.

External IP Enter the External IP Address.

Click here to return to the “Install Checklist” .

Prerequisites

Access Permissions Allworx Server Administrator
Allworx System Administrator
Network Administrator role

Feature Key Required No
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Chapter 29 Virtual Private Network (VPN)

VPN provides access to remote and secure 
data. The Allworx Connect servers support a 
single-user diagnostic VPN, and the VPN feature 
is not available for Allworx 6x12 servers.

To enable the VPN PPTP server:

1. Log in to the Allworx server admin page, 
and navigate to Network > VPN. The 
VPN page displays.

2. Click Modify, and then check the Enable VPN PPTP Server box and update the fields with the 
required information.

3. Click Update to save changes or Cancel to disregard the request. Restart the Allworx server for 
the VPN changes to take effect.

To enable VPN for individual users, see “User Template Settings” on page 136 for more information.

Click here to return to the “Install Checklist” .

Prerequisites

Access Permissions Allworx Server Administrator
Allworx System Administrator
Phone Administrator role
Network Administrator role

Feature Key Required Virtual Private Network (VPN)*

* The Allworx server does not require the feature key for opening 
a single-user remote diagnostic VPN.
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Part 5  Servers 

The Servers features support customizing the server types specific to the business requirements.Each 
chapter explains:

• necessary access permissions and feature keys,

• necessary equipment to perform the procedures, and

• necessary procedures to setup and customize the Allworx server network.

The various Server pages on the server web admin site enable the Allworx administrator to set up, 
configure, and manage the settings of the following server types:

• DHCP

• DNS

• Email

• Reach Link

• SNMP

• VoIP

• Web
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Chapter 30 DHCP

The DHCP server displays the active leases 
associated with the DHCP server. 

30.1 Manage the DHCP 
Server

To manage the DHCP server:
1. Log in to the Allworx server admin page, navigate to Servers > DHCP. The DHCP Server page 

displays with the server information, active leases, and known hosts.

2.  Locate the DHCP Sever section, and click the IP Address upward or downward facing arrow to 
sort the servers ascending or descending order, respectively.

3. Click modify, and then update the settings.: 

4. Click Update to save the changes or Cancel to disregard the request. Any saved changes 
require restarting the Allworx server.

30.2 Delete a Known Host
The web admin page displays the Known Hosts associated with the DHCP server. 

1. Log in to the Allworx server admin page, navigate to Servers > DHCP. The DHCP Server page 
displays with the server information, active leases, and known hosts.

2. Locate the Known Hosts section, and click the IP Address upward or downward facing arrow to 
sort the servers ascending or descending order, respectively.

3. Check the box next to the IP Address, and click Delete to remove the IP Address from the list.

Enable DHCP Server Check the box to enable.

Dynamic Address Range Enter the ending IP Address ranges in the fields provided. 

DHCP Address Reservations Enter the ending TCP/IP Address and the MAC Address in the fields provided.

Enable Dynamic DNS DHCP server automatically adds discovered hosts to the DNS Server list. Check the box 
to enable.

Click here to return to the “Install Checklist” .

Prerequisites

Access Permissions Allworx Server Administrator
Allworx System Administrator
Network Administrator role

Feature Key Required No
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Chapter 31 DNS

The DNS server resolves and maintains a 
directory of domain names, and then translates 
the names to Internet Protocol (IP) Addresses. 

To manage the DNS server:
1. Log in to the Allworx server admin page, 

navigate to Servers > DNS. The DNS 
Server page displays with the current 
values.

2.  Click one of the following links: 

3. Click Update to save the changes or Cancel to disregard the request. Any saved changes 
require restarting the Allworx server.

modify Update the current settings. 

flush the DNS
 cache

Clears the locations (IP addresses) of web servers containing recently viewed pages. 

Click here to return to the “Install Checklist” .

Prerequisites

Access Permissions Allworx Server Administrator
Allworx System Administrator
Network Administrator role

Feature Key Required No

Operating Mode

Normal The Allworx server attempts to resolve domain names to IP addresses in 
this order: internal cache, Primary DNS Server (if specified), Secondary 
DNS Server (if specified), list of well-known DNS Root Name Servers (only 
if there are no specified Primary or Secondary servers).
•  Primary DNS Server - Enter the IP Address in the field provided.
•  Secondary DNS Server - Enter the IP Address in the field provided.

Stand Alone The Allworx server does not use any external servers to resolve domain 
names to IP addresses. The Allworx server processes domain names not 
resolved internally as invalid.

Host Table

DNS Zone: Use the Allworx DNS server to host the DNS Zone. Uncheck if another 
computer hosts the DNS Zone.

Host Name Enter the host name.

IP Address Enter the host IP Address.
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Chapter 32 Email

The Email server handles and delivers e-mail 
over a network. The procedure in this chapter 
describes customizing the email server for the 
business needs.

To manage the Email Server settings:
1. Log in to the Allworx server admin page, 

navigate to Servers > Email. The Email 
Server displays with the current settings and values.

2. Click one of the following links: 

Email Server Configuration Settings

Modify Change the current email settings. See “Email Server Configuration Settings” on page 173 for 
more information. 
•  Click Update to save the changes or Cancel to disregard the request. 
•  Modifying the settings requires restarting the Allworx server for the new settings to take 

effect.

manage the email 
queue

Displays a list of the current emails. 
1.  Select a single email by checking the box in the left column or all the emails by clicking 

Check All. To uncheck all the email check boxes, click Clear All.
2.  Select one of the available options:

3.  Refresh Page: click to update the viewable emails.

Features

Connection Timeout (secs) Enter a value in seconds.

Voicemail Attachment Format Select an option from the drop-down list.

SMTP Settings
Forward voicemail and email using external Internet SMTP services such as Gmail and Hotmail. The web admin page includes SMTP 
server settings to enter login credentials for an existing email account. Use this account for email, voicemail, and text alerts. For user 
voicemail, it sends the email to the address in the user’s Message Alias.

Port Enter a value.

Transmit Threads Enter a value.

Transmit Queue Depth Enter a value.

Prerequisites

Access Permissions Allworx Server Administrator
Allworx System Administrator
Network Administrator role

Feature Key Required No

Flush Clears the email or emails from the list without Non-Deliverable 
Receipts (bounced messages).

Flush with NDR Clears the email or emails from the list with Non-Deliverable 
Receipts (bounced messages).

Retry Send Now Attempts to resend the email. 

Cancel Disregards changing the email queue.
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Notify Sender of Delivery 
Delay

Check the box to enable. 

Enable use of SMTP Smart 
Host

Check the box to enable. Enter the following information:

Enable use of SMTP Server 1.  Check the box to enable. Enter the following information:

2.  Click Send Test Email.

POP3 Settings
Only the email and voicemail message option transfers voicemail messages to the PC inbox. Configure the email program on the PC 
used to receives messages to pop the messages from the Allworx server. Use the following information to configure the email program:
NOTE: Most email programs enable leaving the messages on the server when transferring to the PC. When using this feature, the user 
may exceed the server inbox quota. To avoid this, Allworx recommends enabling the email program to:
•  Delete all the server email after N days. 
•  Delete the email when the user deletes it on the PC.

Port Number Enter a value.

Maximum Connections Enter a value.

Number Client Threads Enter a value.

Max. Depth Client Deferred 
Queue

Enter a value.

Min. Poll Period (minutes) Enter a value.

Secure Login Check the box to enable.

Smart Host Address Enter IP Address or DNS name.

Smart Host Port Enter a value.

Smart Host requires 
authentication

Check the box to enable.
•  Smart Host User name
•  Smart Host Password

Email for local domain Select an option from the drop-down list.

Voicemail for local domain Select an option from the drop-down list.

Server Address Enter IP Address or DNS name.

Server Port Enter a value.

Display Name Enter a value.

Sender’s Email Address Enter a value.

Use authentication Check the box to enable.
•  User name
•  Password

Use authentication Secure Connection - Select an option from the drop-down list.
•  None - No secure connection.
•  SSL - Uses SSL without sending the STARTTLS message at the 

beginning of the connection prior to doing the SSL handshake.
•  TLS - Uses SSL WITH sending the STARTTLS message at the 

beginning of the connection prior to doing the SSL handshake.
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IMAP Settings
IMAP synchronizes email so users can access an account from multiple locations. Configure the PC email application to send and 
receive messages from the Allworx server. The details depend on the application but require:
•  Entering the Allworx server IP address LAN TCP/IP Address (from the Network > Configuration > Modify page) as the incoming 

IMAP server address.
•  Entering the same address as the outgoing SMTP server address.
•  Entering the Allworx user login name / password as the IMAP user / password.
•  Do not use Secure Password Authentication (SPA).
•  Do not use SSL to communicate with the Allworx server.
•  Do not use authentication for the outgoing server.
NOTE: Enabling the IMAP protocol requires a Mobile Link Feature Key on the Allworx server.

Port Number Enter a value.

Maximum Connections Enter a value.

Alternate Email Domains

<alternate domain name> Enter a different email domain in the field provided.

Unsolicited Bulk Email

Use Block Service(s) Check the box to enable, and then enter the URL in the field provided.

Click here to return to the “Install Checklist” .
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Chapter 33 Reach Link

Adjusting the Reach Link settings requires 
assigned permissions enabled within the specific 
application.

In a multi-site network configuration: Reach Link 
functionality is limited to users and handsets 
configured on an Allworx server with the Reach 
Link feature key installed.

To manage the Reach Link server:
1. Log in to the Allworx server admin page, navigate to Servers > Reach Link. The Reach Link 

Server page displays with the current values.

2. Click modify and update the information:

3. Click Update to save the changes or Cancel to disregard the request. Any saved changes 
require restarting the Allworx server.

Server Web Admin Page My Allworx Manager Reach Application

•  Set the amount of time to determine:

•  Reach device has lost the server 
connection during an active call.

•  Begin call restoration after the "Lost 
Connection Timeout" expires during an 
active call.

•  Set up recovery numbers including 
descriptions to dial when the connection 
to an Reach device is lost during an active 
call per user.

•  Set up fallback numbers including 
descriptions to dial when the connection 
to an Reach device is lost during an active 
call per user.

•  Select the hold music for the non-Reach 
user to hear when the Reach connection 
is lost during an active call.

•  Define the restoration number to attempt 
when an Reach device data connection is 
lost during an active call per user.

•  Define the fallback number to attempt 
when an Reach device data connection is 
lost during an active call per user.

•  Define the number of rings to wait when 
attempting a restoration number when an 
Reach device data connection is lost 
during an active call per user.

•  Define the final destination when an 
Reach device data connection is lost 
during an active call per user

Enable Reach Link Server Globally enable or disable Reach Link on all Reach handsets on the server. 

Lost Connection Timeout (secs) Enter a value for the amount of time a network is down before the Reach Link 
reconnection process begins. 

Call Recover Timeout 
(secs)

Enter a value for the amount of time after starting the Reach Link feature and determining 
a call is lost. 

Hold Music Selection Select an option from the drop-down list.

Click here to return to the “Install Checklist” .

Prerequisites

Access Permissions Allworx Server Administrator
Allworx System Administrator
Network Administrator role

Feature Key Required Reach Link
(one feature key for all users)

Servers Connect servers
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Chapter 34 SNMP Server

The SNMP server collects information from and 
configures network devices on an Internet 
Protocol (IP) network such as:

To manage the SNMP server:
1. Log in to the Allworx server admin page, navigate to Servers > SNMP. The SNMP Server page 

displays with the current values.

2. Click modify and update the Enable SNMP Agent line. Check the box to enable.

3. Click Update to save the changes or Cancel to disregard the request. Any saved changes 
require restarting the Allworx server.

• servers • printers

• hubs • switches

• routers

Click here to return to the “Install Checklist” .

Prerequisites

Access Permissions Allworx Server Administrator
Allworx System Administrator
Network Administrator role

Feature Key Required No
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Chapter 35 VoIP Server

The VoIP server supports businesses 
transferring the traditional phone systems to a 
dedicated server-based system and offers a 
central location to control the internal 
communications systems. 

To manage the VoIP server:
1. Log in to the Allworx server admin page, 

navigate to Servers > VoIP. The VoIP 
Server page displays with the current values.

2.  Click modify and update the settings: 

BLF Port Typically set to 2088. If necessary, change for firewall rules.

Secure BLF Default - unchecked.

Force Remote Phone audio through server For WAN to WAN calls. Check the box to enable.

Plug and Play Secret Key Click show to see or change the code. Click hide to remove from sight.

Phone Administration Password Access each handset through a web interface. The Phone Admin page has the 
same look and feel as the Allworx server admin page. However, the password 
used to access the phone admin page is NOT the same.
•  View stored configuration information of the handset.
•  Modify the handset’s configuration and personal speed dials.
•  View information (event log, call history, phone configuration parameters).
Click show to see or change the code. Click hide to remove from sight.
NOTE: Users receive an error message when trying to use Allworx as the 
password. The system does not accept Allworx as the password, enter another 
password.
To access the administration page of an Allworx handset:
•  From the Allworx server admin page, navigate to the Phone System > 

Handsets page and then click handset IP address.
•  From a browser, enter the IP address of the handset. Find the IP address 

using the handset soft keys: CONFIG > Current Status > Info.

Global SIP Connection Limit Set to at least 1 for SIP trunks, remote phones, remote sites as bandwidth 
allows.

Paging Base IP Address The multicast base IP address used by the server. 
•  Each paging zone uses the base address plus an offset. Zone 0 (the overhead 

zone), uses an offset of 0, zone 1 uses an offset of 1, etc. 
•  Example, if the base address were set to 239.255.10.0, then zone 2 would use 

multicast IP address 239.255.10.2.

Paging Port The UDP port number destination for the packets. All zones use the same port 
number, but each has its own multicast IP address. Enter a value.

Paging Maximum Hop Count Controls the time-to-live (TTL) count in the IP header of all paging UDP/RTP 
frames. Enter a value.
•  Typically, this value is set to 1 so that the packet is not sent beyond the local 

subnet. 
•  If there are multiple subnets with phones, increase this value

Prerequisites

Access Permissions Allworx Server Administrator
Allworx System Administrator
Phone Administrator role
Network Administrator role

Feature Key Required No
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3. Click Update to save the changes or Cancel to disregard the request. As necessary, restart the 
Allworx server or handsets. 

Paging Maximum Duration Enter a value.

RTP Base Port Enter a value.

RTP DTMF Payload Enter a value.

RTP DSCP Tag Select an option from the drop-down list.

SIP DSCP Tag Select an option from the drop-down list.

Disable Phone Creates via LAN Plug and 
Play

Check the box to activate the feature.

Disable Phone Creates via Wan (Remote 
Phone) Plug and Play

Check the box to activate the feature.

Disable Assign User at Phone Check the box to activate the feature.

Disable PCP Proxy Check the box to activate the feature.

Requires a restart Does not 
require a 

restartSetting Server
Allworx 
Handset

Force Remote Phone audio through server X

Phone Administration Password X

Global SIP Connection Limit X

Paging Maximum Duration X

RTP DTMF Payload X

RTP DSCP Tag X

SIP DSCP Tag X

Disable Phone Creates via LAN Plug and Play X

Disable Phone Creates via Wan (Remote Phone) 
Plug and Play

X

Disable Assign User at Phone X

Disable PCP Proxy X

Click here to return to the “Install Checklist” .
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Chapter 36 Web Server

The Web server processes requests via HTTP 
or HTTPS. This chapter describes customizing 
the Web server for the business needs.

The Connect servers enable HTTPS on Allworx 
server web admin pages and My Allworx 
Manager pages. 

The Connect server default is HTTP disabled. 
The Allworx administrator can enable or disable 
HTTP but cannot disable HTTPS.

• Disabled HTTP (Connect servers only)

• Access to My Allworx Manager via secure HTTPS port: 443.

• Access to the Allworx Server Web Admin via the secure HTTPS port: 8443.

• Enabled HTTP

• Access to My Allworx Manager via the insecure HTTP port on all network interfaces, except the 
public network interface.

• Access to the Allworx Server Web Admin page via the insecure HTTP port on all network 
interfaces, except the public network interface. 

• The Connect servers do not enable insecure HTTP access on the public network interface.

The server generates a private key, public key, and self-signed SSL certificate to use with HTTPS:

• at first boot up.

• after formatting the server disk.

• after removing a user-installed self-signed certificate. 

To manage the web server:
1. Log in to the Allworx server admin page, navigate to Servers > Web. The Web Server page 

displays with the current values.

2.  Locate the Web Server section and click modify and update the settings: 

Connection Timeout (secs) Enter a value.

Maximum HTTP/HTTPS Sessions Enter a value.

Secure Web (HTTPS)

My Allworx Manager Secure Port (HTTPS)* Enter a value.

Web Administration Secure Port (HTTPS)* Enter a value.

Prerequisites

Access Permissions Allworx Server Administrator
Allworx System Administrator
Network Administrator role

Feature Key Required No

Servers •  Allworx 6x, 6x 12, 48x servers - 
HTTP

•  Connect servers - HTTP (if 
enabled) and HTTPS
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3. Click Update to save the changes or Cancel to disregard the request. Any saved changes 
require restarting the Allworx server.

To manage the Installed Certificate:
This applies only to the Connect servers and displays the current installed certificate information.

1. Log in to the Allworx server admin page, navigate to Servers > Web. The Web Server page 
displays with the current values.

2. Locate the Installed Certificate section and click the additional information arrow , if 
necessary. The SSL information displays.

3. Click: 

To install a user-provided SSL certificate:
1. Log in to the Allworx server admin page, navigate to Servers > Web. The Web Server page 

displays with the current values.

2. Locate the Certificate Installation section and click the additional information arrow , if 
necessary. 

3. Follow the steps on the web admin page to install a new certificate for Secure Web Access 
(HTTPS). Verify the certificate adheres to the formatting guidelines listed on the web admin 
page.

4. Click a link:

Insecure Web Access (HTTP) (Connect servers only)
Check the box to enable.

My Allworx Manager Port (HTTP)* Enter a value.

Web Administration Port (HTTP)* Enter a value.

* Feature is only available on the Connect servers.

import/export Navigation shortcut to Import/Export screen for the current SSL certificate and keys.

Reset Certificate Deletes the current certificate and the private key, and then create a new self-signed certificate and 
private key. Click Yes to proceed and No to disregard the request.

Show / Hide Displays or removes an example certificate, respectively.

import/export Navigation shortcut to import/export the certificates and keys.

Install Starts the certificate confirmation process.

Cancel Disregard the request.
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To create the Certificate Signing Request:
1. Log in to the Allworx server admin page, navigate to Servers > Web. The Web Server page 

displays with the current values.

2. Locate the Certificate Signing Request section and click the additional information arrow , if 
necessary. The Certificate Signing Request form displays.

3. Enter the information for the Certificate Signing Request into the fields provided.

4. Click Create CSR to proceed and Cancel to disregard the request.

Click here to return to the “Install Checklist” .
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Part 6  Reports

The Reports features support customizing the reports specific to the business requirements. Each 
chapter explains:

• necessary access permissions and feature keys.

• necessary equipment to perform the procedures.

• necessary procedures to setup and customize the Allworx server network.

The various Server pages on the server web admin site enable the Allworx administrator to access the 
following information:

• About

• Allworx View

• Auto Notification

• Call Details

• Configuration

• Live Calls

• Resource Summary

• System Events

• Users
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Chapter 37 About

The About page displays information about the 
Allworx system such as server model, software 
version, and last successful server backup.

To view the About page:
1. Log in to the Allworx server admin page, 

navigate to Reports > About. The page 
displays with the Allworx system 
information.

2. Click one of the following links:

show logged in administrators /
 hide logged in administrators

Displays or removes the administrators currently logged in to the Allworx 
system, respectively.

Open Source Licenses Displays the Open Source Licenses associated with the application. To return to 
the server web admin page, click the browser back button.

Click here to return to the “Install Checklist” .

Prerequisites

Access 
Permissions

Allworx Server Administrator
Allworx System Administrator
Phone Administrator Role
Network Administrator Role
Support Technician Role

Feature Key 
Required

No
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Chapter 38 Allworx View

The Allworx View application is a significantly 
enhanced version of the Call Detail Record 
(CDR) streaming feature, which gives dynamic, 
comprehensive usage reporting on the Allworx 
phone system The View application provides 
separate connections and interaction between 
the Allworx View application and the Allworx 
server and does not replace the current CDR 
streaming feature.

Additionally, the Allworx View ACD add-on application:

• offers real-time contact center and analysis to maximize agent productivity,

• ensures an optimal experience for customers, 

• customizable dashboards for supervisors and agents,

• displays the selected information using any popular web browser, and

• uses configurable alarms for supervisors and agents to recognize and react to high call volume 
situations to minimize abandoned calls and frustrated customers.

To change the port:
1. Log into the server admin page and navigate to Reports > Allworx View.

2. Locate the Allworx View Settings section, and click one of the following links: 

3. Click Update to save the changes.

Reset Allworx 
View port

•  Port Reset - shuts down any current connection from an Allworx View client, and then re-initializes 
the port. The Allworx View client re-connects without user intervention using the same 
authentication token as when it was previously connected. This is best used as a recovery step 
when there are connection problems.

•  Authentication Token Reset - (see Modify below) a security-related configuration change that 
disconnects an Allworx View application client, but with no port reset and requires user 
authentication for Allworx View to re-connect. This is best used when changing access permissions, 
such as removing a user with View administration permissions from the system.

Modify •  TCP/IP Port - Enter the TCP IP Port number in the field.
•  Reset Authentication Token - Check the box to enable.

Click here to return to the “Install Checklist” .

Prerequisites

Access Permissions Allworx Server Administrator
Allworx System Administrator
Phone Administrator Role
Network Administrator Role
Support Technician Role

Feature Key Required •  Allworx View CDR
•  Allworx View ACDR 
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Chapter 39 Auto Notification

The Auto Notification report supports configuring 
automatic email notifications for specified 
systems events to specific users.

To setup the Auto Notification:
Prior to performing this procedure, set up the 
email services. See “Email” on page 173 for 
more information.

1. Log into the server admin page and 
navigate to Reports > Auto Notification.

2. Locate the Auto Notification section, and click modify. Update the settings:

Auto Notification

Modify Updates the current settings. Check the Enable Notification checkbox, if not already checked and edit 
the settings, as required.

Click Update to save the changes or Cancel to disregard the request. 

Flush Pending 
Notifications

Clears any pending notifications.

Text Filtering - requires enabling in Auto Notification > Modify > Enable Log Text Filtering section.

add new text filter Enter a new text filter. Click Add to save the change or Cancel to disregard the request.

delete all Deletes all of the text filters. Click OK to remove the filters or Cancel to disregard the request.

Modify Change the text filter information. Click Update to save the change or Cancel to disregard the request.

Delete Delete the text filter information. Click OK to save the change or Cancel to disregard the request.

Email Addresses - requires enabling in Auto Notification > Modify > Enable Auto Notification.

add new email 
address

Enter a new email address. Click Add to save the change or Cancel to disregard the request.

delete all Delete all the email addresses. Click OK to remove the filters or Cancel to disregard the request.

Modify Change the email address. Click Update to save the change or Cancel to disregard the request

Delete Delete the email address. Click OK to delete the email address or Cancel to disregard the request.

Click here to return to the “Install Checklist” .

Prerequisites

Access Permissions Allworx Server Administrator
Allworx System Administrator
Phone Administrator Role
Network Administrator Role
Support Technician Role

Feature Key Required No

Enable Message 
Severity Filtering

Check the required filters:
•  Emergency (0)    • Critical (2)         • Warning (4)             • Info (6)
•  Alert (1)               • Error (3)            • Notice (5)                • Debut (7)

Enable Log Text 
Filtering

Check the box to enable and update the settings:
•  Maximum number of notifications per day - enter a number.
•  Timeout for sending notifications (min) - enter a number.
•  Maximum number of messages per notification - enter a number.
•  Email subject - Enter information.
•  Email header - Enter information.
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Chapter 40 Call Details

The Call Details report supports managing a Call 
Details Report from the server.

To change the Call Details Settings:
1. Log into the server admin page and 

navigate to Reports > Call Details.

2. Locate the Call Details Settings section 
and click modify. Update the settings:

Call Detail Settings

modify Change the current settings..

Click Update to save the changes or Cancel to disregard the request.

Completed Calls Detail Report

delete Removes specific calls from the report. Select:
•  Delete all calls
•  Delete calls made before - select the date from the drop-down list.
Click Delete to save the changes or Cancel to disregard the request.

Report Start 
Date

Enter a date in the field and select the number of days to include in the report from the drop-down list.

View Report Displays the report on the computer screen.

Export TSV 
Report

Exports the report to a Tab Separated Values format.

Export XML 
Report

Exports the report to an Extensible Markup Language format.

Click here to return to the “Install Checklist” .

Prerequisites

Access Permissions Allworx Server Administrator
Allworx System Administrator
Phone Administrator Role
Network Administrator Role
Support Technician Role

Feature Key Required No

Call Detail Storage Identify what to store. Select an option from the drop-down list.
•  Do not store calls
•  Store Completed Calls only
•  Store Live Calls only
•  Store Live and Completed Calls

Call Detail Streaming Identify what to stream. Select an option from the drop-down list.
•  Do not stream calls
•  Stream Completed Calls
•  Stream Completed Calls only
•  Stream Live Calls only
•  Stream Live and Completed Calls

Call Detail Streaming Port Enter the port number in the field.
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Chapter 41 Configuration

The Configuration report provides the Allworx 
server configuration information such as, but not 
limited to system settings, network settings, 
internal dial plans, phones, and users.

To manage the Configuration Report:
Click the Generate XLS Report button to create 
a configuration report. This report may take up to 
10 minutes to complete. 

To see the report, click View next to the Excel workbook file. The worksheet tabs at the bottom of the 
report provide specific configuration information.

Click here to return to the “Install Checklist” .

Prerequisites

Access Permissions Allworx Server Administrator
Allworx System Administrator
Support Technician role

Feature Key Required No
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Chapter 42 Digital Lines

The Digital Lines report displays the information 
specific to each digital line.

To manage the digital lines report:
1. Log in to the server admin page and 

navigate to the Reports > Digital Lines 
page. A window displays the information 
for each digital line.

2. Click one of the following options:

.

Clear 
Report

Clears the current information from 
the viewable report.

Refresh 
Report

Updates the current information on 
the report.

Click here to return to the “Install Checklist” .

Prerequisites

Access Permissions Allworx Server Administrator
Allworx System Administrator
Support Technician role
Network Administrator role

Feature Key Required No

Servers Allworx 48x and Connect

* Not all features on the Roles page are available to Phone 
Administrators. These features require Allworx Server 
Administrator or Allworx System Administrator permissions.
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Chapter 43 Live Calls

The Live Calls report displays the call 
information in a separate browser window.

To display Live Calls:
1. Log in to the server admin page and 

navigate to the Reports > Live Calls 
page. A separate window opens.

2. Do one of the following options:

3. Click the “X” on the browser window or tab to close the admin web window (not the Live Calls 
window). Do not log out of the admin web page before closing. 

To hide or show the Queued Calls or Active Calls, click hide or show, respectively.

Check the Auto Refresh checkbox.

Click the Refresh Now button. Requires clicking at least once every 30 minutes.

Click here to return to the “Install Checklist” .

Prerequisites

Access Permissions Allworx Server Administrator
Allworx System Administrator
Support Technician role

Feature Key Required No
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Chapter 44 Resource Summary

The Resource Summary report describes 
current Allworx server configurations, maximum 
admissible configurations, and current license 
usage counts. Additionally, the Resource 
Summary page supports viewing the 
compatibility of the current configuration with 
other server models.

To manage the Resource Summary report:
1. Log in to the server admin page and 

navigate to the Reports > Resource Summary page. The page displays the current Allworx 
server information.

2. (requires that the service PC has an Internet connection) Click check server compatibility to 
determine Allworx server data configuration compatibility with other Allworx server models. 

Checking the server compatibility is helpful if there is a need to replace the current Allworx 
server model with a different Allworx server model. 

3. Select a different Allworx server model from the drop-down list. 

A table displays with both the current server counts and the selected server model capabilities. 

Green Configuration is compatible.

Yellow Configuration is incompatible. Line item describes the issue and suggests a remedy to fix the incompatibility.

Click here to return to the “Install Checklist” .

Prerequisites

Access Permissions Allworx Server Administrator
Allworx System Administrator
Phone Administrator role
Network Administrator role
Support Technician role

Feature Key Required No
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Chapter 45 System Events

The System Events report displays system 
information (i.e., server type, MAC address, 
software version, etc.) and log information. 

To manage the System Event Severity 
filtering:
1. Log in to the server admin page and 

navigate to the Reports > System 
Events page. 

2. Click one of the following options:

show Severity Filter /
hide Severity Filter

Opens or closes the Event Severity Filtering section, respectively. Check the filter boxes to select 
the filters to display.
Click Apply Filter to save the changes or Reset Default Filter to use the factory default settings.

Download Downloads the system events to a file.

Click here to return to the “Install Checklist” .

Prerequisites

Access Permissions Allworx Server Administrator
Allworx System Administrator
Support Technician role

Feature Key Required No
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Chapter 46 Users

The Users report displays a list of all active 
users in the business directory including the 
associated extension, the user name, and the 
messages/space used as well as email and 
voicemail information.

To manage the Users page:
1. Log in to the server admin page and 

navigate to the Reports > Users page. 

2. Click one of the following options:

<user> The Phone System > Users > Modify page opens. See “User Settings” on page 133 for more 
information.

delete messages Permanently deletes messages from the Allworx system. Recovering deleted messages requires 
an OfficeSafe backup. Select the types of messages to delete for the user:
•  Delete all emails
•  Delete all read emails
•  Keep all emails
•  Delete all voicemails
•  Delete all saved voicemails
•  Keep all voicemails
Click Delete to remove the messages or Cancel to disregard the request.
NOTE: To recover deleted messages, perform a System Report using an OfficeSafe Backup. See 
“To restore data using the Allworx OfficeSafe application:” on page 232 for more information.

Click here to return to the “Install Checklist” .

Prerequisites

Access Permissions Allworx Server Administrator
Allworx System Administrator
Network Administrator role

Feature Key Required No
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Part 7  Maintenance

The Maintenance features support customizing the performing routine maintenance on the Allworx 
server. Each chapter explains:

• necessary access permissions and feature keys.

• necessary equipment to perform the procedures.

• necessary procedures to setup and customize the Allworx server network.

The various Maintenance pages on the server web admin site enable the Allworx administrator to:

• Backup

• Custom Recordings

• feature Keys

• Import/Export

• Restart

• Time

• Tools

• Update



Section 7 - Maintenance

Page 210 1 866 ALLWORX * 1 585 421 3850
www.allworx.com

Revised: 03/25/2016



Allworx System Administrator Guide Version 8.1

1-866-ALLWORX * 585-421-3850 Page 211
www.allworx.com
Revised: 03/25/2016

Chapter 47 Backup

Backup supports restoring entire Allworx server 
disk data, not a specific file, to a PC. It is critical 
to configure the Allworx server to initiate 
backups frequently, including daily backups, 
before system software updates, and before 
configuration changes. 

Assess the data loss requirements in the event a 
restore from a server backup is necessary. In the 
event of a server failure, restore the system from 
the backup. See the OfficeSafe User Guide to perform a restore, available on the Allworx Partner 
Portal (www.allworxportal.com).

To perform an Allworx Server Backup
The OfficeSafe application Current Status and Activity Log displays the progress of the backup 
process. When the backup is complete, the Current Status state is Idle and the Activity Log displays 
“Saving backup completed successfully.”

1. Start the OfficeSafe application on the backup PC, and enter the network path from the server to 
the PC.

2. Log in to the Allworx server admin page, navigate to Maintenance > Backup. Click one of the 
following options:

Modify Change the backup settings. 

Click Update to save the changes or Cancel to disregard the request. Backups begin at the Start Time 
on each day based on the Frequency setting.

Backup Now Starts the backup process immediately. See the Allworx OfficeSafe User Guide for detailed set up 
information.

Prerequisites

Access Permissions Allworx Server Administrator
Allworx System Administrator
Phone Administrator Role
Network Administrator Role
Support Technician Role

Feature Key Required No

Start Time Specify the time of day to begin the backup using the drop-down lists.

IP Address Enter the same IP Address as the PC that is running OfficeSafe. In OfficeSafe, 
the value is available at: Tools > Options > Network.

TCP/IP Port Enter the same TCP/IP Port as the PC that is running OfficeSafe. In OfficeSafe, 
the value is available at: Tools > Options > Network.

Frequency Select an available option from the drop-down list.

Mode Select an option from the drop-down list.
•  Full - includes all servers in every backup.
•  Incremental - Includes only the changes to the server data since the most 

recent Full backup to merge with previous backup data. This backup mode is 
helpful to speed the duration of each backup by reducing the amount of 
transmitted data that to the backup PC during every backup.

Last Successful 
Backup

Displays the date of the last successful backup.

www.allworxportal.com
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To transfer the settings from one server to another server, see “Import/Export” on page 225 for more 
information.

To perform an Allworx server restore using the OfficeSafe application, see “To restore data using the 
Allworx OfficeSafe application:” on page 232 for more information.

Click here to return to the “Install Checklist” .
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Chapter 48 Custom Recordings

Custom Recordings supports easy export/import 
of greetings and messages without the use of 
FTP. Allworx administrators can select specific 
recording categories on the Allworx server to 
export to a .ZIP file automatically for use on other 
servers or to archive. 

The Allworx server supports the following 
recording types:

• Auto Attendant - one custom message and up to 9 greetings per Auto Attendant.

• Call Queue - one custom message and one greeting.

• Message Center - one name recording and up to 9 greeting/announcements for each user.

• Music On Hold - up to 30 recordings.

Allworx administrators can select single or multiple recording files at once to import onto the current 
Allworx server by selecting files with a drag-and-drop or browse/select capability. After exporting the 
recordings, the Allworx administrator can import to the preferred language. 

To export the Custom Recordings:
1. Log in to the Allworx server admin page, and navigate to Maintenance > Custom Recordings. 

2. Locate the Custom Recordings - File Export section, and click the additional information 
arrow , if necessary. Update the settings:

3. Click Export to export the selected recordings to a ZIP file. 

4. Click one of the following options:

File Naming Conventions A short cut to the File Naming Conventions described lower on the page.

Select Recordings Check the box to select which recordings to export.
•  Auto Attendants
•  Call Queues
•  User Names and Greetings
•  Music on Hold

Select type Select an available option from the drop-down list
•  Primary Language custom recordings
•  Secondary Language custom recordings.

Download Downloads the ZIP file to the PC.

Delete Removes any previous ZIP files. The settings to export redisplay on the page.

Prerequisites

Access Permissions Allworx Server Administrator
Allworx System Administrator
Phone Administrator Role
Support Technician Role

Feature Key Required No
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To import the Custom Recordings:

Files must be Telephony, raw, mu-law (u-law), mono, 8-bits per sample, 8KHz sample rate. The 
following procedure uses the sound editing application Audacity  (available at 
http://audacity.sourceforge.net); conversion of other formats is similar. 

1. Verify the file to import is a .snd file. If the file is not a .snd file:

a. Open an audio file (example: MP3 file) in Audacity. Click Tracks > Stereo Track to 
Mono, and then change the Project Rate (Hz) value to 8000.

b. Click File > Export Audio > Save as type. Select Other uncompressed files from the 
drop-down list. 

c. Enter a file name using the specific file name format and an .snd extension.

d. Select Options and update the settings to:

e. Click the OK > Save. The Edit Metadata dialog box opens. Leave all fields blank, and 
click OK. 

2. Log in to the Allworx server admin page, and navigate to Maintenance > Custom Recordings. 

Note: If the system is using the Dual Language Support feature, click Load for the language in which the messages and 
greetings are recorded. See “Manage the Language Settings” on page 88 for more information.

Auto Attendant Example: aa#x.snd
•  # - Replace with the Auto Attendant number (6x12, Connect 320, and Connect 324 

servers support Auto Attendant custom recordings 1 through 9; 6x, Connect 530, and 
Connect 536 servers support Auto Attendant custom recordings 1 through 16; 48x and 
Connect 731 servers support Auto Attendant custom recordings 1 through 32).

•  x - Replace with greeting number (0 through 9 - Use '0' for the Open greeting, '1' closed 
greeting) or “c” for Custom Message.

File name: aa20.snd = auto attendant 2/open greeting.

Call Queue Example: cq#x.snd
•  # - Replace with a Call Queue number 0 through 9.
•  x - Replace with “g” for greeting or “s” for status message.
File name: cq3s.snd = call queue/3/status message.

Music On Hold Example: moh_n_m.snd
•  'n' is a number between 1 and 30. This is a unique number among the Music On Hold 

files on the system. If importing a Music On Hold file that duplicates the number ‘n’ of a 
file that is already on the system, the system replaces the existing file.

•  'm' is a user defined string that uniquely identifies the file. Valid characters include 
('A'-'Z'), ('a'-'z'), ('0'-'9') and underscore.

File name: moh_1_sales.snd = music on hold/1/sales department file.

Header RAW (header-less)

Ending U-LAW

http://audacity.sourceforge.net
http://audacity.sourceforge.net
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3. Locate the Custom Recordings - File Import section, and click the additional information 
arrow , if necessary. To see the file name requirements for the recordings, click File Naming 
Conventions.

4. Drag and drop an audio file into the field provided or click Choose File, navigate to the file 
location, and click OK.

5. Click one of the following options:

6. Locate the Select type to install: and select one of the options from the drop-down list:

7. Click one of the following options:

Upload Identifies the file to install into the Allworx system.

Cancel Disregards the request to upload the file.

Primary Language custom recordings Imports the file as the Primary Language.

Secondary Language custom recordings Imports the file as the Secondary Language.

Install Imports the selected file.

Delete Removes all previously uploaded but uninstalled recordings.

Click here to return to the “Install Checklist” .
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Chapter 49 Feature Keys

Feature Keys support access to advanced 
server features available as a separate purchase 
from the base feature set for Allworx servers. 
Each issued feature key is specific to each 
Allworx server.

Note: Feature keys activate features only on the 
Allworx server for which they are generated. 
Therefore, one system cannot use feature 
keys generated for a different system.

Feature Key Description

Allworx View CDR* Provides dynamic, comprehensive usage reporting on the Allworx phone system. This application uses complete 
and accurate data of the Allworx phone system for users to make data-driven decisions with an easy-to-use web 
browser-based user interface. Required for each Allworx server in a multi-site network.

Allworx View ACDR* An add-on feature to the Allworx View CDR feature providing customizable dashboards for supervisors and 
agents, and displays the information - using any popular web browser. Using configurable alarms, supervisors 
and agents can recognize and react to high call volume situations to minimize abandoned calls and frustrated 
customers. Requires the ACD and View CDR keys. Required for each Allworx server in a multi-site network.

Automatic Call 
Distribution

Directs calls in a queue to agents using a variety of call distribution algorithms without requiring any additional 
software. This key also enables the method described for the Call Queuing feature key, therefore, servers with 
an ACD feature key do not require a Call Queuing feature key.
•  If installing the Automatic Call Distribution feature key, the Call Queuing feature key is not required. 
•  The Automatic Call Distribution feature is not available for Allworx 6x12 or Connect 300 series servers.
•  For details on Call Queuing and Automatic Call Distribution, “Call Queues/ACD” on page 25

Call Queuing Provides the ability to direct inbound calls into Ring All queues. Rings all phones logged into the queue. This 
option does not require any additional software. The ACD key enables Call Queuing, therefore, servers with an 
ACD feature key do not require a Call Queuing feature key.

Conference Center Enables Conference Center feature, and offers password-restricted access for attendees. This option does not 
require any additional software.

Dual Language 
Support

Provides the capability of a second language for all audio and phone screen prompts. Language Packs 
containing audio prompts in languages other than US English are available for download from the Allworx 
Partner Portal at www.allworxportal.com.

Extended Warranty Extend the expiration of the Allworx server hardware warranty. 

Prerequisites

Access 
Permissions

Allworx Server Administrator
Allworx System Administrator
Phone Administrator Role
Network Administrator Role
Support Technician Role

Feature Key 
Required

No

https://allworxportal.com/
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Generic SIP 
Handsets

Create new Generic SIP handsets on the system without requiring any additional software.
•  Generic SIP handsets existing in the system prior to the 7.5 upgrade operate without the purchase of a feature 

key package.
•  Order Feature key licenses in increments of 1, 5, and 10, and the feature counts are additive.
•  Installing multiple keys for the same or different feature count adds licenses to the server. 
•  Server feature key limits:

Interact Professional Enables users to control a handset with convenient access to call history and contacts from the Allworx directory 

and accesses personal directory contacts from the user’s Microsoft® Outlook® application. 
•  Integrates with CRM applications to perform lookups based on incoming Caller ID. 
•  Order Feature key licenses in increments of 1, 5, and 10; the feature counts are additive. Installing multiple 

keys for any feature count adds licenses to the server. Each user requires an Interact license.
•  Server feature key limits:

Interact Sync Activates communication between the Interact Professional application and the Microsoft Office applications 
running on a PC. One key enables all Interact users. See the Interact Professional User Guide for more 
information.

Mobile VM
(formerly known as 
Mobile Link)

Activates the mobile voicemail capability of Reach without configuring the Reach application on the mobile 
device as a handset.

Multi-Site Branch •  Enables sites to join a network of sites but not as the controller site. 
•  Sites without a Multi-Site Primary key are limited to DSS/BLF for a maximum of 10 handsets from other sites.
•  This option does not require any additional software. 

Multi-Site Primary Enables a server to be the Controller in a multi-site network.
•  Controls requesting other sites to join a network of sites (up to 99 Allworx servers with up to 1000 users and up 

to 1000 system extensions across all sites. The total number of Multi-Site Users and Multi-Site System 
Extensions varies with the maximum users licensed on each Allworx server). 

•  At least one site in the network must have a Multi-Site Primary key. More than one site can have a primary key. 
•  The Multi-Site Primary feature is not available for Allworx 6x12 servers.
•  This option does not require any additional software. 

Multi-Site Upgrade •  Enables changing the Multi-Site Branch feature key to a Multi-Site Primary feature key.
•  When upgrading the Multi-Site Branch feature key to a Multi-Site Primary feature key, the Feature Key list 

displays Multi-Site Primary - not Multi-Site Upgrade.
•  This option does not require any additional software. 

Feature Key Description

Connect servers

License Limit 6x12 6x 48x 320 324 530 536 731

Built-in Licenses 2 6 12 4 4 6 6 12

Purchase Limit 0 54 238 16 16 44 44 168

Total Server Limit 2 60 250 20 20 50 50 180

Connect servers

License Limit 6x12 6x 48x 320 324 530 536 731

Built-in Licenses 1 1 1 1 1 1 1 1

Purchase Limit 12 60 250 20 20 50 50 180

Total Server Limit 13 61 251 21 21 51 51 181
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Reach •  Enables users to send or receive business phone calls from an iOS or Android device. The server provides a 
single instance of the Reach application without purchasing a feature key.

•  Enables working from remote locations and continue to send, receive, hold, transfer, and park calls; see the 
handset’s call history and business/personal contacts; and listen, reply, forward, or create voicemail. 

•  Enables managing voicemail options without creating a Reach handset.
•  Order Feature key licenses in increments of 1, 5, and 10; the feature counts are additive. Installing multiple 

keys for any feature count adds licenses to the server. Each Reach device requires a Reach license.
•  Enables configuring users to claim licenses. 
•  Server feature key limits:

Reach Link Keep Reach calls connected as the mobile device changes networks. See “Reach Link” on page 177 for more 
information.
NOTE: In a multi-site network configuration: Reach Link functionality is limited to users and handsets configured 
on an Allworx server with the Reach Link feature key installed.

Software Upgrade 
License

Enable system software updates. Without this key, only patch updates to the currently loaded release are 
available.

T1 License #1 Activates the T1-A port. T1 License #1 (Allworx 48x and Connect 731 servers only). This option does not require 
any additional software. 

T1 License #2 Activates the T1-B port. This does not include the license for the first T1. Install T1 license #1, and then install 
the T1 License #2 to activate the T1-B port (Allworx 48x server only). This option does not require any additional 
software. 

User Expansion 
License

Expands the maximum number of users on Allworx 6x, 48x servers, and Connect servers. 
•  The expansion does not require downloading any additional software. 
•  The User Expansion feature is not available for Allworx 6x12 servers.

Feature Key Description

Connect servers

License Limit 6x12 6x 48x 320 324 530 536 731

Built-in Licenses 1 1 1 1 1 1 1 1

Purchase Limit 12 60 250 20 20 50 50 180

Total Server Limit 13 61 251 21 21 51 51 181

Connect servers

Key 6x 48x 320 324 530 536 731

20 Users X X

48 Users

50Users X X X

60 Users X

100 Users X X

150 Users X X

180 Users X

200 Users X

250 Users X
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To install Feature Keys:
1. Log in to the Allworx server admin page, and navigate to Maintenance > Feature Keys. 

2. Click one of the following options: 

49.1 Manage Reach Handset Licenses
Users must install the Reach application on the iOS and/or Android devices to provide soft phone 
capability. See the Allworx Reach User’s Guide for information on installing the Reach application. 

Each Reach handset requires a license for soft phone capability. The Allworx server includes one 
Reach license; to add more Reach handsets, install additional Reach feature keys (available in one, 
five or 10 license increments). To enable larger numbers of Reach handsets, install multiple feature 
keys of the same or different license counts. To allocate a Reach license, do one of the following:

• Reserve licenses for specific users by manually configuring the Reach handsets.

• Authorize users to claim licenses on a first come, first served basis using Plug and Play.

To reserve an Reach license for a specific user:
1. Log in to the Allworx server admin page.

2. (If necessary) Install the Reach feature key. See “Feature Keys” on page 217 .

3. Navigate to Maintenance > Feature Keys, and click Allworx Reach. 

4. Click add new. If the link is unavailable, purchase more licenses. Update the following settings: 

Virtual Private 
Network (VPN)

Enables multiple simultaneous remote access sessions. 
•  This key is not required for opening a single-user remote diagnostic VPN. 
•  This option does not require any additional software. 
•  The VPN feature is not available for Allworx 6x12 or Allworx Connect servers.

* Required for each Allworx server (both controller and branch servers) in a multi-site network for comprehensive call data reporting to 
Allworx View. It is not necessary to install the feature keys on Allworx servers that do not provide call reporting data. The installation of 
Allworx View keys enable reporting the call data only from a single Allworx server to Allworx View. Allworx View will only report the call 
data from Allworx servers with the Allworx View CDR and Allworx View ACDR feature keys installed. 

Install Automatically retrieves new Feature Keys from the Allworx Partner Portal. 

Enter New Feature Key Enter the provided Feature Key code in the field provided. Click Submit to retrieve the 
new features.

Allworx Reach Handset

Owner Select an available user from the drop-down list.

Feature Key Description
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5. Click the Add button to save the changes or Cancel to disregard the request.

6. Click one of the links in the table below to email the setup information to the user.

To authorize users to claim licenses:
It is possible to over-allocate the number of installed licenses when authorizing users to claim licenses.

• If users have claimed all licenses, the server blocks attempts to install Reach handsets. 

• If the Allworx administrator creates a Reach handset and assigns an owner before using all the 
licenses, the owner keeps the installed license and can register the Reach handset.

See “User Template Settings” on page 136 to adjust the number of Reach activations a user may 
claim.

To manage Reach licenses:
1. Log in to the Allworx server admin page.

2. (If necessary) Install the Reach feature key. See “Feature Keys” on page 217 for more 
information.

3. Navigate to Maintenance > Feature Keys, and click Allworx Reach. The Reach page displays.

4. Click one of the following options: 

Extension Specify the extension for the handset. If selecting an owner other than admin, the system 
automatically adds the handset to the In Office call route of the owner.
If selecting an Extension, the system creates an extension with a call route to ring this handset. 
This is typically the case of using a conference room or lab phone that does not require an owner.

Caller ID Number Select an option from the drop-down list.

Caller ID Name Automatically populates from Owner selection. Update as necessary.

Description Automatically populates from Owner selection. Update as necessary.

Handset Features

Hold Music Selection Select an option from the drop-down list. See “Music On Hold” on page 95 for more information.

Can Place Calls Check the box to enable.

Can Receive Calls Check the box to enable.

setup link for all users Opens a new page with information to connect the device running Reach to the server. This link 
does not contain user-specific information such as username or password.

setup link for <user> Opens a new page with user-specific information to connect the device running Reach to the 
server.

setup link for 
all users

Opens a new page with information to connect the device running Reach to the server. This link does not 
contain user-specific information such as username or password.

setup link Opens a new page with information specific to the user to connect the device running Reach to the server.
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5. Create an email to the Reach user and attach the setup link and the Allworx Reach User’s 
Guide. It is available on the Allworx Partner Portal (www.allworxportal.com) and on the Allworx 
Reach Installation web page (get.allworx.com/reach). Send the email to the user.

49.2 Manage Generic SIP Handset Licenses

To manage the Generic SIP Handset licenses:
1. Log in to the Allworx server admin page.

2. (If necessary) Install the Generic SIP Handset feature key. See “Feature Keys” on page 217 for 
more information.

3. Navigate to Maintenance > Feature Keys > Generic SIP Handset >

49.3 Manage the Interact Professional Licenses
The Interact application enables users to control a handset with convenient access to call history and 
contacts from the Allworx directory. The Interact application also accesses personal directory contacts 
from a user’s Microsoft® Outlook® application.

• Interact - a free edition of the application is available to all Allworx users and enables users to 
Answer, Ignore, End, or place calls on Hold.

• Interact Professional - a licensed edition of the application that offers all of the Interact edition 
features as well as Transfer, Park, Conference, and settings features.

Both Interact editions provide a user-centric view of the Allworx business directory. Therefore, a user 
places a call to another directory contact with multiple handsets without selecting an individual 
handset. The application works with any Allworx handset and does not disconnect the call. In either 
edition, the Interact application does not provide voicemail support such as voicemail indicators or the 
ability to retrieve a voicemail message.

The Allworx administrator manages which users have access to the licensed features of the Interact 
Professional application. Users that see the Interact free screen pop-up feature and would like to 
upgrade to Interact Professional should contact the Allworx administrator to reserve a license or make 
the user eligible to obtain a license from the server. If the Allworx administrator installs the Interact 
Professional Feature Key on the server, all users can use the free features of the Interact application. 
Users that upgrade from the Interact edition to the Interact Professional edition see the licensing 

View Display handset information about a specific user.

Manage Enable or disable the Allworx Reach license, the Reach Link for handset, or both by checking or unchecking 
the box, respectively.

Delete Remove the Reach handset from the system and the associated Call Appearances. Click Delete to confirm.

Create The Add Generic SIP Handset page displays. See “To add a handset:” on page 63 for more information.

Delete Removes the user from the handset. Click Delete to save the change or Cancel to disregard the request.

https://allworxportal.com/
get.allworx.com/reach
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changes take effect on the next logout/login in the application.

Each Interact application requires a license for soft phone capability. The Allworx server includes one 
Interact Professional license. To add more Interact Professional licenses requires purchasing and 
installing of additional Interact feature keys. The Interact feature keys are available in increments one, 
five, or 10 licenses. To enable larger numbers of Interact licenses, install multiple feature keys of the 
same or different license counts.

To reserve an Interact Professional license:
1. Log in to the Allworx server admin page.

2. (If necessary) Install the Interact Professional feature key. See “Feature Keys” on page 217 for 
more information.

3. Navigate to Maintenance > Feature Keys, and click Allworx Interact Professional. The 
Interact Professional page displays.

4. Click create to assign an owner a license select a user from the drop-down list. Enter a 
description, if necessary.

5. Click the Add button to reserve a license or Cancel to disregard the request.

To manage Interact Professional licenses:
1. Log in to the Allworx server admin page, navigate to Maintenance > Feature Keys, and click 

Allworx Interact Professional. The Interact Professional page displays.

2. Click one of the following links:

To enable users to claim a license:
1. Install the Interact Professional feature key. See “Feature Keys” on page 217. for more 

information.

2. See “To modify or delete existing users:”  and refer to “Feature Eligibility” on page 137 for more 
information.

setup link for 
all users

Opens a new page with information to connect Interact to the server. This link does not contain user-specific 
information such as username or password.

Modify Enables changing the license assignment. Update the settings and click Modify to save the changes or 
Cancel to disregard the request.

Delete Removes the Interact communication from the server. Click Delete to confirm.

Disable / 
Enable

Prevents or permits any further communication with the Allworx Server. The link toggles between Disable 
and Enable.

Click here to return to the “Install Checklist” .
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Chapter 50 Import/Export

Import/Export eases the task of upgrading a site 
from one Allworx server model to another model. 
Import/Export is not a substitute for using Allworx 
OfficeSafe to backup the server.

Important Notes
• When importing the settings, the port 

numbers assigned to native CO lines and 
analog handsets settings are available.

• When importing an Allworx Px 6/2 Port 
Expander, the Import includes all configured CO lines and analog handsets from the export. Do 
not modify the port assignments. If the Allworx server does not support CO lines, the Analog CO 
lines display in the Import file as a conflict.

• DID blocks, routes plans, and digital lines do not display on the Import Configuration screen. 
The system imports these settings, if included on the export.

• The export does not include: Digital line fields, PPP Username, PPP Password, and PPP MTU.

• If the current system is not “clean” and has conflicts with the imported configuration settings, 
then the system resolves conflicts for the import settings:

• The system appends digits to user login names and incremented, starting at 01, as 
needed (e.g. jAdams will become jAdams01).

• Extensions change to the lowest available extension.

• The Allworx server does not import phones with conflicting MAC addresses and removes all 
references (e.g. call routing and BLF PFK assignments).

• The Allworx server does not import analog phones with unavailable port and removes all 
references (e.g. call routing and BLF PFK assignments).

• The Allworx server does not save SIP handsets and SIP gateway station numbers during an 
import. If changing station numbers for generic SIP phones or SIP gateways, setup the new 
station number on each device.

• On multi-site configurations, the Export does not include references to extensions, users or 
outside lines at remote sites.

• Imported extensions/users are limited to the total number available in the imported server. The 
order in the export file determines the available extensions/users. If exceeding the imported 
server extensions/user limit, the server disables and does not import the remaining extensions/
users.

• Do not modify the XML export file.

Prerequisites

Access Permissions Allworx Server Administrator
Allworx System Administrator
Phone Administrator Role
Network Administrator Role
Support Technician Role

Feature Key Required No
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To manage the Import / Export: 
An export includes all configurable parameters for:

To manage importing or exporting the configuration settings:
1. Log in to the Allworx server admin page and navigate to Maintenance > Import / Export.

2. Click one of the following links:

Phone System Settings Outside Lines Network Settings

•  Users •  CO Lines •  Configurations

•  User Templates •  Digital Lines •  Digital Line Configurations

•  System Extensions •  SIP Gateways •  SSL Certificates

•  Handsets •  SIP Proxies

•  Handset Preference Groups •  DID Blocks and Routing

•  Schedules

•  Allworx Port Expander (including all attached analog phones 
and CO lines)

VoIP Server Settings SIP Proxy Settings Dial Plan Settings

•  All •  All •  Internal Dial Plan

•  External Dial Plan

•  Automatic route selection for 
external dial plan

•  Dialing Privileges Groups

•  Non-default Service Groups

Export Configuration 1.  Check the box for the available configurations to export. To select all the available options, 
click the checkbox next to Configuration Type.

2.  Click Export.
Note: For Connect Servers only: Selecting the SSL Keys and Certificates requires entering a 
Key Encryption password in the field provided. 
After exporting the configuration, the following options are available: 

View Displays the XML file in a separate browser window.
To save the XML file:
1.  Right-click and select Save Link As... .
2.  Browse to the correct file location and enter a description in the File 

name: field.
3.  Click Save to keep the file or Cancel to disregard the request.
4.  Verify the server receiving the imported configuration settings has 

none of the above configurations added prior to import. Update the 
internal dial plan and extension length to match the configuration 
being imported before the doing import.

Delete Removes the configuration file from the server. 
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Import Configuration

Choose File Select the configuration file to import onto the server. Use the browser to navigate to the file 
location and select the file. Click Open to import the file or Cancel to disregard the request.

Load Prepares the selected configuration file to import. Then select Process to finish the import 
configuration process or Cancel to stop the import configuration process.

Click here to return to the “Install Checklist” .
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Chapter 51 Registration

Registration is comprised of two separate 
processes - Registration and Activation - of the 
Allworx server.

Registration
Register the Connect server within the Allworx 
System Software. Upon completing the online 
registration, the Registration feature:

• generates the Site ID.

• generates the Connect server Activation Code.

• keeps a service history of each Connect server.

After registering the Connect server, the following functionality is available:

• configuring the server,.

• performing software upgrades.

• testing the Allworx system. NOTE:  the Allworx system disconnects all phone calls after a few 
seconds.

Activation
Activate the Connect server software within the Allworx System Software using the 
registration-generated Activation Code. 

After activating the Connect server, the following functionality is available:

• viewing the registration information.

• placing and receiving phone calls.

• starting the warranty period of any warranties and software upgrade keys.

• tracking the server history of Allworx sites by the Allworx Support team.

To register the Connect server:

1. Log in to the Allworx server admin page and navigate to Maintenance > Registration.

2. Click Register. A new web page for the Allworx Partner Portal opens.

3. Log in to the Allworx Partner Portal with the Allworx assigned username and password.

Note: This procedure requires Allworx Partner Portal permissions.

Prerequisites

Alternate Access 
Permissions

Allworx Server Administrator
Allworx System Administrator
Phone Administrator Role
Network Administrator Role
Support Technician Role

Feature Key Required No
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4. Click Server Management located in the left panel.

5. Click Add/Register Server. The Add/Register page opens with the server serial number 
entered in the field.

6. Click Submit.The registration form displays.

7. Fill in the registration form fields. The System Name, Street Address 2, and Additional Info 
fields are optional. 

Providing the System Name and Additional Info fields enables:  

8. Click Register. An automatically generated email confirmation that includes the Activation 
Code goes to the email address of record to the Portal user account.

9. Write down the displayed Activation Code, if using manual activation.

To activate the Connect server:
1. Connect the server following the specific server installation instructions. 

See www.allworxportal.com for the correct installation guide.

2. Log in to the Allworx server web admin page with the Allworx assigned username and 
password. The Maintenance > Registration page displays.

3. Select one of the following options:

The page displays “Server is Activated” and is ready to use.

To see updated server information, click Refresh.

System Name Displays in the Server Management dashboard on the portal. Use this description as a nickname 
for the account, location, or machine. 

Additional info Any notes to view later in the Server Management dashboard on the portal.

Activate Automatically retrieves the Activation Code from the portal via the Internet.

Enter Activation Code Manually activates the Connect server. Enter the Activation Code from “To register the Connect 
server:” on page 229, step 9 in the field provided and click Submit.

Click here to return to the “Install Checklist” .

http://www.allworx.com/
www.allworxportal.com
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Chapter 52 Restart / Shutdown

Restart / Shutdown reboots the Allworx server 
and phones for settings to take effect or powers 
off the Allworx server from the web admin page 
and ends all active calls.

52.1 Restart the Allworx 
Server and/or 
Allworx Phones

To manage the Allworx server restart:
1. Log in to the Allworx server admin page and navigate to Maintenance > Restart.

2. Click one of the following links:

Restart

Restart or Shutdown 
the Allworx Server

Check the box to view the Allworx server restart options:

Restart Allworx Phones Check the box to initiate a reboot of the Allworx phones connected to server.
Check the Automatically accept phone software update to force the phones to automatically 
confirm updates without intervention.

Restart Now Begins the restart process immediately.

Restart Later... Schedule a time to reboot the server. Enter a start date and time in the provided fields. Click 
Schedule Restart to save the change or Cancel to disregard the request. If the Allworx 
administrator restarts the server before a scheduled shutdown, the Allworx system cancels the 
pending shutdown. 

Logged in Administrators
Displays the users currently logged in with administrative permissions.

Prerequisites

Access Permissions Allworx Server Administrator
Allworx System Administrator
Phone Administrator Role
Network Administrator Role
Support Technician Role

Feature Key Required No

Normal restart Reboots the server with the current settings.

Restart with factory 
defaults restored

Reboots the server and returns the server settings to the original factory 
default settings.

Enter Migration 
Mode after restart

Reboots the server for use with the Allworx Migrate tool.

Enter Safe Mode 
after restart

Format the disk or restoring an OfficeSafe backup. To perform a Restore 
with the Allworx OfficeSafe application, see “To restore data using the 
Allworx OfficeSafe application:” on page 232.

Shutdown and 
Power Off

Shutdown and power off the Allworx server from the web admin page. 
•  Shutdown Now - Immediately shutdown and power off the Allworx 

server.
•  Shutdown Later - Schedule a time in the future to shutdown and power 

off the Allworx server. (the Allworx administrator can cancel the scheduled 
shutdown). If the Allworx administrator restarts the server before a 
scheduled shutdown, the Allworx system cancels the pending shutdown. 
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52.2 Perform a Restore using Allworx OfficeSafe 
See the Allworx OfficeSafe User Guide for detailed restore information. Alternatively, use the Allworx 
Migrate Tool to transfer the settings from one Allworx server to another Allworx server. See the 
Allworx Migration Tool Administrator’s Guide for more details.

To restore data using the Allworx OfficeSafe application:
1. View customers: perform a backup of the View database prior to performing the restore (see 

the Allworx View Users Guide for more information).

2. Unplug all the network cables going to the server and only plug in the backup PC.

3. Log in to the Allworx server admin page, navigate to Maintenance > Restart. Restart the 
Allworx server into Safe Mode by using one of the following options:

4. Start the OfficeSafe application on the OfficeSafe PC. 

5. Connect the OfficeSafe PC to the Allworx server.

6. Navigate to the web server admin page > Safe Mode screen > Restore and enter the IP 
address of the OfficeSafe PC. 

7. Verify the PC has an IP address on the 192.168.2.x network. It may be necessary to release 
and renew the IP address on the PC to get an address from the server.

a. Click Start and type cmd in the Search field. A command window opens.

b. Type the following to clear the PC current IP settings:

c. Press enter to clear the PC current IP settings.

Web administration Page 1.  Log in to the Allworx server admin page and navigate to Maintenance > Restart.
2.  Check the box for Restart Allworx Server.
3.  Select Enter Safe Mode after restart.
4.  Click Restart Now. A warning banner displays. Click OK. The Allworx server powers 

down and then powers back up in Safe Mode. Once the system powers up into Safe 
Mode, access the Safe Mode web page.

Front Panel of the Allworx Server The method used to force entry into Safe Mode via the Allworx server front panel varies 
by product model. Consult the specific product model Allworx server Installation guide for 
more details.

Connect servers Plug into the ETH0 port.

6x12 server
6x server
48X server

Plug into the LAN port.

ipconfig /release 
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d. Type the following to obtain a new IP Address:

e. Press enter.

8. Click Restore from OfficeSafe.

9. Click Accept on the Confirm Restore Request dialog box to begin the restore. Depending on the 
size of the backup data (and the performance of the network and OfficeSafe PC), it may take 
several minutes or over an hour to restore the backup, if there are several gigabytes of data to 
recover. A “Restore was successful” message displays in the Status pane on the Safe Mode 
page when the operation completes.

10. Click Reboot in Normal Mode and select Reboot. 

After the Allworx server restarts:

• reconnect the network cables, 
• log in to the Allworx server, and
• verify that the data restored successfully. 

ipconfig /renew

Caution: Do NOT select Reboot the Allworx server in Normal Mode with Factory Defaults restored. This loses the restored 
settings during the reboot. If this happens, start the entire restore operation over again.

Click here to return to the “Install Checklist” .
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Chapter 53 Time

Time enables adjusting the time and date on the 
Allworx server automatically or manually. 

To set the time:
1. Log in to the Allworx server admin page, 

and navigate to Maintenance > Time.

2. Click modify in the Action column. The 
Time page displays.

3. Update the settings:

Use NTP To set time automatically
Preferred setting, if the Allworx server has Internet access. Check the box to enable. 

NTP Server Specify an SNTP-server IP address or a domain name. 

Poll Period Specify the number of minutes between polls.

Set Time Manually Specify the time in hours, minutes, seconds, and then the date.

Time Zone Select the correct time zone from the drop-down list. Check the Automatically adjust clock for 
Daylight Saving Time box to enable the system to update the time automatically.

Set Time Saves the current changes.

Get Time Updates the clock to the current time when using an SNTP server.

Cancel Disregards the changes.

Click here to return to the “Install Checklist” .

Prerequisites

Access Permissions Allworx Server Administrator
Allworx System Administrator
Phone Administrator Role
Network Administrator Role
Support Technician Role

Feature Key Required No
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Chapter 54 Tools

Tools is a set of various features to supports 
troubleshooting server communication 
problems. 

54.1 Network Diagnostics
1. Log in to the Allworx server admin page, 

and navigate to Maintenance > Tools.

2. Locate the Network Diagnostics section, 
and click the additional information arrow , if necessary.

3. Update the settings:

54.2 Syslog - System Events
1. Log in to the Allworx server admin page, and navigate to Maintenance > Tools.

2. Locate the Syslog - System Events section, and click the additional information arrow , if 
necessary.

3. Click one of the following options:

Enter an IP Address or 
Domain Name

Type in site IP Address or Domain Name.

Select a Function: Click an option:
•  Ping
•  DNS Get Address From Name
•  DNS Get Name From Address
•  MX Record Lookup
•  Trace Route
•  Bandwidth Test
•  Discover DHCP Servers
•  What is my External IP?
The results display in the space below.

Start Enter an IP Address and Port in the field provided to transmit the system events to a specified 
Syslog server.

setup Send automatic notification of selected system events. See page 193 for more information.

Prerequisites

Access Permissions Allworx Server Administrator
Allworx System Administrator
Phone Administrator Role
Network Administrator Role
Support Technician Role

Feature Key Required No
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54.3 Allworx Technical Support Server
Connect to the Allworx support server to enable Allworx Technical Support to access the Web Admin 
page.

1. Log in to the Allworx server admin page, and navigate to Maintenance > Tools.

2. Locate the Allworx Technical Support Server section, and click the additional information 
arrow , if necessary.

3. Enter the Support Server IP Address information in the field provided.

4. Click Connect to begin.

54.4 Advanced Troubleshooting
1. Log in to the Allworx server admin page, and navigate to Maintenance > Tools.

2. Locate the Advanced Troubleshooting section, and click the additional information arrow , 
if necessary.

3. Locate the appropriate section and click the additional information arrow , if necessary:

Setting Description

Advanced Diagnostic Logging
Only enable at the direction of Allworx Customer Support to assist support engineers in troubleshooting a problem.
Allworx server performance degrades when enabled.

Call Control
Backplane
Messages

Check the box to enable.

SIP Messages Check the box to enable.

Advanced Update the fields with the required information:
•  Module Name
•  Level Mask

Capture Enter a value in minutes (1 to 60) for the diagnostic messages.

Stop Ends the advanced diagnostic logging.

View Display the advanced diagnostic log in a separate browser window.

Delete Removes the advanced diagnostic log from the server.

Four Wire Return Less Measurements
A noise measurement defined for the LAN and associated components.

Capture While capture four wire return loss values, verify the analog CO lines are not active. Incoming or 
outgoing calls while the test is running causes the test to capture incorrect data. Click to start the 
test.

Refresh Resets the current page to check the Packet Capture Tool status when writing packets to the file.
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View Display the information log in a separate browser window.

Delete Removes the log from the server.

Network Address Translation (NAT) information
A method of modifying network address information in Internet Protocol (IP) datagram packet headers while it is in transit 
across a traffic routing device.

Capture Starts gathering the NAT information for the log.

View Display the NAT information log in a separate browser window.

Delete Removes the NAT log from the server.

Network Device Monitoring
Watching a computer network for slow or failing components.
Only enable at the direction of Allworx Customer Support to assist support engineers in troubleshooting a problem. Allworx 
server performance degrades when enabled.

Check All Selects all displayed devices for network device monitoring.

Uncheck All De-selects all displayed devices for network device monitoring.

<device> Check the box selects specific devices for network device monitoring.

Capture Enter a value in hours (0 to 99) for the network diagnostic monitoring. The value 0 hours indicates 
the network device monitoring is running continuously.

Open View the network device monitoring log.

Stop Ends the network device monitoring.

Delete Removes the Network Device Monitoring log from the server.

Packet Capture Tool
Intercept and log traffic passing over a digital network.
Only enable at the direction of Allworx Customer Support to assist support engineers in troubleshooting a problem. Allworx 
server performance degrades when enabled.

Network Interfaces Check the box to enable.
•  LAN Port Interfaces

•  LAN/untagged | Local Phones

•  WAN Port Interfaces

•  WAN/untagged | Local Phones

•  IP Addresses

•  Source IP Address - enter the address in the field provided.

•  Destination IP Address - enter the address in the field provided

Uncheck All De-selects all displayed devices for network device monitoring.

<device> Check the box selects specific devices for network device monitoring.

Capture Enter a value in minutes (0 to 60) for the network diagnostic monitoring. The value 0 minutes 
indicates the packet capture tool is running continuously.

Stop Ends the packet capture tool.

Open View the packet captures.

Refresh Resets the current page to check the Packet Capture Tool status when writing packets to the file.

Delete Removes the packet capture file from the server.

Setting Description
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Performance Monitoring
The Allworx server collects system performance data in the background, which may assist Allworx support engineers in 
troubleshooting a problem. Save the file to disk before making it available to download, in RRD format, which requires 
specialized tools to view. The performance monitoring data gathered before an Allworx server reboot persists after the Allworx 
server reboot.

Write Saves the system performance file to disk.

Open View the RRD system performance file.

Delete Removes the RRD system performance file from the server.

Telnet
Using one computer to log onto another computer that is part of the same network. Only Allworx 6x, 6x12, and 48x servers 
support Telnet.
Only enable at the direction of Allworx Customer Support to assist support engineers in troubleshooting a problem. Allworx 
server performance degrades when enabled.

Enable Telnet Click to Enable the Telnet. Enter a port that is not in use by another service on this server.

Disable Telnet Click to Disable the Telnet. Click Refresh to redisplay the page with Telenet disabled.

SSH
Using one computer to securely log onto another computer that is part of the same network.
NOTE: The Allworx System Software 8.0 and higher application does support a full pseudo-tty terminal. To avoid warnings in 
the SSH client, disable the pseudo-tty on the SSH client. When enabled, users see a warning message, but SSH is still 
operable.  Only Allworx Connect servers support Telnet.

Only enable at the direction of Allworx Customer Support to assist support engineers in troubleshooting a problem. Allworx 
server performance degrades when enabled.

Enable SSH Click to Enable the SSH. Enter a port that is not in use by another service on this server.

Disable SSH Click to Disable the SSH. Click Refresh to redisplay the page with SSH disabled.

Click here to return to the “Install Checklist” .

Setting Description
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Chapter 55 Update

Update supports upgrading the software version. 
The page displays the current software version 
number, build date, and indicates if there is a 
current software upgrade license feature key 
available on the Allworx server.

Before doing an upgrade, be aware that:
• Downgrading from one release to an 

earlier release results in undesirable 
behavior and is not supported.

• Allworx highly recommends running an OfficeSafe backup prior to the upgrade (see “Backup” on 
page 211.).

• View customers: Allworx highly recommends performing a backup of the View database prior to 
the upgrade (see the Allworx View Users Guide for more information).

• The upgrade requires a server restart. Since this causes disconnections and disruption of data, 
verify the system is idle (no phone or data users) when the upgrade is done. 

• After installing, close all browser windows and open a new browser window before proceeding. 
If there is a browser session open during the upgrade, the Allworx server admin page may not 
display properly. 

• See “Install and Configure the Allworx Server” on page 7 for supported web browsers.

To update the server:
1. Log in to the Allworx server admin page, and navigate to Maintenance > Update.

2. Click an update option.

Note: Upgrading from prior releases of the Allworx System Software to Release 8.1 requires installing a Software Upgrade 
Feature Key or that the server is in its initial software warranty period.

Note: Do not skip software releases to install Allworx System Software Release 8.1.For example, if upgrading from Release 
7.5 to 8.0, install 7.6, 7.7, 8.0, and finally Release 8.1.

Download update from 
web

The server determines if new software releases are available. If an upgrade is available, the option 
to install them is available. Select the software version, and then click Download Update.

Upload update 
from PC

1.  Navigate to the Allworx Partner Portal (www.allworxportal.com) and download the update file.
2.  Unzip the downloaded file.
3.  Click Choose file > Browse to navigate to the location of the Allworx System Software file.
4.  Select the file, and click Open. The Update page displays.
5.  Click the Load button. The page displays the current version of software and the software 

version of the file that was loaded on the system. A warning message displays for any 
inconsistencies such as:

•  update version is the same or lower than the current version.

•  update is for a different Allworx server model.

Prerequisites

Access Permissions Allworx Server Administrator
Allworx System Administrator
Phone Administrator Role
Network Administrator Role
Support Technician Role

Feature Key Required Yes

https://allworxportal.com/
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3. Select an option to activate the system software update.

Note: The first server restart after an upgrade can be slower due to upgrade processing.

Note: After installing, close all browser windows and open a new browser window before proceeding. If there is a browser 
session open during the upgrade, the Admin page may not display properly.

Activate Update 
Now

Update begins immediately.
1.  Click Activate Update Now.
2.  (optional) Check the Automatic Update box to update Allworx Phone firmware automatically. 
3.  Click Start Update.

Activate Update Later Schedule the update to begin at another time - up to one week later.
1.  Click Activate Update Later.
2.  (optional) Check the Automatic Update box to update Allworx Phone firmware automatically. 
3.  Select the date and time to begin the update, and then click Submit Schedule. The Update 

page displays with the scheduled date and time for the system software update.

Cancel Ends the update and returns to the main update screen.

Click here to return to the “Install Checklist” .
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Appendix A Abbreviations

Abbreviation Definition

BLF Busy Lamp Field

CDR Call Detail Record

CO Central Office

DHCP Dynamic Host Configuration Protocol

DID Direct Inward Dialing

DND Do Not Disturb

DNS Domain Name System

DOD Direct Outward Dialing

DTMF Dual Tone Multi-Frequency

FTP File Transfer Protocol

FXO Foreign Exchange Office

FSX Foreign Exchange Subscriber

HTTP Hypertext Transfer Protocol

HTTPS Hypertext Transfer Protocol Secure

IP Internet Protocol

ITSP Internet Telephony Service Provider

LAN Local Area Network

NAT Network Address Translation

PBX Private Branch Exchange

PFK Programmable Function Key

PoE Power Over Ethernet

POP Post Office Protocol

PPTP Point-to-Point Tunneling Protocol

RTP Real-time Transport Protocol

SIP Session Initiation Protocol

SMTP Simple Mail Transfer Protocol

SNTP Simple Network Time Protocol

TCP Transmission Control Protocol

UDP User Datagram Protocol

URI Uniform Resource Identifier

VLAN Virtual Local Area Network

VoIP Voice over Internet Protocol

WAN Wide Area Network
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